MustangForums.com

MustangForums.com (http://mustangforums.com/forum/index.php)
-   2005 - 2014 Mustangs (http://mustangforums.com/forum/2005-2014-mustangs-43/)
-   -   Everyone please VOTE!!!! All mustang owners HERE! (http://mustangforums.com/forum/2005-2014-mustangs/227768-everyone-please-vote-all-mustang-owners-here.html)

Juntech 01-07-2007 04:36 AM

Everyone please VOTE!!!! All mustang owners HERE!
 
Please VOTE!

Ok guys, i want to gauge the average # of problems in the S197. But i need alotta votes. Please contribute at least that. I've been seeing a lot of the same problems on all sorts of mustang boards. (Sqeeks, rattles, fuel system, electrical and the LEAK) I'm wondering if it's just the tiiiny percentage of actual owners posting or is it just about everyone.

If you want to add your year, engine and whatever else is related, feel free.

Thanks so much in advance. This poll will weigh heavily on whether or not i stroll into the dealerships and actually order within the next few weeks!!! :) (Thanks for putting up with my constant badgering and questions :D )

Skoshi42 01-07-2007 04:47 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Im tired of bringing it back into the dealer for false OBDII codes, so now all I do is reset my ECU by disconnecting my battery for 5 minutes and then reconnecting it... this is what my dealership does and not tell me, they say they fixed it and send me back home..

Edit:: I have no leak anywhere, i checked... dry as a bone.. so its just doing it on its own, pulling "ghost"codes..

FordDude 01-07-2007 05:36 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
But I only have 891 miles on my Mustang, and I have only had it less than 2 months. fd

shockme76 01-07-2007 05:47 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Problems i've had....

Had the fuel sender replaced. (i think that's what it's called) Anyway, it was the problem where i had about a quarter of a tank of gas left and the fuel guage would go to E and then come back up shortly after. Took it to the dealer and it was a known TSB. They fixed it and i've had to problems from that since.

Last week i had a very weird problem. I was getting off from work and got to my car and tried to unlock it with the key fob. It didn't work so i thought the battery in it was dead. So i unlocked it with the key, got in, and started it up. Next thing i know it beeps, all the guages go down, and it starts telling me fuel level low, oil pressure low, etc. It says to check the charging system. My head lights, internal lights, and radio were all flickering off and on. But the car was running and running fine. Luckily i don't live to far from work and was able to get home ok. Since i couldn't unlock it with the key fob it had to be something before i started it up. I don't know if it could've been moisture that got on something or what. It only did it that night and hasn't done it since.

Those are the only two problems i've had. The first one is fixed and hopefully the second one doesn't happen again. If it does i'll be back to the dealership.

howarmat 01-07-2007 06:18 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
E-brake is the only thing I had a problem with. Dealership fixed it and no problems since.

LegallyTorchRED 01-07-2007 06:23 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Go order one. Aren't ya tired of countin' ?????[sm=boosign.gif][sm=violin.gif][sm=closed.gif]

saltzy 01-07-2007 11:13 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Lame. Get a subscription to Consumer Reports, they've done this work for you already.

Heavyg72 01-07-2007 11:40 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
I've only had 2 TSB issues (grinding noise around slow corners and fuel pick-up issues after long runs) and the dealership fixed them with no questions asked....despite my mods. Other than that it has been great.


my77stang 01-07-2007 11:43 AM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
door mirrors rattle, seat lifter upper handle broke off in my hand, door panel pieces rattle (easy fix), and clutch pack in the rearend. also there have been several times it JUST WONT START and then after a few trys it does. dealer said they cant do anything because it didnt throw a code. theres 15,000 miles on ours right now, but all of these problems started at or around 5k

Juntech 01-07-2007 02:52 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Thanks for the vote guys, i will be picking up a Consumer Reports too. ANd it's always good to get real data from actual owners. ;)

RUFDRAFT 01-07-2007 03:06 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
3500 miles. No issues. It does, however, seem to be getting faster....

cheftjpeck 01-07-2007 03:14 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Quote:

ORIGINAL: RUFDRAFT

3500 miles. No issues. It does, however, seem to be getting faster....
or your foot is getting heavier....LOL ;)

cheftjpeck 01-07-2007 03:17 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
had window tint scratching (Fixed by dealer ) felt installed and window tint replaced by dealer
fuel PO8063 code.(or PO4063 code something like that...i forget)...had fuel sender replaced
has some squeaks and rattles in right front.....have not take it in for it YET....
other than that I love my stang

ANBAUTO 01-07-2007 04:14 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
When i first got mine i had the air bag light come on the day of picking it up. The sales manager got it to turn off some how then 2 days later it came on and would come on all the time. They finally had it for the week at the dealership and they had to replace the seats. Its all better now the only thing now is that it makes all kinds of squeaks but i just turn up the radio

BHRS 01-07-2007 04:32 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
I have not had any problems with the car so far. I have a little over 2000 miles on it and I am more happy with it now than when I picked her up. The only changes I have made was the installation of a single Magnaflow muffler and disconnecting/reconnecting the battery to reset the computer.

Luckily my car stays under cover at home and work so I have not seen any leak problems. I have washed her several times and made a point to put more water in the pass side windsheld area to see if it leaks-so far NO LEAKS.

Fourth Horseman 01-07-2007 04:51 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Only a little over 1000 miles on mine but so far so good. All of the little issues I might have run into (tint scratching, and freezing parking brake lines for example) I was able to avoid thanks to reading this forum. I have to say that my Mustang seems to be put together better with less little annoying issues than my 2003 Mercury was. Maybe quality is improving at Ford? Hope so. In any event, absolutely no complaints from me in my first 1000 miles on the GT.

s2k 01-07-2007 04:59 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Around the 900ish miles my E-brake light stayed on and also my T/C would notturn on but the dealer fixed it it was due to a "poor connection" but it was a quick fix and no problems since!

Rupp 01-07-2007 05:02 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
Quote:

ORIGINAL: Skoshi42

Im tired of bringing it back into the dealer for false OBDII codes, so now all I do is reset my ECU by disconnecting my battery for 5 minutes and then reconnecting it... this is what my dealership does and not tell me, they say they fixed it and send me back home..

Edit:: I have no leak anywhere, i checked... dry as a bone.. so its just doing it on its own, pulling "ghost"codes.. example video of it acting up with no problem what so ever...

http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=1 49397960
Have you moded your engine?

Riggs007 01-07-2007 05:25 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
fuel sender, thats it

Drivesthebeast 01-07-2007 06:02 PM

RE: Everyone please VOTE!!!! All mustang owners HERE!
 
The parking brake freezing problem, yet to be remedied...that was after a week of buying the car used from the local Ford Store.

Then, when I was on my christmas leave, I was going to go somewhere with my dad to help out with a friends car, and had started the car to warm it up, and go to the house to lock up. Come back out to get in the car, and the driver side door is locked. The passenger side is locked, and of course, the trunk is locked. This is all while the engine was running, and the stereo was going. I had to get a locksmith to come and unlock the car for me (which took him 90 mins!). I wasn't happy, as I was locked out of the car with it running, so as an "etiquette lesson", I switched off the TCS as soon as I got in the car, pulled out of the driveway, and scat the car almost sideways through 2 gears up the street, shifting at over 5000rpm. Had 2 cop cars roll down the street past my parents house about 15-20 mins later after I had returned and parked...

I also have some rattles from the passenger side of the car, I think it has to do with the window.

No leaks, no fuel delivery issues, no ignition issues.


All times are GMT -5. The time now is 05:39 AM.