Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Blinker/ tail light problems

Reply
 
 
 
 
Thread Tools Search this Thread
Old 11-03-2008, 05:41 PM   #1
urnamethere
2nd Gear Member
 
Join Date: Mar 2007
Location: san diego/orange county CA
Posts: 309
Send a message via AIM to urnamethere
Default Blinker/ tail light problems

so my right blinker started to blink really fast, i get out of the car to check and sure enough the one all the way on the right was not blinking only the one in the middle was blinking so i figured a bulb was blown, i went to the store to pick up a replacement. when i took off the tail light assembly i noticed the bulbs were not blown but replaced them anyways. now both of them dont blink or light up brighter when i step on the brakes, they do however come on when i turn on the lights. any one know what the problem could be?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
urnamethere is offline   Reply With Quote
Old 11-03-2008, 05:47 PM   #2
zporta
5th Gear Member
 
zporta's Avatar
 
Join Date: Jan 2008
Vehicle: 2007 Shelby GT500
Location: MD
Posts: 2,544
Default

check ur fuses
__________________
zporta is offline   Reply With Quote
Old 11-03-2008, 06:52 PM   #3
urnamethere
2nd Gear Member
 
Join Date: Mar 2007
Location: san diego/orange county CA
Posts: 309
Send a message via AIM to urnamethere
Default

i checked all the fuses the ones under the hood and the ones by the kicker panel, is there a way to check relays?
__________________
urnamethere is offline   Reply With Quote
Old 11-03-2008, 09:58 PM   #4
urnamethere
2nd Gear Member
 
Join Date: Mar 2007
Location: san diego/orange county CA
Posts: 309
Send a message via AIM to urnamethere
Default

ttt...
__________________
urnamethere is offline   Reply With Quote
Old 11-03-2008, 10:01 PM   #5
zporta
5th Gear Member
 
zporta's Avatar
 
Join Date: Jan 2008
Vehicle: 2007 Shelby GT500
Location: MD
Posts: 2,544
Default

well look in the manual and figure out what relay get a new one try it if it doesnt work return it...
__________________
zporta is offline   Reply With Quote
Old 11-04-2008, 09:38 AM   #6
d_ames117
2nd Gear Member
 
Join Date: Jun 2007
Posts: 368
Default

Did you get the right bulbs - i.e. do they have a major and minor filament? When you turn on the turn signal do the signal indicators on the dash still light up?

p.s. Love the sig!
__________________
'07 Vista Blue GT/CS
d_ames117 is offline   Reply With Quote
Old 06-24-2009, 12:17 PM   #7
Juntech
3rd Gear Member
 
Juntech's Avatar
 
Join Date: Jan 2006
Location: Boston
Posts: 571
Send a message via AIM to Juntech Send a message via Yahoo to Juntech
Default

Hey, i just got the same problem this morning. The right blinker was going a lot quicker. I thought it was because of the Diablosport Predator.

Is it because the bulb went out or the wiring?

I was thinking of getting sequential tailights, would that solve the problem while getting a cool look at the same time...kill two birds with a giant rock?

Thanks,
-Jun-
__________________
2012 Boss 302. Competition OJ
Juntech is offline   Reply With Quote
Old 06-24-2009, 12:19 PM   #8
cavediver
3rd Gear Member
 
cavediver's Avatar
 
Join Date: Sep 2007
Vehicle: 2007 Mustang GT
Location: Lake County, Florida
Posts: 553
Default

Quote:
Originally Posted by d_ames117 View Post
Did you get the right bulbs - i.e. do they have a major and minor filament? When you turn on the turn signal do the signal indicators on the dash still light up?

p.s. Love the sig!

I agree, check to make sure you have the correct bulbs!
__________________
2007 Mustang GT Premium
5-speed manual w/ Hurst Competition Plus Shifter
Redfire w/ Charcoal Leather Interior
GT Appearance Pkg w/ Interior Upgrade Pkg
18" Polished Fan Blade Wheels
Airaid CAI w/ FRPP Tune
Roush Lowering Springs
cavediver is offline   Reply With Quote
Old 06-24-2009, 12:32 PM   #9
siberian.mist
4th Gear Member
 
Join Date: Apr 2008
Location: mn
Posts: 1,132
Default

my bulb was out for like 2 days(was also blinking fast), took it to dealer under warranty, and the bulb started working again(they never even replaced it) no problems since.
__________________
siberian.mist is offline   Reply With Quote
Old 06-24-2009, 03:41 PM   #10
cavediver
3rd Gear Member
 
cavediver's Avatar
 
Join Date: Sep 2007
Vehicle: 2007 Mustang GT
Location: Lake County, Florida
Posts: 553
Default

Quote:
Originally Posted by siberian.mist View Post
my bulb was out for like 2 days(was also blinking fast), took it to dealer under warranty, and the bulb started working again(they never even replaced it) no problems since.

Sometimes resolving issues is all about having good karma
__________________
2007 Mustang GT Premium
5-speed manual w/ Hurst Competition Plus Shifter
Redfire w/ Charcoal Leather Interior
GT Appearance Pkg w/ Interior Upgrade Pkg
18" Polished Fan Blade Wheels
Airaid CAI w/ FRPP Tune
Roush Lowering Springs
cavediver is offline   Reply With Quote
Old 06-24-2009, 03:52 PM   #11
Margarita Girl
Is the tide gonna reach my chair?
 
Margarita Girl's Avatar
 
Join Date: Mar 2007
Vehicle: 05 GT Vert
Location: Nor'east
Posts: 4,389
Default

I thought that when a blinker flashed double it meant that one of the bulbs is out. Possible it is the front turn signal?

Other than that, if the replacement bulbs aren't drawing the same amount of power the sensor may still think that one is out?
__________________

Mustang Ladies Club


Sidewayz 6.0 won me in a poker game
Margarita Girl is offline   Reply With Quote
Old 06-25-2009, 07:36 PM   #12
Juntech
3rd Gear Member
 
Juntech's Avatar
 
Join Date: Jan 2006
Location: Boston
Posts: 571
Send a message via AIM to Juntech Send a message via Yahoo to Juntech
Default

I just got some Sylvania replacement bulbs from Autozone today. Put those puppies in there, and guess what, chill blink is BACK!

So the problem is the bulb going out.

It's a super easy fix and the bulbs were only $5 from Autozone (part #4057).

Any idea what the black rubbery stuff is between the 3 nuts holding the taillight assembly and the chassis is?
__________________
2012 Boss 302. Competition OJ
Juntech is offline   Reply With Quote
Old 06-26-2009, 09:52 AM   #13
157dB
Cut & Paste Expert
 
157dB's Avatar
 
Join Date: May 2007
Vehicle: 2007 Pony Package
Location: NW Arkansas
Posts: 13,322
Default

Quote:
Originally Posted by Juntech View Post
Hey, i just got the same problem this morning. The right blinker was going a lot quicker. I thought it was because of the Diablosport Predator.
Is it because the bulb went out or the wiring?
I was thinking of getting sequential tailights, would that solve the problem while getting a cool look at the same time...kill two birds with a giant rock?
Thanks,
-Jun-
Fix the problem, then get sequentials or the problem will still be there.

Quote:
Originally Posted by zporta View Post
well look in the manual and figure out what relay get a new one try it if it doesnt work return it...
There is no relay persay.
Its probably a wet SmartJunctinBox under the dash.

Quote:
Originally Posted by Juntech View Post
I just got some Sylvania replacement bulbs from Autozone today. Put those puppies in there, and guess what, chill blink is BACK!

So the problem is the bulb going out.

It's a super easy fix and the bulbs were only $5 from Autozone (part #4057).

Any idea what the black rubbery stuff is between the 3 nuts holding the taillight assembly and the chassis is?
Mastic sealant.
__________________
NON PUMKIN JACKER
http://www.mustangforums.com/forum/5...-this-car.html
Quote:
Originally Posted by chronos View Post
You and that darn manual! If you like it so much, maybe you should marry it!
157dB is offline   Reply With Quote
Old 10-26-2009, 12:38 AM   #14
arrjay
1st Gear Member
 
arrjay's Avatar
 
Join Date: Nov 2008
Vehicle: 2008, Ford, Mustang V6
Location: Ca
Posts: 70
Default

Hey bro. ive just rece4ntly seen your mustang. your using a gt front bumper, and a lip? or is that the original v6 front. can you send pics to my profile or fbersalona@yahoo.com. i want to see your car.
arrjay is offline   Reply With Quote
Old 10-26-2009, 12:38 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
05, 2007, blinker, blinking, blinks, edge, fast, flashing, ford, light, lights, mustang, problems, quicker, started, tail

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
s197 W/ 110,000 Miles - What Will Break? wasvette 2005 - 2014 Mustangs 73 10-17-2008 10:26 PM

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 02:20 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup