Search



Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search

2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by Latemodel Restoration


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-12-2012, 06:10 AM   #1
MADSCOTSMAN
2nd Gear Member
 
MADSCOTSMAN's Avatar
 
Join Date: May 2008
Vehicle: 2013 Mustang GT
Location: Indiana
Posts: 272
Default Seat back release lever

So the one on the back of my passenger seat didn't break off, but it suddenly (yesterday) no longer releases the seat back. I never heard any pop or anything. It worked one day then not the next. It moves freely up and down with the same "resistance" it had before, but does not engage whatever the mechanism is, that allows the seat back to be moved. I use this daily when I get my son from school. Has anyone had this happen and been able to fix it themself? I 've looked through all the online shop manuals that I have found, and also looked at any directions that show replacing the broken handles i could find, but cant find any information on how to look at the mechanism in the seat itself, or how it attaches to the arm/lever. I'm going to try to take the one screw off that holds the trim peice on, and then try popping the handle itself off this afternoon, but am worried that this fix may require removing the top seat cover?? Any suggestions/experiences would be greatly appreciated...
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
MADSCOTSMAN is offline   Reply With Quote
Old 04-12-2012, 07:19 AM   #2
wkayl
1st Gear Member
 
Join Date: Oct 2008
Vehicle: 2013 Mustang GT Premium Convertible
Location: Colorado
Posts: 115
Default

When I bought my 2011 it did not work (car was used with 19,000 miles). Dealer replaced the cable, said it would have cost about $400 if it had not been under warrenty.
wkayl is offline   Reply With Quote
Old 04-12-2012, 07:19 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
2005, 2009, back, broke, cable, lever, mechanism, mustang, pic, ralease, release, replace, s197, seat, seatback, upper

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 10:16 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup