Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by Latemodel Restoration


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-14-2012, 08:43 PM   #1
ricstr03
 
Join Date: May 2012
Vehicle: 2008 mustang gt
Location: texas
Posts: 3
Default 08 mustang gt stalling

I have an 2008 mustang gt, stalls on take off, but once past 3 grams she is off like a rocket, and also sometimes she cuts out, while i'm driving, i have done everything to try to figue this crap out, plus i'm getting terrible gas mileage, 230 miles to a tank, thats with 93 octane, i have changed out TB, changed out the mass flow air sensor, new plugs and boots, MSD boots, so i am putting top of the line into my stang, I have k& n CAI, performance pulleys, 62mm ford racing Throttle Body, SCT programmer, bigger throttle body custom tune on my tuner, someone even told me to change out the 02 sensors, did that too, just freak'n frustrating to put all this money out and no changes, if anybody has any ideas, let me know, thanks, oh yea, another thing, sometimes she don't want to start on first try....just had to throw that in there...thanks
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
ricstr03 is offline   Reply With Quote
Old 05-14-2012, 09:00 PM   #2
waykooljr
3rd Gear Member
 
waykooljr's Avatar
 
Join Date: Jun 2006
Vehicle: 2006 Mustang GT
Location: Texas
Posts: 503
Default

Have you changed the fuel filter?
__________________
waykooljr is offline   Reply With Quote
Old 05-15-2012, 10:53 AM   #3
kevinmalec
5th Gear Member
 
kevinmalec's Avatar
 
Join Date: Apr 2008
Vehicle: 2005 Ford Mustang
Location: Acworth, GA
Posts: 3,633
Default

Sorry to hear the issues you are experiencing....
Have you checked to make sure your ground wire is not loose in your engine compartment? Ground wires are located in front of the washer fluid resevoir.
Also, have you tested your battery and alternator?
In addition to the fuel filter (mentioned above), maybe a bad fuel pump or gunked up fuel lines.
__________________


- 2005, 4.0 - Missing 2 cylinders :-/
- SCT Xcal3 w/ Brenspeed Custom Tunes
- Airaid CAI
- Pypes Streetpro Exhaust
- AM Front Chin Spoiler
- AM Quarter window louvers
- SHR honeycomb decklid panel
- Cobra R wheels
- Eibach Pro-Kit lowering springs
- Billet Honeycomb Chrome Front Grille Overlay
- Smoked tail lights & turn signals, Mustang 3rd brake light decal
- Raxiom sequential tail light kit

Last edited by kevinmalec; 05-15-2012 at 11:01 AM.
kevinmalec is offline   Reply With Quote
Old 05-15-2012, 06:33 PM   #4
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Vehicle: 2007 GT
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,020
Send a message via AIM to Nuke Send a message via Yahoo to Nuke Send a message via Skype™ to Nuke
Default

Some of the mods you've installed have been related to poor performance and idle issues, mainly the TB and the COPs. I'd probably go back as close to stock as possible and begin from there. Yeah, I mean stock tune and airbox, too. If it still stumbles then you know it wasn't your mods.
__________________
Rick
07 GT Prem: Alloy, MT, 3.55's, Steeda CAI w/Brenspeed tunes, FRPP Stingers, 275/40/18 Goodyear Eagle F1 A/S on SVT Cobras (OE GT500's), 14" shorty, Wheelskin side scoops & qtr window louvers, A-H rear window louvers, SHR honeycomb blackout panel, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
06 V6: Legend Lime, Pony Package, 14" shorty, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
Nuke is offline   Reply With Quote
Old 05-15-2012, 06:47 PM   #5
SpartaPerformance
4th Gear Member
 
SpartaPerformance's Avatar
 
Join Date: Apr 2010
Vehicle: 2007 Ford Mustang GT
Location: Long Island, New York
Posts: 1,275
Default

No codes? When did it start, was after a performance tune?
SpartaPerformance is offline   Reply With Quote
Old 01-03-2013, 08:25 AM   #6
ricstr03
 
Join Date: May 2012
Vehicle: 2008 mustang gt
Location: texas
Posts: 3
Default

yes, I changed the filter, very first thing I've done
ricstr03 is offline   Reply With Quote
Old 01-03-2013, 08:29 AM   #7
ricstr03
 
Join Date: May 2012
Vehicle: 2008 mustang gt
Location: texas
Posts: 3
Default

its weird that you had post this, cuz now I am having electrical issues, went through 4 alternators so far, battery light is coming on at start but once I drive a few miles battery light goes off, I am going to check ground in the morning, is there more than that one ground that you described?
ricstr03 is offline   Reply With Quote
Old 01-03-2013, 09:33 AM   #8
waykooljr
3rd Gear Member
 
waykooljr's Avatar
 
Join Date: Jun 2006
Vehicle: 2006 Mustang GT
Location: Texas
Posts: 503
Default

Holy thread revival!

Check your throttle body too, it may need a cleaning.
__________________
waykooljr is offline   Reply With Quote
Old 01-03-2013, 10:06 AM   #9
moosestang
6th Gear Member
 
Join Date: Sep 2006
Vehicle: 2006 mustang gt
Location: Gainesville, FL
Posts: 11,270
Default

4 alternators? Where are you getting these alternators? I would only trust a PA performance alternator from amercian muscle. All the ones you get from autozone or discount auto are remanufactured stock alternators, which we all know suck!

Is this an auto or manual? Where did you get the replacement MAF sensor? Unless you got it from Ford, I'd go back to your stock one. Odds are there was nothing wrong with the stocker, but the ones on ebay or from autozone are junk.

I agree with going back to stock to rule out the tune. Who's tune, amercian muscle, brenspeed?

There is an engine ground at the top/middle of the firewall.

Under drive pulleys are probably responsible for your battery light and maybe your alternator problems. Not a big fan of under drive or over drive pulleys.
__________________
Boost or Buell, decisions, decisions.

whipple HO SC,FRPP k springs, Pypes mid mufflers, hurst, frpp TB, 4.10's, spohn lca's, adj. UCA, relo brackets, 1 piece DS, spec stg 3+ clutch. 12.52@117.6mph so far with a 2.01 60 ft time

Pumpkin jacking addict

Last edited by moosestang; 01-03-2013 at 10:11 AM.
moosestang is offline   Reply With Quote
Old 01-03-2013, 10:12 AM   #10
moosestang
6th Gear Member
 
Join Date: Sep 2006
Vehicle: 2006 mustang gt
Location: Gainesville, FL
Posts: 11,270
Default

What spark plugs?
__________________
Boost or Buell, decisions, decisions.

whipple HO SC,FRPP k springs, Pypes mid mufflers, hurst, frpp TB, 4.10's, spohn lca's, adj. UCA, relo brackets, 1 piece DS, spec stg 3+ clutch. 12.52@117.6mph so far with a 2.01 60 ft time

Pumpkin jacking addict
moosestang is offline   Reply With Quote
Old 01-03-2013, 10:12 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
05, 08, 2005, 2008, cut, ford, forum, gt, mustang, stall, stalling, stalls, start, takeoff, v6, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:56 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup