Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by Latemodel Restoration


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-26-2013, 11:50 PM   #1
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Vehicle: 2013 GTHG Ford Mustang
Location: WA
Posts: 863
Default Strange screeching sound from front wheel?

So we were getting ready to head out to a car show when my wives 2013 V6 Vert made a horrific screeching sound from one of its front wheels. Kind of sounded like wet breaks only it was 60 sunny and dry. Had her slam the breaks harder and it stopped. I am thinking the caliper stuck maybe? Anyone else got any ideas or should I just have Ford take a look at her? Cars only got 1,670 miles on it.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
DocSnickers is offline   Reply With Quote
Old 04-27-2013, 07:36 AM   #2
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Vehicle: 2007 GT
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,020
Send a message via AIM to Nuke Send a message via Yahoo to Nuke Send a message via Skype™ to Nuke
Default

Either brakes (caliper or pads) or a bearing. I doubt it's a bearing. Unless it's just something jammed in between the pad and rotor.
__________________
Rick
07 GT Prem: Alloy, MT, 3.55's, Steeda CAI w/Brenspeed tunes, FRPP Stingers, 275/40/18 Goodyear Eagle F1 A/S on SVT Cobras (OE GT500's), 14" shorty, Wheelskin side scoops & qtr window louvers, A-H rear window louvers, SHR honeycomb blackout panel, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
06 V6: Legend Lime, Pony Package, 14" shorty, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
Nuke is offline   Reply With Quote
Old 04-27-2013, 11:14 AM   #3
Simon1
5th Gear Member
 
Join Date: Dec 2006
Vehicle: 2006 Mustang GT
Location: Redding, CA
Posts: 4,232
Default

I say there is something stuck in there. It happens to me when I'm hunting and it is usually stuck between the dust cover and rotor.
Simon1 is offline   Reply With Quote
Old 04-27-2013, 12:16 PM   #4
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Vehicle: 2013 GTHG Ford Mustang
Location: WA
Posts: 863
Default

Haven't pulled apart any breaks newer than 72.... Any advice on checking for anything in there?
DocSnickers is offline   Reply With Quote
Old 04-27-2013, 01:06 PM   #5
Cristoff
2nd Gear Member
 
Cristoff's Avatar
 
Join Date: May 2012
Vehicle: 2013 GT / California Special Edition
Location: California
Posts: 232
Default

Sounds like a pebble got lodged up in there and when she hard stopped it broke loose.

You can have someone look at it for any damage, but it doesn't sound all that serious to me.
Cristoff is offline   Reply With Quote
Old 04-27-2013, 03:18 PM   #6
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Vehicle: 2013 GTHG Ford Mustang
Location: WA
Posts: 863
Default

Yeah I got out there this morning and looked it over everything looks fine. Took it around the block giving it break test at different speeds no issues. Thanks for the reply's everyone.
DocSnickers is offline   Reply With Quote
Old 04-30-2013, 02:14 PM   #7
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Vehicle: Mustangs
Location: MI
Posts: 801
facebook.com/FordMustang @FordService
Default

Quote:
Originally Posted by DocSnickers View Post
So we were getting ready to head out to a car show when my wives 2013 V6 Vert made a horrific screeching sound from one of its front wheels. Kind of sounded like wet breaks only it was 60 sunny and dry. Had her slam the breaks harder and it stopped. I am thinking the caliper stuck maybe? Anyone else got any ideas or should I just have Ford take a look at her? Cars only got 1,670 miles on it.
Hello DocSnickers,

I’d like to get this escalated to the customer service manager of your area. Please, make an appointment to have it checked out. Then, PM me with your VIN, dealer, mileage, full name, and best daytime number so I can help.

Deysha
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordMustang @Ford
f: facebook.com/FordMustang facebook.com/Ford
FordService is online now   Reply With Quote
Old 04-30-2013, 02:14 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:25 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup