P2198 and a poor idle - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 05-06-2013, 03:07 PM   #1
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default P2198 and a poor idle

So yesterday I threw a code for the O2 stuck rich after my 35 mile drive to work and I noticed it had been wanting to die when coming to a stop (going to about 500rpm and saving itself). I have had a exhaust leak from the passenger bank (same bank) FRPP header for some time. I am thinking that the leak is causing this issue and that it is also screwing with my tune causing the idle to come down like that. When the leak first started it would idle down to around 500 once in a blue moon and I am suspecting that it getting worse is what is causing the problems. Just wondering if anyone has had a similar situation since all the P2198's I've seen have been leaks somewhere else or both codes and I haven't seen one on a blown motor yet.

I will be attempting to retighten the header bolts after work tonight to see if that could possibly solve my problems (with my luck I doubt I fix anything without at least one part though) and going from there.

Any input is appreciated. Also, please keep your fingers crossed for me... haha



EDIT: I guess I should mention that I did an oil change, coolant flush, and put in RP Max ATF (manual) all on Saturday and then sprayed the engine bay down with some degreaser and water and gave her a wash and wax. Irrelevant I would think but I'm used to working in a Toyota Dealer and not Ford so my knowledge for common problems and quirks with my Stang is very limited right now.

Last edited by TheStigSC; 05-06-2013 at 03:13 PM.
TheStigSC is offline   Reply With Quote
Old 05-06-2013, 03:23 PM   #2
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Location: WA
Posts: 863
Default

Water should not really hurt anything unless your just soaking the top of the engine with a hose like your watering flowers.
DocSnickers is offline   Reply With Quote
Old 05-06-2013, 03:33 PM   #3
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default

Quote:
Originally Posted by DocSnickers View Post
Water should not really hurt anything unless your just soaking the top of the engine with a hose like your watering flowers.
Yea in my experience it never has but you never know and I need her to be in tip top shape by next Wednesday so I'm just kinda freaking out haha.


Car's mod list is in my sig. Currently at 46,000 miles.
TheStigSC is offline   Reply With Quote
Old 05-07-2013, 09:20 AM   #4
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default

Well problem seems to be resolved. I don't even want to say what the issue was but, the Air Filter fell off. I'm guessing sometime mid-drive on my way to work. Completely baffled as to how it happened without me noticing. It was there Saturday after I did all that work and it wasn't even touched. That's embarrassing but hey, $h!t happens. That's why there's a screen behind the filter At least it was an easy fix so she'll be ready for Cruisin' Weekend in OCMD.

I reflashed the tune anyway and got a new Spectre cone filter and she's running good as new. I did tighten up some of the bolts on the passenger side header that were slightly loose and it quieted up a tiny bit, but the leak is still there. But that is for another day
TheStigSC is offline   Reply With Quote
Old 05-07-2013, 10:16 AM   #5
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Location: WA
Posts: 863
Default

Well that would do it, air filter not being on caused a huge air flow issue and threw that code. Still odd they don't really ever come off.
DocSnickers is offline   Reply With Quote
Old 05-07-2013, 01:07 PM   #6
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default

Quote:
Originally Posted by DocSnickers View Post
Well that would do it, air filter not being on caused a huge air flow issue and threw that code. Still odd they don't really ever come off.
Yea and I mean this thing was on tight. Before I RETIGHTENED it, I was pulling on it with probably almost half of my 235lb body weight and it wasn't budging. Mind boggling. Needless to say she got tightened down even tighter haha
TheStigSC is offline   Reply With Quote
Old 05-07-2013, 01:13 PM   #7
moosestang
6th Gear Member
 
Join Date: Sep 2006
Location: Gainesville, FL
Posts: 11,278
Default

You have a screen behind your air filter? Is that part of the kenne bell kit?
moosestang is offline   Reply With Quote
Old 05-07-2013, 01:55 PM   #8
Lifter583
4th Gear Member
 
Lifter583's Avatar
 
Join Date: Apr 2008
Location: North Idaho
Posts: 1,440
Default

Quote:
Originally Posted by TheStigSC View Post
So yesterday I threw a code for the O2 stuck rich after my 35 mile drive to work and I noticed it had been wanting to die when coming to a stop (going to about 500rpm and saving itself). I have had a exhaust leak from the passenger bank (same bank) FRPP header for some time. I am thinking that the leak is causing this issue and that it is also screwing with my tune causing the idle to come down like that. When the leak first started it would idle down to around 500 once in a blue moon and I am suspecting that it getting worse is what is causing the problems. Just wondering if anyone has had a similar situation since all the P2198's I've seen have been leaks somewhere else or both codes and I haven't seen one on a blown motor yet.

I will be attempting to retighten the header bolts after work tonight to see if that could possibly solve my problems (with my luck I doubt I fix anything without at least one part though) and going from there.

Any input is appreciated. Also, please keep your fingers crossed for me... haha



EDIT: I guess I should mention that I did an oil change, coolant flush, and put in RP Max ATF (manual) all on Saturday and then sprayed the engine bay down with some degreaser and water and gave her a wash and wax. Irrelevant I would think but I'm used to working in a Toyota Dealer and not Ford so my knowledge for common problems and quirks with my Stang is very limited right now.
Might want to pull that header and double gasket it...wont leak again for sure, probably has a bit of a warp to it.
Lifter583 is offline   Reply With Quote
Old 05-07-2013, 02:49 PM   #9
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default

Quote:
Originally Posted by moosestang View Post
You have a screen behind your air filter? Is that part of the kenne bell kit?
Yea it is. Right before the MAF. The filter gets tightened onto the screen.
TheStigSC is offline   Reply With Quote
Old 05-07-2013, 02:50 PM   #10
TheStigSC
2nd Gear Member
Thread Starter
 
TheStigSC's Avatar
 
Join Date: Jan 2013
Location: Maryland
Posts: 287
Default

Quote:
Originally Posted by Lifter583 View Post
Might want to pull that header and double gasket it...wont leak again for sure, probably has a bit of a warp to it.
Is that what people are doing to fix the header leaks? Or at least with the FRPP shorties? I bought the replacement gaskets but really don't want to go through the install process (at least not now while I'm so busy---I don't like working on my car when I'm stressed haha)
TheStigSC is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
website issues rgingo Forum Issues and Feedback 3 10-21-2015 12:49 PM
TNT, New PB TCStangerv6 Street/Strip 12 10-11-2015 05:57 PM
Starting Issue svfetter 5.0L (1979-1995) Mustang 9 10-05-2015 11:39 AM
Rough idle and vibrating 4cylinderplus2 V6 (1994-2004) Mustangs 9 09-30-2015 05:26 PM
91 vert tailpipe smoking MacSerio 5.0L (1979-1995) Mustang 3 09-27-2015 01:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:46 PM.