MustangForums.com

MustangForums.com (http://mustangforums.com/forum/index.php)
-   2005 - 2014 Mustangs (http://mustangforums.com/forum/2005-2014-mustangs-43/)
-   -   2013 Mustang GT Turn Signals (http://mustangforums.com/forum/2005-2014-mustangs/698168-2013-mustang-gt-turn-signals.html)

Black Beauty 09 07-15-2013 02:27 PM

2013 Mustang GT Turn Signals
 
2013 Mustang GT has 7444NA listed as the bulb size for the turn signals. It seems I am unable to find those exact size. I find lots of 7443, but no 7444.

What I want to do is this:
7444 Xenon Chrome/Amber Bulbs for 13'

^The problem is that the reviews say they are not the right ones and I am unable to find any others.

I want to go with the "stealth" bulb look (basically chrome silver off, turns on amber). It seems like a simple swap, just need to find the right bulbs. Any help would be appreciated. Thanks in advance gents.

From my understanding the bulbs I want to replace are not LED, but of that I am unsure.

Black Beauty 09 07-15-2013 04:24 PM

http://www.ebay.com/itm/7443-Stealth...-/180844123461

I am thinking those might work^

DocSnickers 07-15-2013 04:30 PM

They still might be to new to get outside of the dealership. Try your dealerships parts store.

Black Beauty 09 07-15-2013 05:19 PM

Quote:

Originally Posted by DocSnickers (Post 8248442)
They still might be to new to get outside of the dealership. Try your dealerships parts store.

Tried them. They told me that they only sell the replacement bulb. The guy said the fitment was 7444NA, which I have been unable to find really.

DocSnickers 07-15-2013 05:44 PM

Oh I misread it looks like. You're trying to get the LED lights into the 09 model?

Black Beauty 09 07-15-2013 05:50 PM

Quote:

Originally Posted by DocSnickers (Post 8248480)
Oh I misread it looks like. You're trying to get the LED lights into the 09 model?

I am trying to get rid of the amber bulb in the 2013 turn signal. I have a 2013 Mustang GT.
This:
http://www.stangmods.com/v/vspfiles/photos/2439-3.jpg
To this:
http://www.stangmods.com/v/vspfiles/photos/2439-4.jpg

Black Beauty 09 07-15-2013 10:06 PM

I am going to head down to Autozone tomorrow and see what I can find out. The manual says 7444NA, websites say 7443 work though. But I don't believe the stock are LED.

BeachBlv 07-16-2013 12:21 PM

I just installed the chrome amber 7440 bulbs from auto illumination yesterday. I stopped by both oriellys and autozone and they did not have the bulbs so I had to order them. They were $11 plus shipping and they work and look just like the picture you posted.

http://autolumination.com/7443_7440.htm

Click on that link and its is the 6th bulb up from the bottom of the page. The chrome 7440s

Black Beauty 09 07-23-2013 12:49 PM

Quote:

Originally Posted by BeachBlv (Post 8248898)
I just installed the chrome amber 7440 bulbs from auto illumination yesterday. I stopped by both oriellys and autozone and they did not have the bulbs so I had to order them. They were $11 plus shipping and they work and look just like the picture you posted.

http://autolumination.com/7443_7440.htm

Click on that link and its is the 6th bulb up from the bottom of the page. The chrome 7440s

I will try them. I ordered some 7443s cause many people said they worked, but they just would not fit in the plugs. I will let you know how I make out! Thanks.

Black Beauty 09 07-31-2013 04:24 PM

https://fbcdn-sphotos-e-a.akamaihd.n...28820647_o.jpg

^Done! And it looks great! Thanks BeachBlv


All times are GMT -5. The time now is 01:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.