Fuel/temp/batt gauges not working - MustangForums.com


2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-26-2014, 02:08 PM   #1
05StangZz
1st Gear Member
Thread Starter
 
05StangZz's Avatar
 
Join Date: Mar 2011
Location: New Hampshire
Posts: 97
Default Fuel/temp/batt gauges not working

I did a search but wasnt very successful. I noticed the three gauges not working after i attempted to jump my stang but ended up buying a new battery.
Is there a fuse for these or is it more likely the 'stepper motors'? failing ?
And if so, how hard is it to replace?
A link to a how to guide and where to buy the cluster would be aweseomly appreciated
Thanks guys
05StangZz is offline   Reply With Quote
Old 07-26-2014, 05:10 PM   #2
Lethaldosage423
4th Gear Member
 
Lethaldosage423's Avatar
 
Join Date: Apr 2008
Location: Southern California
Posts: 1,632
Default

pretty common for the stepper motors to go bad. i actually made a how to but it never got stickyed. ill try to find the link for you.

are they just totally inop? or are they like way off where they should be? The issue with my 05 was the oil pressure gauge was completely opposite (facing up) so i replaced all of them with ones off ebay
Lethaldosage423 is offline   Reply With Quote
Old 07-26-2014, 05:38 PM   #3
Lethaldosage423
4th Gear Member
 
Lethaldosage423's Avatar
 
Join Date: Apr 2008
Location: Southern California
Posts: 1,632
Default

Lethaldosage423 is offline   Reply With Quote
Old 07-26-2014, 05:51 PM   #4
05StangZz
1st Gear Member
Thread Starter
 
05StangZz's Avatar
 
Join Date: Mar 2011
Location: New Hampshire
Posts: 97
Default

Yeah they are not moving what so ever. Thanks for the link!
05StangZz is offline   Reply With Quote
Old 07-28-2014, 10:32 AM   #5
kevinmalec
5th Gear Member
 
kevinmalec's Avatar
 
Join Date: Apr 2008
Location: Acworth, GA
Posts: 3,641
Default

Yeah, stepper motors are known to go out in the 2005 models.
My RPM gauge is off by 300 RPM, my coolant temp gauge works ONLY if it is 65 degrees or warmer. My gas gauge intermittently is off by a quarter of a tank.
Thankfully, no issues with my speedometer gauge (knock on wood).
kevinmalec is offline   Reply With Quote
Old 07-28-2014, 11:10 AM   #6
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Not sure how you could do a search and not come up with any hits for this chronic issue on the 05's and early 06's. But glad you asked and got your answer.
Nuke is offline   Reply With Quote
Old 07-28-2014, 11:21 AM   #7
kevinmalec
5th Gear Member
 
kevinmalec's Avatar
 
Join Date: Apr 2008
Location: Acworth, GA
Posts: 3,641
Default

I've read it's kind of a pain to replace out the stepper motors. Plus, you will need a soldering gun in order to fix them. There are companies that offer this type of service.
FYI, On Craigslist, I located a local businesses that specializes in replacing stepper motors.

Last edited by kevinmalec; 07-28-2014 at 11:24 AM.
kevinmalec is offline   Reply With Quote
Old 07-28-2014, 04:41 PM   #8
05StangZz
1st Gear Member
Thread Starter
 
05StangZz's Avatar
 
Join Date: Mar 2011
Location: New Hampshire
Posts: 97
Default

Yeah Nuke I dunno man. I always have bad luck with my thread searches on here. *Shrug*
Kevinmalic thanks for reminding me about CL... I try to avoid the site and forgot about it lol. I do not think i have the patience to do the stepper motors myself so I def would love to find someone local.
05StangZz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wheel Question! (New member, hi folks) Tivo304 New Member Area 4 12-05-2015 09:46 PM
Weird electrical/battery issue?? Mobiusone stang 2005-2014 Mustangs 7 09-07-2015 09:46 PM
First Mustang 99' 3 differnt body kits installed TimeLord101 New Member Area 3 09-04-2015 10:27 AM
HELP.. Should I buy this fox? raleigh05GTO New Member Area 5 09-04-2015 08:09 AM
Help! Metra 70-5521 AMP Harness Install cbird1177711 2005-2014 Mustangs 2 09-03-2015 09:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:15 PM.