Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by Latemodel Restoration


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 11-17-2014, 09:42 PM   #1
krazykevin
2nd Gear Member
 
krazykevin's Avatar
 
Join Date: Jan 2013
Vehicle: 2005, Ford, Mustang GT
Location: LA
Posts: 310
krazykevin
Default HVAC **** not working

I have a 2006 GT and the HVAC know that lets you choose between max, panel, floor, floor and defrost, or defrost is acting up. Sometimes it seems like turning it has no effect on where the air comes our but normally will work after switching it around a few times. Has anyone delt with this ?

Know what part is messed up in the system ?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
krazykevin is offline   Reply With Quote
Old 11-19-2014, 02:44 PM   #2
krazykevin
2nd Gear Member
 
krazykevin's Avatar
 
Join Date: Jan 2013
Vehicle: 2005, Ford, Mustang GT
Location: LA
Posts: 310
krazykevin
Default

Anyone ?
__________________


New:
2006 GT, Redfire
Steeda Sports, Koni's, LCA, Relo Brackets, Off-Road H, Tuned
RIP:
2005 GT, Mineral Grey
krazykevin is offline   Reply With Quote
Old 11-19-2014, 06:49 PM   #3
SteveDwsn
1st Gear Member
 
SteveDwsn's Avatar
 
Join Date: Mar 2011
Vehicle: '06 Pony Convertible
Location: Mid TN
Posts: 62
Default

Make sure the electrical connector is fully plugged in and not corroded. The switch could be bad.
__________________
'06 Mustang Pony Convertible
'00 F150 Super Cab 4X4
'05 Escape Limited
-- Wasn't planned, but I'm not complaining.
SteveDwsn is offline   Reply With Quote
Old 11-19-2014, 07:53 PM   #4
edwin108
2nd Gear Member
 
edwin108's Avatar
 
Join Date: Dec 2009
Vehicle: 2010 GT
Location: New Jersey
Posts: 277
shlbygt500 shlbygt500
Default

Do you hear any clicking/grinding noises from behind the dash when it doesn't change modes? You could have one (or a few) bad blend door actuators.
__________________
2010 Mustang GT Premium Grabber Blue / 4.6L 3V / 5MT / 401A / Security / HID / Comfort / TrackPack / 3.73
Ford Racing Hot Rod Cams / Steeda CAI / Steeda CMDPs / Bama Tunes / UPR Oil Catch Can / Shaftmasters 3.5" Aluminum DS

edwin108 is offline   Reply With Quote
Old 11-19-2014, 07:53 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:41 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup