Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-12-2015, 12:32 PM   #1
luvmy87gt
 
Join Date: Jan 2015
Vehicle: 1987 Ford Mustang
Location: Pennsylvania
Posts: 3
Default Running Issues

Ok guys I have a 2005 Mustang GT with a ProCharger Set up in shop. It originally came in with a fuel pressure issue, we upgraded to the GT500 fuel pump set up and it got rid of the fuel pressure issue but in turn revealed another issue all together. Returned the car back to stock, removed Procharger, installed stock intake, stock injectors. Was also throwing a code for a faulty computer so that was also replaced with new and flashed for the car, also replaced the throttle body with stock and MAF sensor and MAF pigtail also replaced O2 sensors. Whenever the car is at part throttle (2500-3000RPM it breaks up badly) Deleted the Intake runners, tuned for the delete with SCT and also worked with Second Street to get this issue resolved.
STILL NOT RESOLVED.
Tests performed are as followed:
Compression test
Leak down Test
Running Compression Test
Coil on plug test (multiple times)
Pulled the Harmonic Balancer checked the reluctor ring for damage
Smoked tested multiple times
vacuum tested multiple times
Pulled Valve covers checked for broken springs
Checked all grounds
As of right now the car only has upgraded fuel pump, intake runner delete, and shorty headers.
Car only has 40,000 MILES on it.
Called other shops for insight no help or resolve.
Any one out there have the same issue or had the same issue and fixed it????
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
luvmy87gt is offline   Reply With Quote
Old 01-12-2015, 12:58 PM   #2
edwin108
2nd Gear Member
 
edwin108's Avatar
 
Join Date: Dec 2009
Vehicle: 2010 GT
Location: New Jersey
Posts: 286
shlbygt500 shlbygt500
Default

How old is the fuel filter?
__________________
2010 Mustang GT Premium Grabber Blue / 4.6L 3V / 5MT / 401A / Security / HID / Comfort / TrackPack / 3.73
Ford Racing Hot Rod Cams / Steeda CAI / Steeda CMDPs / Bama Tunes / UPR Oil Catch Can / Shaftmasters 3.5" Aluminum DS / MGW Shifter

edwin108 is offline   Reply With Quote
Old 01-12-2015, 02:33 PM   #3
Derf00
6th Gear Member
 
Join Date: Feb 2005
Vehicle: '08 S197 GT
Location: AZ
Posts: 9,819
Default

Timinig maybe as in bad Cam Phaser or Cam Phaser Solenoid? Since they change timing based on engine RPM that's the only thing I can think of. Right at that 2500 to 3500 RPM would be where the solenoid gets flakey or the cam Phaser isn't adjusting correctly.
__________________
08 S197 GT Auto: FRPP Strut Tower Brace, FRPP Bullitt CAI, Bama 91-P Tune, VBX remaned valve body with Superior Transmission Shift Kit.
Pending upgrades: Shaftmasters Aluminum 3.5" DS, FRPP 3.73 gears, Axle back exahust (?)

Quote:
Originally Posted by LostBoyz View Post
if you are getting 29mpg in your 5.0, you aren't driving it correctly
Derf00 is offline   Reply With Quote
Old 01-12-2015, 10:47 PM   #4
Simon1
5th Gear Member
 
Join Date: Dec 2006
Vehicle: 2006 Mustang GT
Location: Redding, CA
Posts: 4,279
Default

A good tuner would be able to rule out tuning issues.

The basic things that would cause what you are describing are issues with fuel, spark, or timing. The other thing not listed in that equation is installing the delete plates.

Check for CELs

I would confirm it is on a good tune.

Check the wiring from the fuel pumps to ensure everything is grounded and ran with the proper gauge wire.


Check the charging system, batt and ALT.

Inspect the cam phasers.

Ensure all vacuum lines are engaged and also take a reading of vacuum.

Take is to ta shop that knows what they are doing.
__________________
[IMG][/IMG]

Motor Built by ST Motorsports
Tuned By Tony at Tuners Inc

11.05@129
Simon1 is offline   Reply With Quote
Old 01-13-2015, 01:21 AM   #5
cruisin5268d
3rd Gear Member
 
Join Date: Mar 2014
Vehicle: 2013 GT/CS Convertible & 2010 GT Premium
Location: Austin, Texas
Posts: 668
Default

All, I think the OP IS the shop asking for help.
cruisin5268d is offline   Reply With Quote
Old 01-13-2015, 02:16 PM   #6
luvmy87gt
 
Join Date: Jan 2015
Vehicle: 1987 Ford Mustang
Location: Pennsylvania
Posts: 3
Default

Quote:
Originally Posted by cruisin5268d View Post
All, I think the OP IS the shop asking for help.
Thank you, I am Posting from a shop and have been in contact with several other shops regarding the issues that this car has. The fuel filter, spark plugs and COB plugs are new and gapped properly.. The timing sounds like something to consider. Thank you all for your insight
luvmy87gt is offline   Reply With Quote
Old 01-13-2015, 02:57 PM   #7
Derf00
6th Gear Member
 
Join Date: Feb 2005
Vehicle: '08 S197 GT
Location: AZ
Posts: 9,819
Default

Quote:
Originally Posted by luvmy87gt View Post
Thank you, I am Posting from a shop and have been in contact with several other shops regarding the issues that this car has. The fuel filter, spark plugs and COB plugs are new and gapped properly.. The timing sounds like something to consider. Thank you all for your insight
Timing issues can also be related to oil pressure in these cars.

http://www3.jasperengines.com/blog/2...l-pump-update/

Note the RPM the OEM pump starts to bleed out pressure...
__________________
08 S197 GT Auto: FRPP Strut Tower Brace, FRPP Bullitt CAI, Bama 91-P Tune, VBX remaned valve body with Superior Transmission Shift Kit.
Pending upgrades: Shaftmasters Aluminum 3.5" DS, FRPP 3.73 gears, Axle back exahust (?)

Quote:
Originally Posted by LostBoyz View Post
if you are getting 29mpg in your 5.0, you aren't driving it correctly
Derf00 is offline   Reply With Quote
Old 01-15-2015, 02:17 PM   #8
Derf00
6th Gear Member
 
Join Date: Feb 2005
Vehicle: '08 S197 GT
Location: AZ
Posts: 9,819
Default

I'm curious OP, any updates on the problem with the car?
__________________
08 S197 GT Auto: FRPP Strut Tower Brace, FRPP Bullitt CAI, Bama 91-P Tune, VBX remaned valve body with Superior Transmission Shift Kit.
Pending upgrades: Shaftmasters Aluminum 3.5" DS, FRPP 3.73 gears, Axle back exahust (?)

Quote:
Originally Posted by LostBoyz View Post
if you are getting 29mpg in your 5.0, you aren't driving it correctly
Derf00 is offline   Reply With Quote
Old 01-26-2015, 11:03 AM   #9
luvmy87gt
 
Join Date: Jan 2015
Vehicle: 1987 Ford Mustang
Location: Pennsylvania
Posts: 3
Default

Well, Still no resolution, waiting on a gas pedal assembly to come in and see if that resolves anything. Did find out that there were stereo components that were wired on top of the PCM which could cause Electrical noise.
luvmy87gt is offline   Reply With Quote
Old 01-26-2015, 11:03 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 04:58 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup