Search



Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Sign in using an external account
Register Forgot Password?
Search

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.
Sponsored by Cruizin Concepts


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-22-2008, 06:23 AM   #1
ryanc
 
Join Date: Mar 2008
Posts: 10
Default Whistle during light throttle after TB/plenum install

I recently purchased this item combo which is a ported stock Ford throttle body and a Professional Products (trick flow) ported plenum:

http://cgi.ebay.com/ebaymotors/ws/eB...25920&rd=1

Got a damn good price as you can see.

anyway, I get a whistle when I open the throttle lightly (maybe 10-25% throttle). I don't hear any whistle at idle. Everything is good and tight and all gaskets are intact.

Any ideas?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
ryanc is offline   Reply With Quote
Old 03-22-2008, 02:06 PM   #2
Jbauer
4th Gear Member
 
Join Date: Aug 2007
Posts: 1,106
Default RE: Whistle during light throttle after TB/plenum install

Damn trickflow plenums are known to do this- i found it obnoxious to the point of dying but all my friends thought it was cool. If it's not whistling at idle- when the most vaccum is present, then it's probably not a vaccum leak and standard operation. Just gotta live with it.
Jbauer is offline   Reply With Quote
Old 03-22-2008, 02:26 PM   #3
koumiss45
2nd Gear Member
 
Join Date: Mar 2006
Location:
Posts: 378
Default RE: Whistle during light throttle after TB/plenum install

My trickflow plenum does this...darn it. It drives me nuts too but everyone who isn't arouind the car alot thinks its great.
__________________
Vt Stage 1's, Ported PI Swap, 70mm TB, BBK CAI, Shorties, Off Road H Flowmaster 40's, Centerforce Clutch, FRPP 3.73's, Custom Tune, Other Appearance Mods, Pro Kit coming soon
koumiss45 is offline   Reply With Quote
Old 03-22-2008, 02:30 PM   #4
Jbauer
4th Gear Member
 
Join Date: Aug 2007
Posts: 1,106
Default RE: Whistle during light throttle after TB/plenum install

My accufab i have on there now makes a diffrent sound..like a high pitched whistle- like a dog whistle almost. It got even louder when i got my cold air intake. Hopefully it gets quiter when i put a 70mm throttle body on
Jbauer is offline   Reply With Quote
Old 03-22-2008, 02:55 PM   #5
NeedStangSpeed
3rd Gear Member
 
Join Date: Oct 2006
Location: New Philadelphia, Ohio
Posts: 786
Default RE: Whistle during light throttle after TB/plenum install

I wouldn't say vacuum leak but it may be a leak either between TB and Upper plenum, or upper plenum and intake manifold, this just happened to me and I had the same sound, run your finger around those areas and check if you feel anything, if not that, say carb cleaner in those areas and see if there is a reaction to it. I just ended up putting some gasket sealer on it and it did the trick. If none of the above holds true, then I'm not sure what could be happening at that point.
__________________
Bullitt (SOLD)
1998 F150 Nascar Edition (TOTALED, damn deer!)

New Philadelphia, Ohio
NeedStangSpeed is offline   Reply With Quote
Old 03-22-2008, 05:13 PM   #6
klfutrelle
4th Gear Member
 
Join Date: Dec 2005
Location:
Posts: 1,120
Default RE: Whistle during light throttle after TB/plenum install

My accufab 75mm tb and plenum does the same thing. I can't find a leak anywhere.
__________________
ORIGINAL: Margarita Girl

I'll foam his *** then hit him with the bat.

klfutrelle is offline   Reply With Quote
Old 03-22-2008, 06:05 PM   #7
2k1gt
5th Gear Member

 
2k1gt's Avatar
 
Join Date: Mar 2004
Vehicle: The Silver Slut
Location: Athens, Georgia
Posts: 3,733
Default RE: Whistle during light throttle after TB/plenum install

Mine does it, all my friends cars do it. Don't worry about it. There is nothing wrong. I personally think it sounds awesome.
__________________
2k1gt is offline   Reply With Quote
Old 03-22-2008, 06:50 PM   #8
timeformiller44
4th Gear Member
 
Join Date: May 2006
Vehicle: 2001 Ford Mustang GT
Location: New York
Posts: 1,856
Send a message via AIM to timeformiller44
Default RE: Whistle during light throttle after TB/plenum install

if u have a CAI .. is it an open filter...chances are u hear the air being sucked in...
__________________

DERKADERKA
timeformiller44 is offline   Reply With Quote
Old 03-23-2008, 05:03 PM   #9
nebraska03gt
1st Gear Member
 
Join Date: Mar 2007
Location:
Posts: 120
Default RE: Whistle during light throttle after TB/plenum install

I installed a TB spacer and i get the whine. i like it alot though! but about the air being sucked in...my car does that when i engine brake (ive got mac CAI)
__________________


nebraska03gt is offline   Reply With Quote
Old 03-23-2008, 05:44 PM   #10
02gtfromky
 
Join Date: Mar 2008
Vehicle: 2002 ford mustang gt
Posts: 14
Default RE: Whistle during light throttle after TB/plenum install

got c&l plenum and accufab 75mm and was havin same problem. I also thought it was a vaccum leak. Thanks guys i was about to post and ask about it.
02gtfromky is offline   Reply With Quote
Old 03-23-2008, 05:44 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
2v, 46, 46l, 50l, body, flow, ford, highflow, mustang, plenums, products, professional, tb, throttle, trick, upper, whisle, whistle, whistles

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:09 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup