coolant confusion - MustangForums.com



4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-07-2003, 01:41 AM   #1
mustangg4.61996
Thread Starter
 
Join Date: Apr 2003
Location: United States
Posts: 5
Default coolant confusion

I have a 96 gt it has 94000 miles on it. the coolant system seems fine no leaks, no bad hoses, no bad or dry rotted ends on hoses. my problem is the check coolant light always stays on and rarely ever thens off. what can this problem be. your repose is much greatfull. thank you
mustangg4.61996 is offline   Reply With Quote
Old 04-07-2003, 01:45 AM   #2
noslow50
I ♥ Acer
 
Join Date: Dec 2002
Posts: 435
Default coolant confusion

how's it runnin???? maybe by some chance u got a blown head gasket and it's suckin in coolant....maybe
noslow50 is offline   Reply With Quote
Old 04-07-2003, 07:19 PM   #3
91GT5.0
2nd Gear Member
 
Join Date: Mar 2003
Location: United States
Posts: 282
Default coolant confusion

There's a sensor on the cap/dipstick that goes into the overflow bottle. Either fill it up or disconnect the plug from the cap. I had it on my 91 GT, lol, one time I filled up the overflow and forgot to put the cap back on, it fell into my fan and chewed up the dipstick thing, light would stay on after that, I just unplugged it and it went away.



91GT5.0 is offline   Reply With Quote
Old 04-07-2003, 09:07 PM   #4
96 gt
 
Join Date: Apr 2003
Location: United States
Posts: 8
Default coolant confusion

well my light comes on every two to three weeks and then i have to add water to it.I think i have blown head gasket.
96 gt is offline   Reply With Quote
Old 04-07-2003, 09:49 PM   #5
jeep45238
I ♥ Acer
 
Join Date: Mar 2003
Location: United States
Posts: 2,199
Default coolant confusion

THEN QUIT DRIVING IT and get it taken care of.



That's why my bud's car is costing him out the butt to take care of, instead of the $40 for gaskets.
jeep45238 is offline   Reply With Quote
Old 04-08-2003, 11:58 PM   #6
lloydchristmas
3rd Gear Member
 
Join Date: Feb 2003
Location: United States
Posts: 708
Default coolant confusion

I had the same problem. Disconnect the stupid sensor at the overflow bottle. They never work right.
lloydchristmas is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Mustang Expansion Tank Granatelli Sales The New S550 2015-2017 Mustang 16 01-30-2017 04:15 PM
Aluminum / performance intake 97 GT 4.6 help Vrooom 4.6L General Discussion 13 02-21-2016 06:25 PM
Need to rebuild the automatic transmission 1996 GT wraith777 General Tech 1 09-28-2015 11:49 AM
01 Mustang Overheating :( MusicCity615 General Tech 7 09-12-2015 08:05 AM
V6 Engine Ticking Nick Oliver V6 S197 General Discussion 2 09-05-2015 11:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:48 AM.