Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Sign in using an external account
Register Forgot Password?
Search


4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.
Sponsored by Cruizin Concepts


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-17-2012, 09:21 PM   #1
SKOT
 
SKOT's Avatar
 
Join Date: Mar 2012
Vehicle: 2000 Ford Mustang
Location: N.C.
Posts: 3
Default 2000 GT Transmision Vibration

Just replaced the clutch, P Plate, Release and Pilot Brgs on 2000 GT with 56kmiles..The car now vibrates in 5th gear and shutters when letting out on the clutch pedal like a bad or really worn clutch plate. I remember when I reinstalled the transmission the mount was a little sloppy, the rubber was not separated from the mount just as I said sloppy.. SO I installed a new mount today and am still having the same issues PLUS....While revving the engine sitting still or driving there is a vibration from 1k-4k RPM Clutch pedal in or out, and the pedal is vibrating like the cable needs adjusted again.

I have replaced many clutches/xmissions and have NEVER had any problem like this T45 is givin me!!

Anyone have any suggestions or heard of anything similar??

THANKS!!!!!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
SKOT is offline   Reply With Quote
Old 03-17-2012, 10:51 PM   #2
Repzard
4th Gear Member
 
Repzard's Avatar
 
Join Date: Apr 2009
Vehicle: 99 Ford Mustang GT & 97 Cobra SVT
Location: sttesuhcaxaT (The State you love to hate)
Posts: 1,360
Default

Did you mark the driveshaft and put it on the same way it came off?
__________________

1997 SVT Cobra #6149 of 6961
Repzard is offline   Reply With Quote
Old 03-17-2012, 11:00 PM   #3
SKOT
 
SKOT's Avatar
 
Join Date: Mar 2012
Vehicle: 2000 Ford Mustang
Location: N.C.
Posts: 3
Default

Yep went back where it came off
SKOT is offline   Reply With Quote
Old 03-17-2012, 11:00 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
96, campana, clutch, de, gas, gear, gt, letting, mount, mustang, pedal, rubber, shutters, transmision, vibrations

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:23 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup