Brake pad separation -

Go Back > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Brake pad separation

Thread Tools Search this Thread
Old 05-09-2013, 06:13 PM   #1
2nd Gear Member
Join Date: Aug 2012
Vehicle: 2000 Ford, Mustang GT
Location: MS
Posts: 464
Default Brake pad separation

I've had this happen to me today, let me tell you worst sound ever. The pad material separated from the backing and was just skating along on the rotor behind the caliper.

Raybestos has an amazing warranty of three years Im expecting replacements shortly. So, the reason for my posting is this:
1. what could be the causes?
I'm sure the reasons are endless, just wanted to see if its possibly something I may have caused. They've only been on the car since Oct.
Seabee1993 is offline   Reply With Quote
Old 05-09-2013, 07:05 PM   #2
Sonic Mustang
Join Date: Feb 2013
Vehicle: 2004 Mach 1
Location: USA
Posts: 545

If you search the web for "brake pad separation failure," you'll find others have experienced the same failure.

I'd have to guess adhesive failure. Either the glue itself or method of application. Raybestos is a name brand and I can't image your problem being more widespread than a small batch.

I certainly can't image your street driving being the cause. If your driving hard enough to cause pad/baking plate failure and the adhesive and workmanship are 100%, you would have trashed the rest of your braking system months ago.

If this happened to me, I'd call Bear, Willwood and Stoptech to get professional opinions. I doubt Raybestos would admit to anything for legal reasons.
Sonic Mustang is offline   Reply With Quote
Old 05-09-2013, 08:11 PM   #3
2nd Gear Member
Join Date: Aug 2012
Vehicle: 2000 Ford, Mustang GT
Location: MS
Posts: 464

Oh no, I wasn't bashing them at all! Raybestos owned up to it, but because they only do their sales through their dealers, I had to go back through rock auto for the exchange process. It happened to be the outside right pad on the passenger side. Already took them off and left the car on jackstands, now it's all to see how long the UPS truck takes to get here.
Seabee1993 is offline   Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting a new project....could use some input. Matt's 95 Stang 5.0L (1979-1995) Mustang 2 10-05-2015 07:16 AM
04 Mach 460 system, Installed Aftermarket HU, No Highs/Tweeters breaking Audio/Visual Electronics 5 10-02-2015 01:27 PM
GT500 front LCA question UrS4 S197 Handling Section 1 09-30-2015 10:13 AM
How to Replace Brake Fluid on Your 1996-2014 Ford Mustang GT MustangForums Editor General Tech 0 09-25-2015 06:42 PM
V6 Project Problems ThatJuanStang V6 (1994-2004) Mustangs 4 09-25-2015 08:01 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 12:47 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company