Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Sign in using an external account
Register Forgot Password?
Search


4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.
Sponsored by Cruizin Concepts


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-14-2006, 01:35 AM   #1
Kadence
3rd Gear Member
 
Join Date: Dec 2005
Location: Houston, TX
Posts: 529
Default Low Coolant Light

I shredded my accesory belt while running my friends SS and overheated the engine and got radiator fluid everywhere. Well i put a new belt on and it started fine, but the low coolant light was on, I filled that fluid nack all the way to the top and ran it and the light was still on. So i drove around for about 20 minutes to get coolant running and but the coolant was still full and the low coolant light was still on. I thought maybe if i reset the computer that the light would go off so i unplugged the battery and put it back in, but the gd light is still on. Any ideas?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________

94 Cobra 447rwhp/401tq
Kadence is offline   Reply With Quote
Old 01-14-2006, 02:12 AM   #2
sprostang
I ♥ Acer
 
Join Date: Sep 2005
Location: Illinois
Posts: 6,190
Default RE: Low Coolant Light

Sounds like your coolant temp sensor is bad.
sprostang is offline   Reply With Quote
Old 01-14-2006, 04:24 AM   #3
sandcracker21
4th Gear Member
 
Join Date: Mar 2005
Vehicle: 2003 Mustang GT
Location:
Posts: 1,957
Default RE: Low Coolant Light

Quote:
ORIGINAL: sprostang

Sounds like your coolant temp sensor is bad.
+1
__________________
PERFORMANCE
Steeda CAI
BBK Throttle body
BBK Plenum
Ford 4.10s
Flowmaster 40s
Steeda UDP
Eibach Pro-Kit
Bilstein Shocks/Struts
Maximum Motorsports LCA
UPR UCA
Diablo Tune

^RIP^
sandcracker21 is offline   Reply With Quote
Old 01-14-2006, 06:48 PM   #4
ZW99GT
6th Gear Member
 
ZW99GT's Avatar
 
Join Date: Nov 2004
Vehicle: 1999 GT
Location: Tennessee
Posts: 7,797
Default RE: Low Coolant Light


Quote:
ORIGINAL: Kadence

I shredded my accesory belt while running my friends SS and overheated the engine and got radiator fluid everywhere. Well i put a new belt on and it started fine, but the low coolant light was on, I filled that fluid nack all the way to the top and ran it and the light was still on. So i drove around for about 20 minutes to get coolant running and but the coolant was still full and the low coolant light was still on. I thought maybe if i reset the computer that the light would go off so i unplugged the battery and put it back in, but the gd light is still on. Any ideas?
Can someone say Intake MANI?
__________________
408ci 1999 GT.......................................... 2000 PowerStroke Turbo Diesel


ZW99GT is offline   Reply With Quote
Old 01-14-2006, 09:08 PM   #5
black01gt
2nd Gear Member
 
Join Date: Apr 2005
Location:
Posts: 222
Send a message via AIM to black01gt
Default RE: Low Coolant Light

What year stang do u have?
__________________
2003 Grey Mustang GT 5spd
BBK O/R X Pipe, SLP Loudmouth II's,Superchips Tuner, JLT RAI

Coming next soon: FRPP 4.10's

Old car 2001 Black gt Auto Stock 14.23 e/t at 96.77mph 2.1310 in
black01gt is offline   Reply With Quote
Old 01-14-2006, 10:23 PM   #6
04BlueGT
5th Gear Member
 
04BlueGT's Avatar
 
Join Date: Jul 2005
Vehicle: 2004 Mustang GT
Location: Grovetown, GA
Posts: 2,378
Default RE: Low Coolant Light

+2 for bad sensor
__________________
Exhaust Video


Too many mods to list, but if it's from Steeda, it's either on or waiting to go on.
04BlueGT is offline   Reply With Quote
Old 01-14-2006, 10:23 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 10:07 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup