Low Coolant Light - MustangForums.com



4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-14-2006, 12:35 AM   #1
Kadence
3rd Gear Member
Thread Starter
 
Join Date: Dec 2005
Location: Houston, TX
Posts: 529
Default Low Coolant Light

I shredded my accesory belt while running my friends SS and overheated the engine and got radiator fluid everywhere. Well i put a new belt on and it started fine, but the low coolant light was on, I filled that fluid nack all the way to the top and ran it and the light was still on. So i drove around for about 20 minutes to get coolant running and but the coolant was still full and the low coolant light was still on. I thought maybe if i reset the computer that the light would go off so i unplugged the battery and put it back in, but the gd light is still on. Any ideas?
Kadence is offline   Reply With Quote
Old 01-14-2006, 01:12 AM   #2
sprostang
I ♥ Acer
 
Join Date: Sep 2005
Location: Illinois
Posts: 6,190
Default RE: Low Coolant Light

Sounds like your coolant temp sensor is bad.
sprostang is offline   Reply With Quote
Old 01-14-2006, 03:24 AM   #3
sandcracker21
4th Gear Member
 
Join Date: Mar 2005
Location:
Posts: 1,957
Default RE: Low Coolant Light

Quote:
ORIGINAL: sprostang

Sounds like your coolant temp sensor is bad.
+1
sandcracker21 is offline   Reply With Quote
Old 01-14-2006, 05:48 PM   #4
ZW99GT
6th Gear Member
 
ZW99GT's Avatar
 
Join Date: Nov 2004
Location: Tennessee
Posts: 7,797
Default RE: Low Coolant Light


Quote:
ORIGINAL: Kadence

I shredded my accesory belt while running my friends SS and overheated the engine and got radiator fluid everywhere. Well i put a new belt on and it started fine, but the low coolant light was on, I filled that fluid nack all the way to the top and ran it and the light was still on. So i drove around for about 20 minutes to get coolant running and but the coolant was still full and the low coolant light was still on. I thought maybe if i reset the computer that the light would go off so i unplugged the battery and put it back in, but the gd light is still on. Any ideas?
Can someone say Intake MANI?
ZW99GT is offline   Reply With Quote
Old 01-14-2006, 08:08 PM   #5
black01gt
2nd Gear Member
 
Join Date: Apr 2005
Location:
Posts: 222
Default RE: Low Coolant Light

What year stang do u have?
black01gt is offline   Reply With Quote
Old 01-14-2006, 09:23 PM   #6
04BlueGT
5th Gear Member
 
04BlueGT's Avatar
 
Join Date: Jul 2005
Location: Grovetown, GA
Posts: 2,378
Default RE: Low Coolant Light

+2 for bad sensor
04BlueGT is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Mustang Expansion Tank Granatelli Sales The New S550 2015-2017 Mustang 20 03-16-2017 07:33 PM
LED light hookup to fog light switch Colin Ringle General Tech 1 09-15-2015 09:27 PM
01 Mustang Overheating :( MusicCity615 General Tech 7 09-12-2015 07:05 AM
2005 GT Intermittent Low Rail Pressure Throttle Drop zanemoseley 2005-2014 Mustangs 6 09-06-2015 12:58 PM
V6 Engine Ticking Nick Oliver V6 S197 General Discussion 2 09-05-2015 10:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:23 PM.