Search



Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang > 4.6L General Discussion
Sign in using an external account
Register Forgot Password?
Search

4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-02-2012, 05:59 PM   #1
mustangmancp
5th Gear Member
 
mustangmancp's Avatar
 
Join Date: Apr 2006
Vehicle: 01 Mustang GT vert
Location: Missouri
Posts: 4,503
Default HID problems...

Ok so I've had these HIDs in my car for about a year now and have been having issues with them since i put em in and I'm just now getting tired of it lol.

1. When I flip my "brights" on it's my dims and vis versa...not really a problem just kinda annoying.

2. When I turn my headlights on sometimes the drivers side headlight doesn't come on, but after turning it on and off like twice it will come on? What could that be realated to?

Any input would be great...my dad's got my car at home while I'm at school and wants to get to work on it so I told him you guys could help me out!

Thanks boys!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________

Built shortblock, H/C/I....70mm turbo coming together
mustangmancp is offline   Reply With Quote
Old 04-02-2012, 06:22 PM   #2
Aereon
5th Gear Member

 
Join Date: Aug 2005
Vehicle: 03
Location: SF Bay.
Posts: 3,035
Send a message via AIM to Aereon
Default

1. When I flip my "brights" on it's my dims and vis versa...not really a problem just kinda annoying.

Don't understand this question, if the headlights are dimming then it may be the ballasts since they regulate/convert current for the bulbs. If interior dome lights/dash lights are dimming you may be running a cheap kit thats drawing too much power through the lines to activate the magnet or the second bulb depending on how your high beams are setup.

2. When I turn my headlights on sometimes the drivers side headlight doesn't come on, but after turning it on and off like twice it will come on? What could that be realated to?

Possibly bad/failing igniter and or loose wires.
__________________


Big corral, very few horses.

Member of Team IRS-GT #0 ^^

The bucket is up for sale.
Aereon is offline   Reply With Quote
Old 04-02-2012, 06:23 PM   #3
jtb727
3rd Gear Member
 
Join Date: Nov 2009
Vehicle: 1999
Location: AZ
Posts: 587
Default

With the Hi beams/low Beams I can't say.. Mine are just on.

But with the driver side not wanting to fire up, mine used to do it too.. go through check your grounds, and plugs.. mine turned out to be a plug that didnt completely "snap" over the little nipple, because the nipple allowed the fingers of the plug to slide upwards and become loose. So I had to do some massaging on the fingers with a pair of dikes to it would stay nice and tight.
__________________
The Mustang:
11:1 forged motor, CMS stage 2.5 NA cams,Nitrous express plate kit(100 or 150 shot havent decided), mac lt's, BBK 78mm TB unit, 24# Injectors, Hughes performance built 4r70w W/ 3200 stall. Awaiting dyno tune...

The DD:"Mader"
2005 F150 supercrew 4x4. Leveled front with an Add-a-Leaf in the rear.Sitting on 33's W/ a nice system.
jtb727 is offline   Reply With Quote
Old 04-02-2012, 06:26 PM   #4
mustangmancp
5th Gear Member
 
mustangmancp's Avatar
 
Join Date: Apr 2006
Vehicle: 01 Mustang GT vert
Location: Missouri
Posts: 4,503
Default

In the first question what I'm meaning is that when i flip my brights on and it shows it on my dash, its my dims, and when I turn my brights off, it goes to my high beams. Its like they're flip flopped.
__________________

Built shortblock, H/C/I....70mm turbo coming together
mustangmancp is offline   Reply With Quote
Old 04-02-2012, 06:56 PM   #5
Aereon
5th Gear Member

 
Join Date: Aug 2005
Vehicle: 03
Location: SF Bay.
Posts: 3,035
Send a message via AIM to Aereon
Default

Quote:
Originally Posted by mustangmancp View Post
In the first question what I'm meaning is that when i flip my brights on and it shows it on my dash, its my dims, and when I turn my brights off, it goes to my high beams. Its like they're flip flopped.
thats because they are flip flopped, the kit you have is an international kit, the wires for your low beam and high beam will need to be swapped. Swap the two power wires on the blue plug and that should fix that issue.

For the flickering/not firing light, #2 still applies.
__________________


Big corral, very few horses.

Member of Team IRS-GT #0 ^^

The bucket is up for sale.
Aereon is offline   Reply With Quote
Old 04-02-2012, 07:37 PM   #6
StockD15b
4th Gear Member
 
Join Date: Oct 2005
Vehicle: 2000 Gt
Location: Fl
Posts: 1,392
Send a message via AIM to StockD15b
Default

Quote:
Originally Posted by Aereon View Post
thats because they are flip flopped, the kit you have is an international kit, the wires for your low beam and high beam will need to be swapped. Swap the two power wires on the blue plug and that should fix that issue.

For the flickering/not firing light, #2 still applies.
^This +
Click the image to open in full size.
+
get a relay harness.
__________________

I have HID projector headlights.
StockD15b is offline   Reply With Quote
Old 04-02-2012, 07:37 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
01, 2012, ballast, convertible, firing, fordmustang, foxbody, hid, mustang, problems, sf

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 11:41 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup