Search



Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs > GT S197 General Discussion > 4.6L V8 Technical Discussions
Sign in using an external account
Register Forgot Password?
Search

4.6L V8 Technical Discussions Any questions about engine, transmission, or gearing can be asked here!

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-29-2009, 07:50 PM   #1
Korpage02
 
Join Date: Sep 2009
Vehicle: 2005 Ford Mustang GT
Location: California
Posts: 2
Angry 2005 Mustang GT clutch problem

Ok 30,000 miles on my car have been more than great...last 6,000 been horrible. My clutch started slipping so I took it in and they replaced the clutch all is good for a month. Clutch pedal starts declining strength...gets soft lost about 30% causing it very hard to shift almost shifting without a clutch. Take it back clutch is fine, dealership then replaces slave cylinder and hydrolic system. It drives fine for another 3 months now it's getting soft again about 20-30% of the clutch is lost. Had a friend bleed it and no difference. If anyone has had a similiar problem or an idea on what I could do to fix this ongoing problem please reply. The car runs great but it's almost been undrivable the past 6 months I'm so frustrated!

Only mods on the car are xcalibrator 1 and steeda cold air intake
Custom xpipe exhaust with flowmasters.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
Korpage02 is offline   Reply With Quote
Old 09-29-2009, 09:42 PM   #2
BruceH
5th Gear Member

 
Join Date: Jul 2008
Vehicle: ......
Location: ......
Posts: 2,057
Default

.......
__________________
.........

Last edited by BruceH; 01-01-2011 at 09:34 PM.
BruceH is offline   Reply With Quote
Old 09-29-2009, 09:45 PM   #3
volcomchester18
3rd Gear Member
 
Join Date: Aug 2004
Vehicle: 2007, ford, mustang
Location: Orange county, CA
Posts: 505
Default

take it back to dealer, tell them they are responsible to fix it. You did not have any of these issue before the install. good luck.
volcomchester18 is offline   Reply With Quote
Old 04-14-2013, 04:06 PM   #4
Pitchblack7720
 
Join Date: Sep 2012
Vehicle: 07 Ford Mustang
Location: Texas
Posts: 32
Chika08
Default

So what end up happening??? How did you fix it? 0.o
__________________


2007 Mustang GT/CS
Pitchblack7720 is offline   Reply With Quote
Old 04-14-2013, 05:01 PM   #5
Diabolical!
5th Gear Member

 
Diabolical!'s Avatar
 
Join Date: Jul 2006
Vehicle: 2006 Mustang GT
Location: New Orleans
Posts: 4,494
Default

I'm gonna go out on a limb here and guess that since this guy only has one post and it's 4 years old... He's not coming back to answer you.
__________________

Whipple-12psi 10 Rib Pulley Kit-McLeod RXT & Steel Flywheel-UPR Rod End LCAs, UCA, Spherical Bearing, Panhard Bar, K-member + Front Swaybar Delete-Metco LCA Relo Brackets-BMR Xtreme Anti Roll-Spydershaft-Race Star Wheels-MGW-PMP Line Locks-Stanghi O/R X-Odyssey 10 lb Battery-Moroso Separator-Eibach Front/CJ Rear Drag Springs-Strange Adjustable Shocks and Struts-MSD 2 Step-etc. 11.29@123 1.59 60'
DRAG RACE? ASK ME ABOUT MY UPR SUSPENSION.
Diabolical! is offline   Reply With Quote
Old 04-14-2013, 05:08 PM   #6
rcerm
 
Join Date: Apr 2013
Vehicle: 2013 GT Premium
Location: Delaware
Posts: 9
Default

When I bought my '09, I noticed around 2k miles that the clutch was slipping every once in a while, and repeatedly took the car back to Ford for them to fix it. They could never replicate the problem and chalked it up to my driving habits. While I love my stangs, I do not abuse them.

My clutch ended up going around 25k and I was livid. Took it back to Ford and i'm unsure of what went on, but I payed $100 for a completely new clutch system and oil change. If you are experiencing similar issues, take the car in as soon as you notice anything. I had my car in six times before the clutch finally went.. My assumption is that they ate the cost as it was documented since the car was new that there were issues.
rcerm is offline   Reply With Quote
Old 04-21-2013, 01:42 AM   #7
Pitchblack7720
 
Join Date: Sep 2012
Vehicle: 07 Ford Mustang
Location: Texas
Posts: 32
Chika08
Default

yea i thought so too, couldnt hurt to ask tho lol

My clutch, after the clutch change, now feels soft compared to my friends stock clutch. and i having trouble shifting to second gear during WOT. changed flywheel, clutch throwout bearing and pilot bearing. 0.o
__________________


2007 Mustang GT/CS
Pitchblack7720 is offline   Reply With Quote
Old 04-21-2013, 09:02 PM   #8
Korpage02
 
Join Date: Sep 2009
Vehicle: 2005 Ford Mustang GT
Location: California
Posts: 2
Default 05 mustang clutch issues

What happened was the clutch was replaced again and I sold the car after a month before running into more problems. Had 2 cars since a 09 dodge challenger rt and now a 2013 subaru wrx. I doubt ill buy another mustang again.
Korpage02 is offline   Reply With Quote
Old 04-22-2013, 02:39 AM   #9
Diabolical!
5th Gear Member

 
Diabolical!'s Avatar
 
Join Date: Jul 2006
Vehicle: 2006 Mustang GT
Location: New Orleans
Posts: 4,494
Default

Holy crap. He lives.
__________________

Whipple-12psi 10 Rib Pulley Kit-McLeod RXT & Steel Flywheel-UPR Rod End LCAs, UCA, Spherical Bearing, Panhard Bar, K-member + Front Swaybar Delete-Metco LCA Relo Brackets-BMR Xtreme Anti Roll-Spydershaft-Race Star Wheels-MGW-PMP Line Locks-Stanghi O/R X-Odyssey 10 lb Battery-Moroso Separator-Eibach Front/CJ Rear Drag Springs-Strange Adjustable Shocks and Struts-MSD 2 Step-etc. 11.29@123 1.59 60'
DRAG RACE? ASK ME ABOUT MY UPR SUSPENSION.
Diabolical! is offline   Reply With Quote
Old 04-25-2013, 02:28 PM   #10
kevinmalec
5th Gear Member

 
kevinmalec's Avatar
 
Join Date: Apr 2008
Vehicle: 2005 Ford Mustang
Location: Acworth, GA
Posts: 3,588
Default

Quote:
Originally Posted by Korpage02 View Post
What happened was the clutch was replaced again and I sold the car after a month before running into more problems. Had 2 cars since a 09 dodge challenger rt and now a 2013 subaru wrx. I doubt ill buy another mustang again.
I'm impressed your still on the forums, especially after all you went through with your Mustang.
Hope your Subaru is a lot more fun than the Mustang was. ;-)
__________________


- 2005, 4.0 - Missing 2 cylinders :-/
- SCT Xcal3 w/ Brenspeed Custom Tunes
- Airaid CAI
- Pypes Streetpro Exhaust
- AM Front Chin Spoiler
- AM Quarter window louvers
- SHR honeycomb decklid panel
- Cobra R wheels
- Eibach Pro-Kit lowering springs
- Billet Honeycomb Chrome Front Grille Overlay
- Smoked tail lights & turn signals, Mustang 3rd brake light decal
- Raxiom sequential tail light kit
kevinmalec is offline   Reply With Quote
Old 04-25-2013, 02:28 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
2000, 2005, 2006, 2007, bleed, clutch, clutchmaster, ford, gt, have, kinds, mustang, problems, slave, v6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Mustang GT Manual Transmission Clunking Sound RiceRocketToMustang 2005 - 2014 Mustangs 47 05-05-2008 02:41 PM
2005 Mustang GT issues? Miracle 2005 - 2014 Mustangs 9 12-03-2006 11:06 AM

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:06 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup