2015 ecoboost is **** - MustangForums.com



4 Cylinder NA and Turbo This section is for questions pertaining to stock or modified 4 cylinders, including the performance 2.3L applications

Reply
 
 
 
Thread Tools Search this Thread
Old 08-30-2016, 03:39 PM   #1
Gzrules37
Thread Starter
 
Join Date: Aug 2016
Location: Ca
Posts: 3
Default 2015 ecoboost is ****

Hey guys, recently my car is acting up. I've had it about for a year and one day now and I'm already encountering many problems. At 5k miles I got an engine light for overboosting so I took it to the dealership and they "fixed" it. They changed someething on the wastegate. So after "fixing it" 4K miles after same problem once again... So I took it in and they were gonna order the same part again and fix the same problem. So they reset the light and I drove off. The next morning I remote started my car and when I went downstairs to my car, I thought my house was on fire, but little do I know my car is making HUGE CLOUDS OF SMOKE and it smelt like something was on fire. So the same exact moment I took it in, so they can fix it. They told me 2015 models have a problem like this, something under the intake that they had to change. They gave me the name of the parts. So my car was at the shop for a week, and apparently they fixed the wastegate and installed 2 other parts to fix that burning smell and smoke. So I got my car back today, and I went for a test drive and now my ****** car doesn't pull as much as it did before... When my foot is on the throttle all the way down, my Rpms go up very slowly whereas before it would fly up, and it takes awhile for it to gain speed... At this point idk what to do. Any one with the same problem? Any advice, solutions?
Gzrules37 is offline   Reply With Quote
Old 09-03-2016, 12:47 PM   #2
bluebeastsrt
6th Gear Member
 
bluebeastsrt's Avatar
 
Join Date: Jun 2006
Location: Jersey
Posts: 11,541
Default

Lemon law. Look it up.
bluebeastsrt is offline   Reply With Quote
Old 09-03-2016, 10:48 PM   #3
jwog666
5th Gear Member
 
jwog666's Avatar
 
Join Date: Mar 2008
Location: wisconsin
Posts: 2,260
Default

2 seperate repairs, 4k miles apart.....he doesnt qualify for lemon law in any state, most lemon laws require that the problem be persistent and unable to be repaired for a period of time. not "i had something fixed........ and 4k miles later something broke......and before i could take it in to replace the part it started smoking"
jwog666 is offline   Reply With Quote
Old 09-07-2016, 10:41 AM   #4
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,319
Default

Take it to a different FORD dealer and tell them to make it right!!!
movielover40 is offline   Reply With Quote
Old 09-07-2016, 02:10 PM   #5
Derf00
6th Gear Member
 
Join Date: Feb 2005
Location: AZ
Posts: 10,556
Default

I'd go to a different dealer.
Derf00 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Changed fog light bulbs, now car wont start!? fourdegrees11 GT S197 General Discussion 13 07-26-2016 02:33 PM
Quick fix or patch for soft top, 95 GT convertible mindaugas 5.0L (1979-1995) Mustang 4 07-22-2016 08:58 PM
How-To Tuesday: Fix a Crack in Your Dashboard MustangForums Editor Mustang Videos 0 06-28-2016 11:39 AM
Moderator.... PLEASE fix my problem..... doubleoh New Member Area 3 06-08-2016 08:29 AM
HEY DO SALEEN Front bumpers have fog lights? GrayGhost01GT Detailing 7 09-03-2004 05:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:46 PM.