Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-10-2006, 04:10 PM   #1
aode08
5th Gear Member
 
Join Date: Oct 2005
Vehicle: 91 Mustang GT
Location: Ohio USA
Posts: 4,614
Default Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

I have a very bad fluctuating cold idle.

Engine when floored in drive, does not wind past 3000 rpm. TPS new, set at .98 idle and so is idle air motor new. so thats not the idle issue, nor any wiring.

SO TWO SEPERATE PROBLEMS, MAYBY SAME FAULT

O2 SENSORS?

I cleaned them with brake cleaner. alot of carbon came out and left my driveway stained. Still same results

Open Headers?

I have NO CATS,NO MUFFLERS, NO RESONANTORS, NO TAILPIPE just open headers.

Enigne new, distributor TFI MODULE , PLUGS, CAP AND ROTOR BUTTON, coilpack,ecm AND ENTIRE WIRING HARNESS new.

This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________



347 , 11:1 Compression,Knife Edged Lightened Crank,AFR 185,Ported Trick-flow Intake,Ford X-CAM,Under-drive pulleys,aluminum drive-shaft, 3:73 gears,Fender Cold Air Intake,Long tube headers,MSD Digital Ignition System
Lightened chassis.

451HP 439 FtLbTrq. mid 10 second car !
aode08 is offline   Reply With Quote
Old 05-10-2006, 05:49 PM   #2
1990mustanggt
4th Gear Member
 
Join Date: Nov 2004
Vehicle: 1990 Ford Mustang GT
Location: Mississippi
Posts: 1,115
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

Are you running Bosch Platinum Plus 4 plugs in it? I ran those in my 4.6 and it wouldn't rev past 3000 RPM's either. I installed just regular Motorcraft platinum plugs and it fixed the problem.
__________________
347 Inches of stroker fury baby
1990mustanggt is offline   Reply With Quote
Old 05-10-2006, 06:04 PM   #3
grabbem88
6th Gear Member
 
Join Date: Dec 2003
Vehicle: 1988 ford mustang
Location: cape giradeau,mo
Posts: 8,872
Send a message via Yahoo to grabbem88
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

get a freak'n exhaust...you are burning the valves...and your cylinders are going to get warped,cause of unbalanced heat/pressure
__________________
THOSE WHO BEG IN SILENCE....STARVE IN SILENCE
http://videos.streetfire.net/video/8EE10B2F-EDEA-4379-91A7-A89E4E27D4A9.htm

http://videos.streetfire.net/video/c535db52-4398-43c2-b538-9849013aa5e5.htm
grabbem88 is offline   Reply With Quote
Old 05-10-2006, 06:43 PM   #4
aode08
5th Gear Member
 
Join Date: Oct 2005
Vehicle: 91 Mustang GT
Location: Ohio USA
Posts: 4,614
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

which bosch paltinums will fit my 1971 351 DO0E heads with the 13/16 diameter and short threaded ends?


also ill do my exhaust before i screw the motor, check the fuel pressure and any codes thanks.



last, how do i perform the cyl bal test
__________________



347 , 11:1 Compression,Knife Edged Lightened Crank,AFR 185,Ported Trick-flow Intake,Ford X-CAM,Under-drive pulleys,aluminum drive-shaft, 3:73 gears,Fender Cold Air Intake,Long tube headers,MSD Digital Ignition System
Lightened chassis.

451HP 439 FtLbTrq. mid 10 second car !
aode08 is offline   Reply With Quote
Old 05-11-2006, 12:30 PM   #5
aode08
5th Gear Member
 
Join Date: Oct 2005
Vehicle: 91 Mustang GT
Location: Ohio USA
Posts: 4,614
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

engine did a code 41 when it told me to tap the accelerator , which is 02 sensor signal, guess there bad, ill add exhaust and replace them i guess,
ANY ADVICE>>???



also did a code 33 egr, I know but thats cause i blocked the passage, with spacer.
__________________



347 , 11:1 Compression,Knife Edged Lightened Crank,AFR 185,Ported Trick-flow Intake,Ford X-CAM,Under-drive pulleys,aluminum drive-shaft, 3:73 gears,Fender Cold Air Intake,Long tube headers,MSD Digital Ignition System
Lightened chassis.

451HP 439 FtLbTrq. mid 10 second car !
aode08 is offline   Reply With Quote
Old 05-11-2006, 02:59 PM   #6
AdderMk2
Banned
 
Join Date: Dec 2005
Vehicle: 94 Cobra
Location: Lil' Rhody
Posts: 22,376
Send a message via AIM to AdderMk2
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

if your running shorties.... with no exhaust... where do you have your o2 sensors... mine bolt into my x-pipe
AdderMk2 is offline   Reply With Quote
Old 05-11-2006, 09:26 PM   #7
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Vehicle: 1986 Ford Mustang GT
Location: Puerto Rico
Posts: 3,926
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

Do the exhaust first.....then confirm any O2 codes by re-running the self-test.....an O2 code should not be a cause for not reving past 3k rpms...something else might be the cause.....suggest to recheck timing, firing order, distributor position (#1 cyl @compression TDC and dist rotor pointing to #1 plug location)...check TPS sensor voltage output, ign on engine off, from closed throttle position to WOT for any signal spikes/flat spots, and start with a fuel pressure setting of 45psi vacuum line off.
__________________
ACRONYMS:
LUK=Let Us Know, GL=Good Luck, LMK=Let Me Know, JIC=Just In Case, BTSTDTRT=Been There Seen That Done That Repaired That, YCYDYP=Your Car Your Dough Your Prerogative and the classic... DILLIGAS=Do I Look Like I Give A S***

1986 GT-X303-289 heads-1.72 rockers-RG 4+1 Trans.
Quote:
Originally Posted by Joel5.0
Great thoughts will overwhelm a feeble mind.
There is never money to do it right, but there's always money to do it over.
The proof of understanding is the ability to explain it. (H. Torruella)
Joel5.0 is offline   Reply With Quote
Old 05-11-2006, 09:32 PM   #8
redmustang83596
4th Gear Member
 
Join Date: May 2005
Vehicle: 2008 Ford Mustang
Location: Chitown
Posts: 1,116
I8URLS1 I8URLSX
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

Does the engine studder and bog really bad under hard acceleration? If that's the case it may be you Mass Air Flow sensor.. I accidently unpluged my MAF sensor one time and forgot to plug it in and it ran like hardcore ****. It would bog really hard and the engine would hardly rev at all.
__________________
Quote:
ORIGINAL: Sidewayz6.0
Ah, my bad. I'm just baffled that this guy has all these mods and he's worried about a procharged Cobra?
1986 Mustang - SOLD
1985 Fiero 5.0 - 14 -0
2008 Mustang - DD race car
redmustang83596 is offline   Reply With Quote
Old 05-11-2006, 09:58 PM   #9
Liquid_02
4th Gear Member
 
Join Date: May 2005
Vehicle: 92 GT
Location:
Posts: 1,267
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

Quote:
ORIGINAL: aode06

engine did a code 41 when it told me to tap the accelerator , which is 02 sensor signal, guess there bad, ill add exhaust and replace them i guess,
ANY ADVICE>>???



also did a code 33 egr, I know but thats cause i blocked the passage, with spacer.
Yah, O2s dont do that... I have open headers w/ no O2's in a video (check "What H/I" on this page, it's in there..), had it revved to probably about 4500 or so with a few quick snaps of the throttle, so that's not your problem.

MAF neither, my MAF wasn't working in that video (wrong MAF), that's why it always stalled apparently, disconnected it and it purred (MAF was connected in that vid)
Liquid_02 is offline   Reply With Quote
Old 05-13-2006, 05:53 PM   #10
aode08
5th Gear Member
 
Join Date: Oct 2005
Vehicle: 91 Mustang GT
Location: Ohio USA
Posts: 4,614
Default RE: Engine Does Not Rev Past 3000 RPMS, Bad Cold Idle

what is the setting for WOT AT THE tps, I KNOW IDLE .98-.99


Iwas at 1100 rpm - bad , ecm told me out of range on idle. TPS 1.00

I set idle to 750pm , and tps .99 -

Second - timing was at 19 * set it down some 13* , motor purs now, havent drove yet to do rpm test , still loud! lol[:-]
__________________



347 , 11:1 Compression,Knife Edged Lightened Crank,AFR 185,Ported Trick-flow Intake,Ford X-CAM,Under-drive pulleys,aluminum drive-shaft, 3:73 gears,Fender Cold Air Intake,Long tube headers,MSD Digital Ignition System
Lightened chassis.

451HP 439 FtLbTrq. mid 10 second car !
aode08 is offline   Reply With Quote
Old 05-13-2006, 05:53 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
3000, 3500, 50, bad, engiine, foxbody, idle, mustang, past, rev, revving, rough, rpm, rpms, studdering

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:34 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup