Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-09-2008, 09:51 PM   #1
red90GT
 
Join Date: Sep 2007
Location:
Posts: 13
Default 5.0 holding back under load

90 GT..although it is running great after a good seafoaming..the engine feels like it holds back in 3rd gear about 2400rpm unless i give it more throttle. 4th gear same thing. now it still has stock headers and stock H with all cats. 180000 on the clock and the cats are original. could this be where the hold back is from? if i bought shortys and a catted H pipe could this solve problem? all sensors have been changed and codes are all clear. maf cleaned and tps set at .98. new plugs everything like i said the motor doesnt hesitiate at all it just seems that under load light throttle it holds back. thanks
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
red90GT is offline   Reply With Quote
Old 02-09-2008, 09:53 PM   #2
notchbackmatt87
3rd Gear Member
 
Join Date: Oct 2006
Location:
Posts: 938
Send a message via AIM to notchbackmatt87
Default RE: 5.0 holding back under load

ever do a tune up. plugs cap rotor, wires? fuel filter? air filter?
notchbackmatt87 is offline   Reply With Quote
Old 02-09-2008, 09:55 PM   #3
red90GT
 
Join Date: Sep 2007
Location:
Posts: 13
Default RE: 5.0 holding back under load

yes. although i am using the autolite platinum plugs. CAI bbk month old. msd 8.5mm wires with cap and rotor. blaster coil
red90GT is offline   Reply With Quote
Old 02-09-2008, 09:56 PM   #4
notchbackmatt87
3rd Gear Member
 
Join Date: Oct 2006
Location:
Posts: 938
Send a message via AIM to notchbackmatt87
Default RE: 5.0 holding back under load

could possibly be a clogged cat or partically clogged cat.
notchbackmatt87 is offline   Reply With Quote
Old 02-09-2008, 09:58 PM   #5
red90GT
 
Join Date: Sep 2007
Location:
Posts: 13
Default RE: 5.0 holding back under load

thanks. i never ran into an experience cat related. it doesnt smell like anything or set off the SES so i didn't know. thanks for your fast replys man..
red90GT is offline   Reply With Quote
Old 02-09-2008, 11:09 PM   #6
mjr46
Wal-mart lube/tire tech
 
mjr46's Avatar
 
Join Date: Jun 2007
Vehicle: 85 mustang
Location: West Virginia
Posts: 30,006
Default RE: 5.0 holding back under load

loosen the exhaust and run it like that and see if the lack of power clears up.. or pull out the o/2's and run it like that..and yes the car will still run without the o2's in...your just doing it for diagnostic purpose so it won't harm it for the short time up the road and back you do it for
__________________

Quote:
Originally Posted by dudegirl View Post
Be polite and cordial when you talk to them, as pissing off the guys that can help you is seldom a good idea.
mjr46 is offline   Reply With Quote
Old 02-09-2008, 11:09 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1993, 50, back, holds, mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
COP Information devongarver 4.6L (1996-2004 Modular) Mustang 25 08-01-2012 07:23 PM
car is falling flat on its face at like 3500-4k. justinschmidt1 4.6L (1996-2004 Modular) Mustang 157 08-18-2009 09:53 PM

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 01:50 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup