Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-15-2011, 11:36 AM   #1
Super88

 
Join Date: Jun 2011
Vehicle: 1988 Mustang LX
Location: Louisiana
Posts: 33
Default 1988 5.0 wont start

1988 5.0 wont start. Its converted to carb with a barry grant speed demon 650 carb. brand new MSD 6AL digital ignition. its getting fuel to the carb, i can see it and smell it. it occasionally backfires through the carb, but when i pull the spark plugs they are completely dry. what could be causing this?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
1988 5.0 LX
E303 cam, GT-40 heads, edelbrock performer intake, Demon 650 cfm carb, Hooker shortie, O/R H-pipe, Flow super 40s, T-5 transmission(2.95 first), 4.11 gears
3" Cowl hood
Super88 is offline   Reply With Quote
Old 09-15-2011, 01:20 PM   #2
mustangGT86_05
3rd Gear Member
 
mustangGT86_05's Avatar
 
Join Date: Mar 2011
Vehicle: 1986 Ford Mustang GT
Location: OH
Posts: 829
Default

Have you checked the timing?
mustangGT86_05 is offline   Reply With Quote
Old 09-15-2011, 03:39 PM   #3
Super88

 
Join Date: Jun 2011
Vehicle: 1988 Mustang LX
Location: Louisiana
Posts: 33
Default

It was running before i put the new ignition in and i didnt mess with the timing. i know im getting spark, i checked multiple times on multiple plugs. it acts like its not gettin fuel to the cylinders
__________________
1988 5.0 LX
E303 cam, GT-40 heads, edelbrock performer intake, Demon 650 cfm carb, Hooker shortie, O/R H-pipe, Flow super 40s, T-5 transmission(2.95 first), 4.11 gears
3" Cowl hood
Super88 is offline   Reply With Quote
Old 09-15-2011, 03:39 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1988, 50, 6al, 88, digital, dry, e303, ford, gt40, heads, issue, msd, mustang, sounds, start, starting, timing, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:27 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup