Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-12-2012, 02:39 PM   #1
BaltRavens
2nd Gear Member

 
Join Date: Aug 2011
Vehicle: 1994 5.0 Mustang
Location: WV
Posts: 192
Default 5.0 Idles rough then dies

1995 GT

When you start it up it fires up just fine no delays etc. but it will rough up and down, until it dies, unless you give it gas. It bounces back and forth between 900-1500RPMs give or take a few hundred here and there without giving it gas until it dies, it will only stay running for about 5-10secs.

When you do give it gas and attempt to hold it at say 3000RPMs it will have some issues constantly holding 3000, it won't jump up, but it will jump down, or miss, and fall to around 2400RPMs and jump back up.

If you attempt to drive it, the car has a loss of power and has a bit of a hesitate and feels like its struggling at times when you give it gas. It will also NOT go past 4000RPMs on the open highway, it stalls at 4000RPMs. I thought it could be blown head gaskets, but I am not sold on that. I haven't noticed a loss in fluids and my oil is very clean, and my car seemed to run at a pretty normal temperature.

I am in the middle of all that jazz of buying a home so my wife is leaving me no room to mess with my toys... so I am just browsing ideas/brainstorming in the mean time. I probably won't have the car looked over / fixed until late spring. I am just looking for ideas and opinions for now, thanks!


Here are some of the mods
Cobra Upper Intake
Gt40 Lower Intake
GT40P Heads
BBK 70MM TB
Professional Products FPR
Walbro 255 fuel pump
24# injectors
Scorpion 1.72 Roller Rockers
MAC CAI
MAC Shorty headers
Under Drive Pulleys
UPR X Pipe (2.5")
Mac Pro Dumps
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
BaltRavens is offline   Reply With Quote
Old 01-12-2012, 04:30 PM   #2
javila2468
2nd Gear Member

 
Join Date: Dec 2011
Vehicle: 1989 Ford Mustang
Location: TX
Posts: 189
Default

Clean out your MAF sensor
javila2468 is offline   Reply With Quote
Old 01-12-2012, 04:32 PM   #3
javila2468
2nd Gear Member

 
Join Date: Dec 2011
Vehicle: 1989 Ford Mustang
Location: TX
Posts: 189
Default

similar issue with my 89 mustang. mine would rev perfect when in neutral but once I hit the road it would feel like if it was being held down by a school bus. i cleaned the MAF and CAI pipes, let it dry and reinstalled and it worked just fine afterwards.
javila2468 is offline   Reply With Quote
Old 01-12-2012, 10:48 PM   #4
BaltRavens
2nd Gear Member

 
Join Date: Aug 2011
Vehicle: 1994 5.0 Mustang
Location: WV
Posts: 192
Default

Simple stuff I will try it t/m and see what happens, minor stuff like this I can do myself.

Thanks!
BaltRavens is offline   Reply With Quote
Old 01-13-2012, 06:14 AM   #5
jojobanks
2nd Gear Member
 
jojobanks's Avatar
 
Join Date: Oct 2011
Vehicle: 70 mustang HT
Location: AL
Posts: 446
Default

you may also have a vacuum leak somewhere
jojobanks is offline   Reply With Quote
Old 01-13-2012, 08:11 PM   #6
Bubba 95SN
4th Gear Member
 
Join Date: Apr 2009
Vehicle: 1995 Ford Mustang GT
Location: N.C.
Posts: 1,891
Default

Codes, fuel presure?
Bubba 95SN is offline   Reply With Quote
Old 01-13-2012, 08:59 PM   #7
AdderMk2
Banned
 
Join Date: Dec 2005
Vehicle: 94 Cobra
Location: Lil' Rhody
Posts: 22,376
Send a message via AIM to AdderMk2
Default

mods list does not show a calibrated MAF sensor... put 19# injectors back in the car, or get it tuned.
AdderMk2 is offline   Reply With Quote
Old 01-14-2012, 01:07 PM   #8
BaltRavens
2nd Gear Member

 
Join Date: Aug 2011
Vehicle: 1994 5.0 Mustang
Location: WV
Posts: 192
Default

Quote:
Originally Posted by AdderMk2 View Post
mods list does not show a calibrated MAF sensor... put 19# injectors back in the car, or get it tuned.
This is what I thought was the issue, the car needing a tune. I had plans to get it tuned. The issue I am having just came about, the car run fine for months then just over night this problem happened. I don't think the car will even drive to the shop for a tune its that bad. Would a issue like I am having come about over night from needing a tune?

I cleaned the MAF but that did nothing it still does the same thing.
BaltRavens is offline   Reply With Quote
Old 01-14-2012, 09:05 PM   #9
SmallblockPower
 
Join Date: Jan 2012
Vehicle: 1991, Ford, Mustang GT
Location: New Hampshire
Posts: 9
Default

It's a possibility that you may have a plugged fuel filter, if you have one, I know I put one in mine just to check out how clean the gas tank was when I first bought mine. The rough idle may be either fuel flow, vacuum malfunction, or even timing. Those will play a role in it. But with the mods you do have I cannot tell unless I'm actually there. That's my best hypothesis.
SmallblockPower is offline   Reply With Quote
Old 01-15-2012, 12:00 PM   #10
BaltRavens
2nd Gear Member

 
Join Date: Aug 2011
Vehicle: 1994 5.0 Mustang
Location: WV
Posts: 192
Default

Quote:
Originally Posted by SmallblockPower View Post
It's a possibility that you may have a plugged fuel filter, if you have one, I know I put one in mine just to check out how clean the gas tank was when I first bought mine. The rough idle may be either fuel flow, vacuum malfunction, or even timing. Those will play a role in it. But with the mods you do have I cannot tell unless I'm actually there. That's my best hypothesis.
Yes its tough because it could be many things, its been snowing here past week. I haven't had any clean/warm weather to get under the car and change the fuel filter or to really mess with the car. I am going to give it a overlook when it warms up before I take it to the shop.
BaltRavens is offline   Reply With Quote
Old 01-15-2012, 12:00 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1991, 1994, 2011, 50, dies, ford, gas, give, gt, idels, idle, idles, mustang, rough, runs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 10:06 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup