Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 12-09-2012, 07:25 PM   #1
hansbro89
 
Join Date: Dec 2012
Vehicle: 1991 ford mustang gt
Location: kentucky
Posts: 8
Exclamation 91 5.0 gt starts but dies when gave gas

my car was running perfect then ran out of gas and so i put 20 in and made it home it aint been running sence it will start but when u try to give it gas sometimes it will hesitate and fire up to 3000 then go back down and die and other times it will die as soon as u hit the gas. also it only idles if maf is unpluged sonn as u plug it in it will die. and i dont kno if this has anything to do with it but there is no gas comeing back trough the return to the tank plz help me somebody
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
hansbro89 is offline   Reply With Quote
Old 12-09-2012, 07:26 PM   #2
hansbro89
 
Join Date: Dec 2012
Vehicle: 1991 ford mustang gt
Location: kentucky
Posts: 8
Default

aslo i have new fuel pump and filter
hansbro89 is offline   Reply With Quote
Old 12-09-2012, 08:05 PM   #3
rmodel65
Yukon Cornelius
 
rmodel65's Avatar
 
Join Date: Oct 2005
Vehicle: 1965, ford, mustang fastback
Location: deep in the heart of dixie GEORGIA
Posts: 11,612
Send a message via AIM to rmodel65 Send a message via MSN to rmodel65 Send a message via Yahoo to rmodel65
Default

what brand is the fuel pump? if its airtek its probably bad even if its new
rmodel65 is offline   Reply With Quote
Old 12-09-2012, 09:47 PM   #4
hansbro89
 
Join Date: Dec 2012
Vehicle: 1991 ford mustang gt
Location: kentucky
Posts: 8
Default

yea thats the brand my fuel pump runs constintly thats the way it was wired when i got it
hansbro89 is offline   Reply With Quote
Old 12-09-2012, 10:01 PM   #5
dawson1112
5th Gear Member

 
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,586
Default

Take the vaccum line off the fuel pressure regulator and plug it , then see if it runs better or worse. The vacuum side should be dry with no fuel in it if there is fuel on that side the reulator is bad. Also since you ran it out of fuel change the fuel filter because it has probly sucked up a lot junk from the tank. and that's why your not getting any or little return it just isn't pumping enough to even keep the car running so its not gonna send any back
__________________
dawson1112 is offline   Reply With Quote
Old 12-09-2012, 11:12 PM   #6
rmodel65
Yukon Cornelius
 
rmodel65's Avatar
 
Join Date: Oct 2005
Vehicle: 1965, ford, mustang fastback
Location: deep in the heart of dixie GEORGIA
Posts: 11,612
Send a message via AIM to rmodel65 Send a message via MSN to rmodel65 Send a message via Yahoo to rmodel65
Default

airtek is crappy...if you test your pressure i bet it drops like crazy anything above idle...id take that garbage back and get a walbro(holley pumps are also walbro)
rmodel65 is offline   Reply With Quote
Old 12-10-2012, 12:34 AM   #7
94redGTConv
2nd Gear Member
 
94redGTConv's Avatar
 
Join Date: Sep 2012
Vehicle: 1994,Ford,Mustang GT
Location: Tennessee
Posts: 161
Tunefully Tunefully
Default

Dawson beat me to it, I'd put my money on filter picking up the bottom of the barrel gas


Posted from MustangForums.com App for Android
__________________
"If you ain't first you're last"
94redGTConv is offline   Reply With Quote
Old 12-10-2012, 05:41 PM   #8
hansbro89
 
Join Date: Dec 2012
Vehicle: 1991 ford mustang gt
Location: kentucky
Posts: 8
Default

thanks for everything every body ima try all everthing yall said and let yall kno how it goes
hansbro89 is offline   Reply With Quote
Old 12-10-2012, 06:12 PM   #9
rmodel65
Yukon Cornelius
 
rmodel65's Avatar
 
Join Date: Oct 2005
Vehicle: 1965, ford, mustang fastback
Location: deep in the heart of dixie GEORGIA
Posts: 11,612
Send a message via AIM to rmodel65 Send a message via MSN to rmodel65 Send a message via Yahoo to rmodel65
Default

im still gonna say its the airtek pump...i went through 3 in less than 3 months...finally bought a real pump and no more problems.
rmodel65 is offline   Reply With Quote
Old 12-11-2012, 12:57 PM   #10
hansbro89
 
Join Date: Dec 2012
Vehicle: 1991 ford mustang gt
Location: kentucky
Posts: 8
Default

new pump will be here in the morning and the brand was bestest lol
hansbro89 is offline   Reply With Quote
Old 12-11-2012, 12:57 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:30 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup