Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-27-2013, 10:44 AM   #11
lavertue
 
Join Date: Jul 2012
Vehicle: 1991 Mustang Gt
Location: Florida
Posts: 20
Default

Hmmm, stumped again. My meter wasn't getting juice last night, but my tps is good. Any other ideas on what to check? I still haven't figured out how to read my codes.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
lavertue is offline   Reply With Quote
Old 02-27-2013, 07:22 PM   #12
Borisbadenov
 
Join Date: Feb 2013
Vehicle: 1998 Ford Mustang
Location: Kentucky
Posts: 9
Default

Does the oil pressure switch have a fuel cut off ?
Borisbadenov is offline   Reply With Quote
Old 02-27-2013, 08:13 PM   #13
mattdel
6th Gear Member
 
mattdel's Avatar
 
Join Date: Nov 2006
Vehicle: 1986 LX, 87 GT Hatch, 89 GT Vert
Location: Spfld, MA
Posts: 9,240
Send a message via AIM to mattdel
Default

Nope.
__________________
mattdel is offline   Reply With Quote
Old 02-27-2013, 11:55 PM   #14
lavertue
 
Join Date: Jul 2012
Vehicle: 1991 Mustang Gt
Location: Florida
Posts: 20
Default

I still can't figure out this check engine light thing. Anyone in the Tampa, Florida Area? Haha.
lavertue is offline   Reply With Quote
Old 02-28-2013, 04:07 PM   #15
rbowmar
2nd Gear Member
 
Join Date: Jun 2012
Vehicle: 2005 Mustang v6 Coupe. CAI Tune, Magnaflo Duals, Eibach lowering springs
Location: Littleton, Colorado
Posts: 246
Default

Since the problem started right after installing your new fuel pump, that seems the logical place to start. New components don't always work right. Electric connections don't always hook up properly. Anything you touched in the process might have been mis-installed, or dirt, bits of gaskets, etc. may have been dislodged. Dirt in the tank may be blocking fuel pickup.

To avoid checking everything in the fuel system, I check the fuel pressure at the fuel pressure relief valve as that pressure will only be correct if everything upstream is working.

To conduct the test:
Disconnect power, Remove the fuel pressure relief valve cap and attach a fuel pressure test gauge. Attach power and crank the engine. Look for 30 to 45 pounds per square inch. Pressure that's too high can indicate that the pressure regulator is malfunctioning. Pressure that's too low indicates fuel filter, fuel pump or clogging problems


I hope this is helpful
__________________
B]2005 V6[/B] .Manual, Eibach Sport Springs, Magnaflow Duals, CAI, Tune 17/9.5" Bullit Wheels.

2003 V6
. Manual, Stalker F/R body kit, 600w stereo amp.

1999 V6.. Manual, CAI, High Performance Cats, High Flow single exhaust, Tune.

1972 Mach1. Built 351W, C4 w/shift kit, Long headers, Flowmaster 40s w/custom duals. Eibach Sport lowering springs. Kyb shocks, New paint and stripes, Custom seats, Fresh red clearcoat paint and mach1 stripes.
rbowmar is offline   Reply With Quote
Old 03-02-2013, 10:57 AM   #16
lavertue
 
Join Date: Jul 2012
Vehicle: 1991 Mustang Gt
Location: Florida
Posts: 20
Default

Quote:
Originally Posted by rbowmar View Post
Since the problem started right after installing your new fuel pump, that seems the logical place to start. New components don't always work right. Electric connections don't always hook up properly. Anything you touched in the process might have been mis-installed, or dirt, bits of gaskets, etc. may have been dislodged. Dirt in the tank may be blocking fuel pickup.

To avoid checking everything in the fuel system, I check the fuel pressure at the fuel pressure relief valve as that pressure will only be correct if everything upstream is working.

To conduct the test:
Disconnect power, Remove the fuel pressure relief valve cap and attach a fuel pressure test gauge. Attach power and crank the engine. Look for 30 to 45 pounds per square inch. Pressure that's too high can indicate that the pressure regulator is malfunctioning. Pressure that's too low indicates fuel filter, fuel pump or clogging problems


I hope this is helpful
I will give this a try, I need to locate a gauge that I can borrow, but I will find one and test it out, and let you guys know the results.
lavertue is offline   Reply With Quote
Old 03-02-2013, 03:36 PM   #17
dragline
2nd Gear Member
 
dragline's Avatar
 
Join Date: Sep 2010
Vehicle: 2011 Ford Mustang 5.0
Location: TX
Posts: 160
Default

this sounds very similar to the problem the engine in my factory five roadster is currently exhibiting. i ran it out of gas a couple of weeks back and she's not real happy with me right now. new fuel filter, plugs, cleaned iac and throttle body, can of seafoam in the tank. seemed to solve the problem until i was driving it yesterday. terrible idle. sputters something awful under load. blowing black smoke. anyway, fwiw, my local oreilly auto parts store will "rent" the fuel pressure gauge set up. they put a charge on your credit card they then reverse when you bring it back.
__________________
2011 GT 5.0 daily driver. FF Roadster for goofing off on weekends (when it's running).
dragline is offline   Reply With Quote
Old 03-02-2013, 03:36 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:34 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup