Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-25-2013, 01:02 AM   #1
88__coupe
 
Join Date: Apr 2013
Vehicle: 1988 For Mustang Coupe
Location: California
Posts: 2
Default Help me please...

I'm a new member, someone advised me to join a forum to see if I can get Frankenstein running properly. I bought a 88 coupe that was originally a 4 cylinder but has a v8 swap. I finally got the car running... now the fun part begins. The only Gauges that work on the dash are the battery and fuel gauge, every thing else does not work. I need some type of guidance of where to start troubleshooting. Any ideas?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
88__coupe is offline   Reply With Quote
Old 04-25-2013, 05:27 AM   #2
dawson1112
5th Gear Member

 
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,635
Default

Youll have to add some info about the swap .... Did they put a 302 v8 with a carb or did they use a 5.0 ho fuel injected engine. With out knowing a lot of variables on the swap , it may be much easier to get some after market gauges and be done with it.

Did they also swap out the dash cluster with the v8 . The v8 cluster differs from the 4 bangers. Does the speedo work ? No fuel gauge means they probly disconnected the wires from the tank.
__________________
dawson1112 is offline   Reply With Quote
Old 05-02-2013, 11:33 PM   #3
88__coupe
 
Join Date: Apr 2013
Vehicle: 1988 For Mustang Coupe
Location: California
Posts: 2
Default

Well it has a 5.0 HO motor in it,fuel Injection, 5 speed.. Let see, it still has the 4 banger 85mph cluster ( I have a 160mph one I want to put in), speedo does not work, rpm kinda works, only goes up to 2k when it wants..battery gauge works, fuel gauge is always full? Temp gauge does not work, oil gauge does not work. I doesn't affect the performance of the car, I just want my cluster working properly it finally got annoying.
88__coupe is offline   Reply With Quote
Old 05-02-2013, 11:33 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:22 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup