MustangForums.com

MustangForums.com (http://mustangforums.com/forum/index.php)
-   5.0L (1979-1995) Mustang (http://mustangforums.com/forum/5-0l-1979-1995-mustang-14/)
-   -   1991 Mustang Convertible Top won't go down (http://mustangforums.com/forum/5-0l-1979-1995-mustang/694103-1991-mustang-convertible-top-wont-go-down.html)

jnoback 04-25-2013 12:17 PM

1991 Mustang Convertible Top won't go down
 
1 Attachment(s)
I have a 1991 5.0 Convertible Mustang and the top won't go down. When you push the button, it doesn't do anything. There is no noise of a motor running or anything else, only silence. I tried replacing the fuse and that didn't help. Any suggestions would be appreciated.Attachment 34153

dawson1112 04-25-2013 01:29 PM

I would go to the back and find the motor that operates the top and confirm that it is getting power when the switch is pressed. If it is getting power back there then chances are the motor is no good. If you get no power to the motor then the relay is probly not any good or you have a bad ground . Im not a vert guy but I have messed with some different models , they usually use an electric motor running a hydraulic pump. Ive seen the lines crack and loose all the fluid out of the pump then the motor turns but the top does nothing and some of the motors are so quiet you can only tell there running if you have someone hit the switch while your back at the motor listening.

BabyGT 04-25-2013 02:49 PM

Emergency brake has to be up for the top to operate.

dwb91lx 04-28-2013 08:05 PM

Quote:

Originally Posted by BabyGT (Post 8201308)
Emergency brake has to be up for the top to operate.

That's not true on mine (the E-brake)... My top will sometimes glitch when I stop it greater than or less than 1/2 way (when I'm tucking material or avoiding the scissor action on the material)....The trick that usually works is to manually lift the top while operating the switch...kinda like push starting. Avoid letting the frame settle (on it's own). If I need to stop it midway, it is always best to stop it straight up...or give it a helping hand to avoid the settling. It's happened plenty of times (10+) & I've always gotten it to work...knock on wood.

rmodel65 04-28-2013 08:43 PM

ive never had to manually do anything with my top...in fact the fox mustang was praised at the time for having a top that was as fast or faster than a benz vert when it came out...like said above you need to see if you are getting power...it might just be a bad top if it was running and not moving anything i would say its low on Auto trans fluid in the top motor.

craig71springsport 04-28-2013 10:49 PM

No juice to your top motor is my guess. Or the motor itself is bad, like others are saying just get a tester and test the lines going to it. I would check CL for the motor, they get pricey IIRC.

dwb91lx 04-29-2013 08:04 AM

always try the easy effort stuff first, motor diagnosis takes more effort & tear down...you'll want to remove back seat & trunk interior trim to get a good look @ the motor for fluid, relay checks, etc.

rmodel65 04-29-2013 09:37 AM

Quote:

Originally Posted by craig71springsport (Post 8203375)
No juice to your top motor is my guess. Or the motor itself is bad, like others are saying just get a tester and test the lines going to it. I would check CL for the motor, they get pricey IIRC.



iirc the top motor is the same from 1965-2004 so they are pretty easy to find. ive seen fox vert 4 cylinder cars for 400$ could always buy one of those and get the top motor and sell the hull for scrap=free top motor and any other parts switches, wiring etc you need

7 UP Mustang 04-29-2013 10:23 AM

MY 1990 LX has two relays, and one went out. The easy thing to do is to swap the relays around since they are plug in types. One is used for UP and one is used for DOWN. In my case a new relay fixed my problem. Good luck!

89StangGTConvertible 04-29-2013 04:58 PM

Yep - check relays first, then pull back seat and see if you're getting juice to the motor when the switch is activated. Hoping it's just a bad relay. Good luck and post back when you find out what the issue was, as it may prove helpful to someone else who is experiencing the same issue.

mebirkle 05-06-2013 07:55 PM

Hi,

I have the same problem with my top. It just makes a really fast click in the back when I push the button and the motor doesn't do a thing. Is there a relay at the motor as well? i guess that click would mean the relay is working, but it's worth a shot.

i ended up putting the top manually down... what a pain. And putting it up manually is a huge pain as well. You need to be a muscle-brain to budge that thing.

I just reglued my rear window with rhino glue over the weekend and had the top in various positions to do just that. I wonder if I somehow tweaked the motor.

I have every tool but a freaking multi-meter. I guess I'll try a test light.

We'll see....

aleos15 03-01-2014 01:02 PM

I'm having the same issue with my 89 vert. except when i push the button on mine i here the motor working. it acts like it wants to go down but it won't. can someone help plz?

Krochus 03-01-2014 01:11 PM

It was the motor in my convertable which is fairly common from what I gather.

If you remove the pins that hold the top frame to the actuator cylinders it becomes much easier to operate manually which is how I "fixed" mine.

www.licarcommunity.com 03-01-2014 01:26 PM

Possible wiring issues
 
Remember to always start with the simplest things first, grab a test light and check your fuses (all your fuses) because even if your convertible top motor fuse is good, another bad fuse might ruin your day. If fuses are good check for a relay (if any) if your getting juice out of the relay go to the motor, and ultimately if your getting juice out of the motor's plug then your motor is bad. I'm very confident your local junkyard would have this part.

mjr46 03-02-2014 12:08 PM

Quote:

Originally Posted by www.licarcommunity.com (Post 8356253)
. I'm very confident your local junkyard would have this part.

I'm not...........this is 2014......not the 90's anymore.......most of these cars are long gone from a boneyard and if any exist, they've been well picked clean.......mustang specialty yards may have such but doubtfully at a local boneyard

Krochus 03-02-2014 03:53 PM

Quote:

Originally Posted by mjr46 (Post 8356562)
I'm not...........this is 2014......not the 90's anymore.......most of these cars are long gone from a boneyard and if any exist, they've been well picked clean.......mustang specialty yards may have such but doubtfully at a local boneyard

I agree. The possibility of stumbling across this oft failed part from a salvage yard in working condition is going to be highly unlikely.

What's more likely to happen is you pay for one that doesn't end up working either

rmodel65 03-02-2014 08:19 PM

Quote:

Originally Posted by aleos15 (Post 8356247)
I'm having the same issue with my 89 vert. except when i push the button on mine i here the motor working. it acts like it wants to go down but it won't. can someone help plz?


probably low on ATF fluid.


All times are GMT -5. The time now is 04:29 PM.