Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-27-2013, 08:32 PM   #1
marlyman
2nd Gear Member
 
marlyman's Avatar
 
Join Date: May 2008
Vehicle: 1988 ford mustang
Location: california
Posts: 267
Default could it be driverseat fuel pump relay ?

Been having some electrical issues when i turn key to on position(not crank it) my fuel pump doesnt prime/turn on...was lookin at crank ok but no start checklist and i folowed my diagrams (veryuseful.com) and im getting power all the way to the fuel pump relay unders driver seat but not to fuel pump...but when i turn to on position the relay makes a "click" sound and i've heard if it clicks that means its working...or could it still be bad ?

I got a long like 12gauge wire an ran from battery to touch underside of relay on certain wires an im able to turn on the pump that way so has to be relay?

Im going to test all the wires off of the relay, find constant 12v then try an find wire that goes to pump from relay and if it doesnt get power when in on position it would have to be the relay right?

I bought a relay/sensor kit awhile back and i got a new fuel pump relay but it looks different and has 1 more wire that the stock relay has going to it...? anyone know ill post pics in a sec to better explain...
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
marlyman is offline   Reply With Quote
Old 04-28-2013, 06:13 AM   #2
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,676
Default

Id just get a new relay and put it in..... 10 bucks is far cheaper than my time spent troubleshooting the circuit. And hell if that's not the problem your can return the relay as long as its still in good condition.
__________________
dawson1112 is online now   Reply With Quote
Old 04-28-2013, 06:13 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:00 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup