Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-14-2013, 11:48 AM   #1
dmr
 
Join Date: May 2013
Vehicle: 1995 Mustang GT Conv.
Location: Indiana
Posts: 2
Default 1995 wiper problem

The wipers on my 1995 Mustang GT will not turn off. I have replaced the control on the column and the wiper motor with no luck. Ant suggestion what to try next. The speeds for low to high work.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
dmr is offline   Reply With Quote
Old 05-15-2013, 03:42 PM   #2
89StangGTConvertible
2nd Gear Member

 
89StangGTConvertible's Avatar
 
Join Date: Jan 2011
Vehicle: 1989 Ford Mustang GT Convertible
Location: Maryland
Posts: 158
Default

a quick thought is that there is a ground fault somewhere... simple fix, however, may be to replace the wiper relay: https://www.carpartsdiscount.com/aut...317687&slide=3
__________________

Last edited by 89StangGTConvertible; 05-15-2013 at 03:58 PM.
89StangGTConvertible is offline   Reply With Quote
Old 05-15-2013, 04:16 PM   #3
7 UP Mustang
1st Gear Member
 
7 UP Mustang's Avatar
 
Join Date: Jan 2005
Vehicle: 1990 5.0 HP LX 7 UP Edition and 2013 Premium Convertible
Location: Corryton, TN 37721
Posts: 116
Send a message via AIM to 7 UP Mustang Send a message via Yahoo to 7 UP Mustang
Default

Check the wiper switch and or wiring up to the wiper relay. Sounds like the relay is being energized all the time. If so the new relay will do the same thing.

Good Luck!
Larry
__________________

1990 LX 5.0 HP Convertible Known as 7 UP Edition

2013 GB Premium Convertible V6 Auto with performance package.
7 UP Mustang is offline   Reply With Quote
Old 05-15-2013, 04:16 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:48 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup