MustangForums.com

MustangForums.com (http://mustangforums.com/forum/index.php)
-   5.0L (1979-1995) Mustang (http://mustangforums.com/forum/5-0l-1979-1995-mustang-14/)
-   -   broken oil fill tube (http://mustangforums.com/forum/5-0l-1979-1995-mustang/708285-broken-oil-fill-tube.html)

StlJimmy 03-28-2014 04:12 PM

broken oil fill tube
 
Just got this car and when I tried to unscrew the cap I noticed the entire neck was moving and it was all gooed up with black RTV. I tried to get one at the junkyard but I am at a loss on how these even come off? What are my options here? I am hoping you guys are going to tell me I don't have to pull the valve covers and there is a simple fix:)?

http://s999.photobucket.com/user/stl...]=1&sort=1&o=0

http://s999.photobucket.com/user/stl...]=1&sort=1&o=1

dawson1112 03-28-2014 04:26 PM

I cant see your pics or open the links, but Im going to say replace the valve cover and be done with it.

StlJimmy 03-28-2014 04:32 PM

oh no! dawson111, that isn't what I wanted to hear, lol. Thanks though

StlJimmy 03-28-2014 04:34 PM

http://s999.photobucket.com/user/stl...tml?sort=3&o=0

Lets see if the pic shows up now

mjr46 03-28-2014 08:30 PM

you need a new set of valve covers....I have a stock set that are in good shape, pm if interested

TOOT 03-30-2014 06:27 PM

What they both said. I had the same problem with my 02, I tried every glue under the sun some worked better than others but ultimately it need to be replaced.


All times are GMT -5. The time now is 07:37 PM.