Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-28-2014, 04:12 PM   #1
StlJimmy
 
StlJimmy's Avatar
 
Join Date: Mar 2014
Vehicle: 1993 GT Vert
Location: MO
Posts: 3
Default broken oil fill tube

Just got this car and when I tried to unscrew the cap I noticed the entire neck was moving and it was all gooed up with black RTV. I tried to get one at the junkyard but I am at a loss on how these even come off? What are my options here? I am hoping you guys are going to tell me I don't have to pull the valve covers and there is a simple fix?

Click the image to open in full size.

Click the image to open in full size.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
StlJimmy is offline   Reply With Quote
Old 03-28-2014, 04:26 PM   #2
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,678
Default

I cant see your pics or open the links, but Im going to say replace the valve cover and be done with it.
__________________
dawson1112 is offline   Reply With Quote
Old 03-28-2014, 04:32 PM   #3
StlJimmy
 
StlJimmy's Avatar
 
Join Date: Mar 2014
Vehicle: 1993 GT Vert
Location: MO
Posts: 3
Default

oh no! dawson111, that isn't what I wanted to hear, lol. Thanks though
StlJimmy is offline   Reply With Quote
Old 03-28-2014, 04:34 PM   #4
StlJimmy
 
StlJimmy's Avatar
 
Join Date: Mar 2014
Vehicle: 1993 GT Vert
Location: MO
Posts: 3
Default

http://s999.photobucket.com/user/stl...tml?sort=3&o=0

Lets see if the pic shows up now
StlJimmy is offline   Reply With Quote
Old 03-28-2014, 08:30 PM   #5
mjr46
Wal-mart lube/tire tech
 
mjr46's Avatar
 
Join Date: Jun 2007
Vehicle: 85 mustang
Location: West Virginia
Posts: 30,006
Default

you need a new set of valve covers....I have a stock set that are in good shape, pm if interested
__________________

Quote:
Originally Posted by dudegirl View Post
Be polite and cordial when you talk to them, as pissing off the guys that can help you is seldom a good idea.
mjr46 is offline   Reply With Quote
Old 03-30-2014, 06:27 PM   #6
TOOT
3rd Gear Member
 
TOOT's Avatar
 
Join Date: Jun 2006
Vehicle: 89 Gt 5.0
Location: Pa
Posts: 640
Default

What they both said. I had the same problem with my 02, I tried every glue under the sun some worked better than others but ultimately it need to be replaced.
__________________
89 GT- Forged Internals*Stage 3 clutch*E303 cam*BBK shorties*Catted H pipe*Flowmasters dumped*3.73 gears
TOTALED 02 BLACK GT
BBK O/R X*FLOWMASTER C/B*MAGNA PACKS*JLT RAM AIR*BBK 70MM TB*TRICK FLOW PLENUM*STEEDA U.D. PULLEYS*HURST BILLET/ PLUS SHIFTER*WELDED SUB FRAME CONNECTORS*SCT X3 TUNED W. BRENSPEED CUSTOM TUNE*MOTIVE 3.90 GEARS*FRPP ALUMINUM DRIVE SHAFT *PIONEER AVIC D3 HEAD UNIT*180 STAT*NITTO NT555 315.35.17*NKG TR-55*FRPP C SPRINGS*MM BLACK C/C PLATES*COBRA BRAKES/ROTORS
TOOT is offline   Reply With Quote
Old 03-30-2014, 06:27 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 12:50 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup