94 mustang cobra - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-01-2014, 01:19 PM   #1
Js88lx
3rd Gear Member
Thread Starter
 
Js88lx's Avatar
 
Join Date: Jan 2011
Location: mid Cali
Posts: 837
Default 94 mustang cobra

Once again another prob..geesh! So now my battery light turned on and my volts dropped and dash lights dimmed. So I had the battery (interstate) tested and charged (passed). What else can this be?
Js88lx is offline   Reply With Quote
Old 07-01-2014, 01:26 PM   #2
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,199
Default

alternator
dawson1112 is offline   Reply With Quote
Old 07-01-2014, 01:34 PM   #3
bluebeastsrt
6th Gear Member
 
bluebeastsrt's Avatar
 
Join Date: Jun 2006
Location: Jersey
Posts: 11,518
Default

Yep. Or voltage regulator (located on the altanator). Those are pretty much all the sexy parts on the charging system.
bluebeastsrt is offline   Reply With Quote
Old 07-01-2014, 04:56 PM   #4
Js88lx
3rd Gear Member
Thread Starter
 
Js88lx's Avatar
 
Join Date: Jan 2011
Location: mid Cali
Posts: 837
Default

After I had the battery tested and charged I moved to the alternator. I had it tested at auto zone. 1st test failed, 2nd passed, 3rd passed, 4th failed, 5th failed. So I got a new one. Drove to work today and car ran fine..., but I don't think ive driven enough to really know. I hope I don't have a short somewhere.
I was also thinking about adding another ground to my motor. What you guys think?
Js88lx is offline   Reply With Quote
Old 07-01-2014, 06:59 PM   #5
bluebeastsrt
6th Gear Member
 
bluebeastsrt's Avatar
 
Join Date: Jun 2006
Location: Jersey
Posts: 11,518
Default

Id wait and see if you cured the problem with the new altanator.
bluebeastsrt is offline   Reply With Quote
Old 07-01-2014, 08:20 PM   #6
Maxwelhse
4th Gear Member
 
Join Date: Jan 2007
Location:
Posts: 1,108
Default

Extra ground sounds like a waste of cash. 99.9% it was the alternator. My '93 Escort just pulled that exact trick (working, not, working, not) and its not unusual.
Maxwelhse is offline   Reply With Quote
Old 07-02-2014, 05:54 PM   #7
Js88lx
3rd Gear Member
Thread Starter
 
Js88lx's Avatar
 
Join Date: Jan 2011
Location: mid Cali
Posts: 837
Default

Ok. Well 2 days now and no problems. Knock on wood. Just that darn bbk header still not sealing to head.. head nod.
Js88lx is offline   Reply With Quote
Old 07-02-2014, 07:13 PM   #8
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,199
Default

I had problems with my bbk headers not wanting to seal to my heads as well, I found that using the thicker aluminum gaskets worked.
dawson1112 is offline   Reply With Quote
Old 07-03-2014, 01:19 AM   #9
Js88lx
3rd Gear Member
Thread Starter
 
Js88lx's Avatar
 
Join Date: Jan 2011
Location: mid Cali
Posts: 837
Default

Is there an easy way of finging out whether its leaking from the head to header or header to xpipe? Today i put the stock header back on and tick was gone... sounded soo dam# good! I miss not having an exhaust leak!
Js88lx is offline   Reply With Quote
Old 07-03-2014, 02:36 AM   #10
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,199
Default

You should be able to look at the header that you took off, on the head side of the flange where it was leaking will be a carbon track. If they are on the car I usually just listen close to where the noise is coming from, and stick my fingers around there to see if I can feel any leaks. If you have some one cover the tail pipe it will usually cause the leak to become very pronounced.
dawson1112 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003-2004 SVT Cobra Fog Light LED Bulbs! Plug & Play install! See Comparison Photos! Diode Dynamics Vendor For Sale / Group Buy Classifieds 4 11-29-2016 12:14 AM
1995 Mustang GT- 8.8 Overhaul Urambo Tauro 5.0L (1979-1995) Mustang 22 09-07-2015 01:47 PM
Is my 98 cobra worth rebuilding? *pics* svtrosey SVT Forums 4 08-15-2015 10:09 PM
T56 Spline Shafts NOW IN STOCK @ LethalPerformance.com! Boostaddict Lethal Performance 0 08-13-2015 02:57 PM
Just swapped motor exhaust want fit daytooday Motor Swap Section 2 08-11-2015 10:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:22 AM.