Search



Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs > GT S197 General Discussion > 5.0L V8 Technical Discussions
Sign in using an external account
Register Forgot Password?
Search

5.0L V8 Technical Discussions Any questions about the 'Coyote' engine, transmission, exhaust, tuners/CAI, or gearing can be asked here!

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-24-2014, 07:53 PM   #1
SilverGT02
2nd Gear Member

 
Join Date: Feb 2008
Vehicle: 2012 Mustang GT
Location: Mooresville, NC
Posts: 153
Default 2012 GT Clutch / Transmission Issue.

I am having an issue with my clutch. When I start out from a stop I get a clicking sound once the clutch has fully engaged, until I hit about 2k rpm. Then it either goes away or the exhaust drowns it out. It does it in 1st 2nd and reverse.

The best noise that I can compare it to is when I was a kid we use to put a playing card in our spokes to make it sound like and engine.


Anyone else has an issue with this.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!

Last edited by SilverGT02; 02-24-2014 at 07:57 PM.
SilverGT02 is offline   Reply With Quote
Old 02-25-2014, 02:21 PM   #2
WJBertrand
1st Gear Member

 
WJBertrand's Avatar
 
Join Date: Jun 2012
Vehicle: 2013 GT Premium
Location: CA
Posts: 72
Default

Bad U-Joint?
__________________
-Jeff
Ventura, CA
2013 Race Red GT w / Brembo brakes
MGW Shifter, Borla Touring Axle Backs
AM Gas Spring Hood lift kit
WJBertrand is offline   Reply With Quote
Old 02-25-2014, 02:23 PM   #3
Slowbra302
2nd Gear Member

 
Slowbra302's Avatar
 
Join Date: May 2012
Vehicle: 2013 Ford Mustang GT Premium
Location: California
Posts: 364
Default

Check clearance of your entire exhaust system. I had a damn chirping noise from 1000-2000 RPMs coming from my tranny area. Passenger side cat delete was rubbing when the exhaust note was at a certain rpm lol.


Drove me nuts...
__________________


2013 Mustang GT Premium, Black, GT Track Package, Manual, Glass Roof, 3.73, BBK 3 inch Cat deletes, FlowMaster Outlaw 3 inch Cat-back, Steeda CAI, Steeda Tri-ax Short Throw w/ bracket, BMR LCAs, JLT Oil Separator, 91 Race and Performance BAMA Cam Tunes

*RIP* 1995 SVT Cobra, Rio Red, 342hp;362tq - 76,363 miles.
Slowbra302 is offline   Reply With Quote
Old 02-25-2014, 02:23 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:20 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup