Search



Go Back   MustangForums.com > Ford Mustang Tech > Classic Mustangs (Tech)
Sign in using an external account
Register Forgot Password?
Search

Classic Mustangs (Tech) Technical discussions about the Mustangs of yester-year.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-07-2007, 06:22 PM   #1
68SCode4speed
2nd Gear Member
 
Join Date: Jul 2006
Vehicle: 1970 Ford Mach 1
Location: Wisconsin
Posts: 445
Default Ballast Resistor or not ???

How can I tell if my ignition system on the Mustang ('65 289 ) has a ballast resistor?? Where is it and what does it look like. (I'm installing the Pertronix II system...)
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
68SCode4speed is offline   Reply With Quote
Old 02-07-2007, 06:49 PM   #2
67Sally
4th Gear Member
 
Join Date: Mar 2006
Location:
Posts: 1,964
Send a message via AIM to 67Sally Send a message via Yahoo to 67Sally
Default RE: Ballast Resistor or not ???

I'm pretty sure it's in the dizzy and it looks like this.


Click the image to open in full size.
__________________
67Sally is offline   Reply With Quote
Old 02-07-2007, 07:10 PM   #3
Yonco
3rd Gear Member
 
Yonco's Avatar
 
Join Date: Sep 2006
Location:
Posts: 790
Send a message via AIM to Yonco
Default RE: Ballast Resistor or not ???

my 71 has a "resistance wire" in the firewall/ under the dash that is used liek a balast reistor. My ignitor went on with the instructions of " without a balast resistor" and it worked perfect. My coil also said " use without a resitor" so i figured my car didnt have one to begin with. but then again... mines a 71-Jon
__________________

2006 GT / FANG Shaker+Glass Hood / TRI-AX/ Spydershaft / C&L +Brenspeed 93 / Boomtubes / LCA's / CHE TQ brace / BBK Shorties / 275 MT ET's / RAM HD Clutch/4.10's
Yonco is offline   Reply With Quote
Old 02-07-2007, 07:21 PM   #4
67Sally
4th Gear Member
 
Join Date: Mar 2006
Location:
Posts: 1,964
Send a message via AIM to 67Sally Send a message via Yahoo to 67Sally
Default RE: Ballast Resistor or not ???

Just get the Pertronix resistor. It isn't 100% mandatory but it's worth it.
__________________
67Sally is offline   Reply With Quote
Old 02-07-2007, 07:30 PM   #5
Soaring
I ♥ Acer
 
Join Date: Oct 2004
Location:
Posts: 17,565
Default RE: Ballast Resistor or not ???

Balast resistor in a 65? Never heard of one. The only resistor you have in your ignition is the pink resistor wire. You do not need a balast resistor with electronic ignition.
Soaring is offline   Reply With Quote
Old 02-07-2007, 09:51 PM   #6
68SCode4speed
2nd Gear Member
 
Join Date: Jul 2006
Vehicle: 1970 Ford Mach 1
Location: Wisconsin
Posts: 445
Default RE: Ballast Resistor or not ???

Yea - I did a search and found an article by Ford Mag that showed it was a straight forward installation. I went back and checked the ignition section of the manual and it showed no ballast resistor but I just wanted to be sure!
Thanks guys!
http://www.mustangmonthly.com/howto/...itor_ignition/
68SCode4speed is offline   Reply With Quote
Old 02-07-2007, 09:58 PM   #7
Soaring
I ♥ Acer
 
Join Date: Oct 2004
Location:
Posts: 17,565
Default RE: Ballast Resistor or not ???

Thanks for the MM rendition of how to install the pertronix. I will add that to the FAQ, so it will be one of three methods. It ain't a big deal though. I put mine in in about 20 minutes even with going to the ignition switch and eliminating the pink resistor wire.
Soaring is offline   Reply With Quote
Old 02-07-2007, 09:58 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1968, 65, 67, 93, ballast, ballist, burned, front, ignition, install, location, mustang, resistor, rubber, smells

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pertronix and ballast resistor help kaliona Classic Mustangs (Tech) 10 10-27-2007 10:04 PM
ballast resistor atomsk680 Classic Mustangs (Tech) 12 07-07-2007 03:42 AM
Project car wont start not getting spark? DrBob67 Classic Mustangs (Tech) 48 04-28-2006 05:43 PM

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:18 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup