Go Back   MustangForums.com > Ford Mustang Tech > Classic Mustangs (Tech)
Sign in using an external account
Register Forgot Password?
Search


Classic Mustangs (Tech) Technical discussions about the Mustangs of yester-year.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 12-30-2007, 04:07 PM   #1
Mustang Dad
2nd Gear Member
 
Join Date: Oct 2006
Location:
Posts: 367
Default 2 new anoying little problems

Now that we have the '65 running good we are going to attack a few of the more anoying problems.

#1--Theproblem #1 is the instrument lights. All of the instrument panel lights arre working with the exception of the guage cluster lights. These are the 4 lights that light up the speedometer area. I've checked voltages and everything seems to lead to the light switch itself. Anyone have any experience in this area.

#2--Problem #2 is with the cigar lighter. I replaced the fuse withthe proper size and it works as advertized, but whenever we plug in a cellphone charger, the fuse blows. The rated fuse is 14 amps and thats what is installed. Do I need to go with a larger fuse because of the phone chager?

This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
If it wasnt made for this car, a hammer and screwdriver will usually adapt it to fit.

2004 Chevy Avalanche------Mine
1995 Chevy Camaro---------The Wifes
1965 "C" Code Mustang coupe---------The sons
1947 Beech Bonanza--------Family vehicle
Mustang Dad is offline   Reply With Quote
Old 12-30-2007, 04:54 PM   #2
colostang
2nd Gear Member
 
Join Date: Dec 2006
Location:
Posts: 295
Default RE: 2 new anoying little problems

Does it happen with different chargers? or have you tried just one? I had a Nokia charger for an old phone that would blow the fuse in my pickup but no other plug-in accessory would. As fasr as installing a larger fuse, I would. But that might not be the thing to do.
__________________
My first car was a 65' fastback, and it's still mine
colostang is offline   Reply With Quote
Old 12-30-2007, 04:59 PM   #3
69thunder
2nd Gear Member
 
Join Date: Sep 2007
Vehicle: 1969 Coupe
Location:
Posts: 248
Default RE: 2 new anoying little problems

Try putting in a 20 amp fuse and see what happens.
__________________
1969 Coupe
Factory A/C
Original sheet metal
New interior
347 stroker
Edelbrock RPM Heads and Cam
Summit Racing 4 Barrel carb
Pertronix/MSD 6a ignition
Doug Thorley long tube headers
Flowmaster Super 44's
69thunder is offline   Reply With Quote
Old 12-30-2007, 04:59 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 04:54 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup