Go Back   MustangForums.com > Ford Mustang Tech > Classic Mustangs (Tech)
Sign in using an external account
Register Forgot Password?
Search


Classic Mustangs (Tech) Technical discussions about the Mustangs of yester-year.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-01-2014, 04:46 PM   #1
65Jennay
 
Join Date: Feb 2014
Vehicle: 1965,Ford,Mustang
Location: Oklahoma/Georgia
Posts: 2
Question Afterstock Radio Problems

Hey Gentlemen I am having a bit of trouble with my aftermarket radio on my 65 Mustang. So here is what happened I have had it installed for about a year now and one day while driving it started shorting in and out. Trying to save it I turned off the radio. Now the radio won't even turn on...I've traced the wires and they all seem to be in place and the fuses are all good. Unusually when this happened my lighter shorted out and now pops the fuse to it every time I turn on the car. The type of radio that is in there is a USA-230. Any ideas on how to fix it or whats wrong would be greatly appreciated. Thanks Gents.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
65Jennay is offline   Reply With Quote
Old 09-03-2014, 02:41 PM   #2
Iskwezm
4th Gear Member
 
Join Date: Feb 2006
Vehicle: 1965 Mustang Fastback
Location: So. Cal,the O.C.
Posts: 1,533
Send a message via Yahoo to Iskwezm
Default

Get a meter and test the red wire for power with the key on, the yellow for constant power and black for ground. If they all test good, the radio is probably done. I have replaced more of those then i've sold.

I had a friend that had one put in a 56 ford wagon, of course I get called when it doesn't work after they paid somebody else to install it. The left **** went bad after a week, luckily I lived close enough to take it back to CA to have it repaired.
__________________
Sound Desicion Car Audio & Perf.
TMI Products.
Ford Cert./ASE Master Tech

2006 Mustang Gt 'Vert-12 sec. daily driver-sold
2006 F250 PSD,9"lift,37's on 20's,King coilovers,air ride,Gearheads 120hp tune,Phoenix Gold 6600 watts,4 12's
1965 FASTBACK- 18X8 18X9.5" TSW's 235/275 M/T's,
http://www.mustangandfords.com/featu...own/index.html

Last edited by Iskwezm; 09-03-2014 at 02:48 PM.
Iskwezm is offline   Reply With Quote
Old 09-03-2014, 08:57 PM   #3
barnett468
3rd Gear Member
 
Join Date: Nov 2013
Vehicle: 1965 shelby
Location: arizona
Posts: 717
Default

.
disconnect the radio and see if your lighter fuse still blows.
.
barnett468 is online now   Reply With Quote
Old 09-03-2014, 08:57 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:32 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup