Search



Go Back   MustangForums.com > Ford Mustang Tech > General Tech
Sign in using an external account
Register Forgot Password?
Search

General Tech Ask model specific questions in the appropriate category below. All other general questions within.
Sponsored by NewTakeOff


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-20-2007, 07:04 AM   #1
mercury267
1st Gear Member
 
mercury267's Avatar
 
Join Date: Jun 2007
Vehicle: 1995 Ford Thunderbird
Location: Maryland
Posts: 51
Default 95 GT gauges stopped working - everything gone

My dad has a 95 GT. He has factory gauges and they all stopped working, along with the odometer. I pulled the gauge pod and see that there is a small circuit board in a slot on the back, AND there is of course the green circuit pad on the back of the whole gauge face.

Is this a common problem? If so, is there a contol box that feeds this info to the gauges or does the car probably just need a new gauge cluster?

I think the temp, amp and oil pressure might still have the needles move to some kind of read out, but it is not accurate, meaning the needles move but not to what is a correct read out (i.e. showing any normal operation temp from a cold start, and shy high oil pressure, and so on). The speedo and tach also just sit at 0 no matter what... they don't move at all.

Any help is appreciated. I would like to buy the parts he needs to fix it and it would just be a stock replacement, no upgrades or conversions. If anyone had a lead on whatever the part would be to fix it, please steer me in the right direction.

Thanks
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
Behold, I am coming quickly.
~Jesus Christ

1995 Thunderbird
SN95 lug conversion
93 17" Cobra wheels (drilled to SN95 circle)
02 Mach 1 Brakes, front & rear
95 Mark VIII LSC fuel tank
03 Cobra IRS & stage 5 axles
Custom body mods (shaved trunk lid, deleted roof moldings, SN95 graphed bumper covers)
Aftermarket mods (Fiberconcepts hood, autometer gauges,
Parts interchanged (SC ir bag, SC gauge cluster, 96/97 headlights & taillights, various Mark VIII and Cougar components).
mercury267 is offline   Reply With Quote
Old 07-21-2007, 01:26 PM   #2
turboblast
 
Join Date: Jul 2007
Posts: 19
Default RE: 95 GT gauges stopped working - everything gone

you may have already done this but check for a blown fuse
__________________
85' GT 429 in progress
turboblast is offline   Reply With Quote
Old 07-21-2007, 03:59 PM   #3
94Blk5.0
5th Gear Member
 
94Blk5.0's Avatar
 
Join Date: Jun 2007
Vehicle: 1994 GT
Location: NC
Posts: 2,082
Default RE: 95 GT gauges stopped working - everything gone

+ 1 Fuses, check the owners manuel to see which fuses controls the panel. Some higher voltage breakers are under the hood.
__________________
1994 GT - Black on Tan - 302 - T5 - Bullitt Wheels - 9.2 @ 77.4

1996 F150 - 351 - E4OD - 4X4 - Towing/Handling/Super Cooling Package

American Made
94Blk5.0 is offline   Reply With Quote
Old 07-17-2008, 11:47 PM   #4
mercury267
1st Gear Member
 
mercury267's Avatar
 
Join Date: Jun 2007
Vehicle: 1995 Ford Thunderbird
Location: Maryland
Posts: 51
Default RE: 95 GT gauges stopped working - everything gone

None of these do the trick. The fuses are ok. None of the gauges work.
__________________
Behold, I am coming quickly.
~Jesus Christ

1995 Thunderbird
SN95 lug conversion
93 17" Cobra wheels (drilled to SN95 circle)
02 Mach 1 Brakes, front & rear
95 Mark VIII LSC fuel tank
03 Cobra IRS & stage 5 axles
Custom body mods (shaved trunk lid, deleted roof moldings, SN95 graphed bumper covers)
Aftermarket mods (Fiberconcepts hood, autometer gauges,
Parts interchanged (SC ir bag, SC gauge cluster, 96/97 headlights & taillights, various Mark VIII and Cougar components).
mercury267 is offline   Reply With Quote
Old 07-18-2008, 02:57 PM   #5
945LSTANG
6th Gear Member
 
945LSTANG's Avatar
 
Join Date: May 2007
Vehicle: 2003 SVT Cobra
Location: Columbia, MO
Posts: 6,347
Default RE: 95 GT gauges stopped working - everything gone

disconnect the negative battery cable, disconnect both instrument cluster connectors, remove fuse 15 from instrument fuse panel. check for continuity at fuse 15.

tell me what you find after you try this.
__________________

03 Cobra
94 GT - R.I.P. 11/30/08

945LSTANG is offline   Reply With Quote
Old 07-18-2008, 02:57 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1994, 94, 95, 96, cluster, gauges, gt, mustang, niddle, quit, speedo, stop, stopped, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 10:30 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup