replaced carpet now doesn't fire up - MustangForums.com


General Tech Ask model specific questions in the appropriate category below. All other general questions within.
Sponsored by NewTakeOff


Reply
 
 
 
Thread Tools Search this Thread
Old 05-18-2013, 03:08 PM   #1
taunusrainer2
Thread Starter
 
Join Date: Jul 2012
Location: Germany
Posts: 13
Default replaced carpet now doesn't fire up

Gentlemen, today I took out the seats, center console and carpet from my 1990 7up convertible and after sunset I wanted to drive it back into the garage with seats still out. Starter spins but engine doesn't fire up. Also I cannot hear the fuel pump when ignition is on. I haven't unplugged too many connectors, only the radio, the trunk release, the mirror control and the seat heater switches. Could I have missed something? Is there some anti theft circuit? Or did my fuel pump pass away right now?
The car did never do strange things before. Reliable turn-the-key-and-go-anywhere car. It is a 5.0 auto trans.
I am completely lost at the moment, no idea where to look.
taunusrainer2 is offline   Reply With Quote
Old 05-18-2013, 10:42 PM   #2
Blueper
2nd Gear Member
 
Join Date: Jul 2006
Location: VA
Posts: 227
Default

Pull the carpet back out and check all connectors. You had to have broken a connection under there somewhere
Blueper is offline   Reply With Quote
Old 05-19-2013, 04:49 AM   #3
taunusrainer2
Thread Starter
 
Join Date: Jul 2012
Location: Germany
Posts: 13
Default Bug found

There is relay which I think is the fuel pump relay under the drivers seat. The stock wiring harness goes there and it doesn't look as if it had ever been modified by some short-circuit-electrician. It is simply hanging loose under the carpet. To replace it one would have to remove the seat and a lot of mouldings in order to have access to under the carpet. No worse location possible for it imo. Yesterday I unplugged this relya from the socket just for curiosity and replugged it. Did the same this morning and found a connector bent. Straightened it, plugged it in and everything is working ok now. Will check for the inertia switch anyway, am curious where it is and how it looks.
Thanks a lot for Your help, gentlemen, I can go and finish my carpet job now, good sunday job, no noise.
CU
Ray
taunusrainer2 is offline   Reply With Quote
Old 05-19-2013, 05:58 AM   #4
FlamingoGT
2nd Gear Member
 
Join Date: Sep 2009
Location: Jax FL
Posts: 442
Default

It's been too many years since I had my fox, but on my 04 the inertia switch is behind the trunk panel right next to the driver's side tail lights. It's about that same size and look as a standard 12V relay with a little push button similar to some 12V circuit breakers I have seen.
FlamingoGT is offline   Reply With Quote
Old 05-19-2013, 07:43 AM   #5
taunusrainer2
Thread Starter
 
Join Date: Jul 2012
Location: Germany
Posts: 13
Default

Found the switch, was ok. Problem solved. Thanks for the input.
CU
Ray
Thread may be closed by admin
taunusrainer2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Mustang Expansion Tank Granatelli Sales The New S550 2015-2016 Mustang 15 06-23-2016 06:26 PM
Drag Radial's whatsup62 5.0L GT S550 Tech 2 10-16-2015 04:07 PM
V6 Engine Ticking Nick Oliver V6 S197 General Discussion 2 09-05-2015 11:34 AM
Help! Metra 70-5521 AMP Harness Install cbird1177711 2005-2014 Mustangs 2 09-03-2015 09:43 PM
5.0 wont start condition 5.0 kevo 5.0L (1979-1995) Mustang 6 09-03-2015 07:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:14 AM.