Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs > GT S197 General Discussion
Sign in using an external account
Register Forgot Password?
Search


GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


I'll try anything.. Tune issues.

Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-13-2013, 12:01 AM   #1
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default I'll try anything.. Tune issues.

06 GT with a Steeda CAI and Bama SF3 tuner.. I just ripped around town a bit on the 91 race tune- car was running Grrrrrreat. I'm going on the road soon, so I went to load the 91 perf tune when I got home. I barely got it to idle-- and tripped the p2104 and p2112 DTCs with associated fail safe and engine lights.. I know these are for:

P2104- throttle actuator control system- forced idle
P2112- " " " " - stuck closed

I tried returning to the race tune. I returned to stock. I disconnected the battery and retried everything. I did a strange "tune dance" in my driveway in hopes that I could get back to where I was a half hour earlier-- to no avail. I've had no Problems of late. I really REFUSE to think this is a TB issue-- who's the genius out there? I've surfed a bit trying to find the answer on my own- but wanted to post to the forum in hopes of taking the beast on the road this week.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-13-2013, 01:32 AM   #2
VistaBlueFrank68
2nd Gear Member
 
VistaBlueFrank68's Avatar
 
Join Date: Jun 2012
Vehicle: 2013, Ford, GT/CS
Location: Washington
Posts: 377
Default

Did you buy the tuner or did it come with the car?
I once had a prob with mine, I lost the stock tune with one tuner, then got a SCT and well things can get confusing when you don't know a cars past.

Did you try Googling problems with p2104 and so on...?

Later.
VistaBlueFrank68 is offline   Reply With Quote
Old 06-13-2013, 01:48 AM   #3
808muscle
5th Gear Member
 
808muscle's Avatar
 
Join Date: Oct 2009
Vehicle: 2006 Mustang GT
Location: Maui
Posts: 4,613
Default

Call bama.
__________________


06 Satin Silver GT - Auto...ROUSH M90 CAI, Afco Dual Fan HE, 4.10s,Trutrac, Detroit Rockers, Moroso, DSS DS, TCI Rachet Shifter, PA Deep Pan, Eibach Handling, FR P Springs, Strange Shocks/Struts, BMR, J&M, SS Lines/ EBC Rotors w/Reds, Mickey Thompson SC5, Nitto 255/305, 2011 leather, Pypes LT's/H-Pipe, MBRP Resonators, Borla

2014 Pro Street 12.90 Class...Season Points Runner Up
12.23@114
808muscle is offline   Reply With Quote
Old 06-13-2013, 07:59 AM   #4
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

Quote:
Originally Posted by VistaBlueFrank68 View Post
Did you buy the tuner or did it come with the car?
I once had a prob with mine, I lost the stock tune with one tuner, then got a SCT and well things can get confusing when you don't know a cars past.

Did you try Googling problems with p2104 and so on...?

Later.
I bought the tuner from AM with the CAI- and I also tried googling everything I can think of.. no luck. I can get a list of what the codes are but nothing as far as a fix. like I said, no reason to think a TB (or TB motor) issue, which is what it seems they are point to.
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-13-2013, 08:15 AM   #5
awbreyjd
2nd Gear Member
 
Join Date: Aug 2012
Vehicle: 2013 Ford Mustang 5.0
Location: Texas
Posts: 219
Default

yes but have you called bama yet. They can probably help you out. At teh same time you said you were ripping around town on the 91 Race Tune then got home and changed tunes. Something could have very well happened to your components during some ripped driving around town. **** does happen. But Bama is good with customer service once you get ahold of them. Sometimes that is a task but they are busy.
__________________
2013 5.0
Lethal Performance O/R xpipe and duel pump fuel return style system, frpp 47lbs injectors, Vortech with 3.48 pulley, Boss heads/Cams, Aluminum Driveshaft, frpp 3.31 gears. pypes pypebomb cat back, mgw shifter. jlt intake, boss 302 intake manifold. bbk 85mm tb.
11.4@130 1/4 at a 3700 DA. (2.0 60ft)
721hp/525tq (tuned by Seminole Automotive Performance)
awbreyjd is offline   Reply With Quote
Old 06-13-2013, 08:58 AM   #6
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

Quote:
Originally Posted by awbreyjd View Post
yes but have you called bama yet. They can probably help you out. At teh same time you said you were ripping around town on the 91 Race Tune then got home and changed tunes. Something could have very well happened to your components during some ripped driving around town. **** does happen. But Bama is good with customer service once you get ahold of them. Sometimes that is a task but they are busy.
Called Bama. No help there. I find it hard to believe that I had no lights, whistles, crappy idle, or DTCs until I changed the tune- and it's gotta be the TB. I really thought they'd be more help too- as far as rippin around town, I understand **** happens but seems coincidental that it would happen at the same time as the tune change. I have had the wrong tune before- and that's what this is like. Takes a few extra seconds to turn over and then idles REAL low and slow.
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-13-2013, 09:38 AM   #7
mapitts
3rd Gear Member
 
Join Date: Nov 2009
Vehicle: 2012 GT, MT82, 3.73's. Borla S Type , Steeda tuned
Location: Decatur AL
Posts: 785
Default

Lots of custom tune issues here lately, or so it seems. Mostly on the 4.6's. Seems like no one is exempt. Bama, Brenspeed, Steeda.
mapitts is offline   Reply With Quote
Old 06-13-2013, 09:47 AM   #8
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

Alright alright- before everyone goes up the ladder on my previous post-- allow me to remove my foot from my forum mouth. It would appear I have a TB issue afterall. Now- maybe I can get some guidance with regard to the TB. It's a BBK 62mm that's been on for about 8-10 months.

I come across a gold-ish colored piece of machined metal that appears to match the color of the idle control. This piece is about a half inch long and cylindrical- almost looking like a piston of sorts. It was found sitting nicely on top of my radiator cover. Any thoughts on a fix, cause, etc?
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-13-2013, 10:00 AM   #9
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

Quote:
Originally Posted by Slowpoek06GT View Post
Alright alright- before everyone goes up the ladder on my previous post-- allow me to remove my foot from my forum mouth. It would appear I have a TB issue afterall. Now- maybe I can get some guidance with regard to the TB. It's a BBK 62mm that's been on for about 8-10 months.

I come across a gold-ish colored piece of machined metal that appears to match the color of the idle control. This piece is about a half inch long and cylindrical- almost looking like a piston of sorts. It was found sitting nicely on top of my radiator cover. Any thoughts on a fix, cause, etc?
The idle control now has an open top to it. It appears this piece came from inside? Anyone heard of this?
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-13-2013, 10:49 AM   #10
lawrencecar1
2nd Gear Member
 
lawrencecar1's Avatar
 
Join Date: Sep 2011
Vehicle: 07, Ford GT
Location: Northern Virginia
Posts: 369
Default

the permanent fix to put the stock tb back on..
__________________
07 Mustang GT 5 Spd
Roush M90 SC w/2.49 pulley, KB BAP, Roush CB, Hurst ss, FRPP cams, FRPP 62mm TB, Helo 20" wheels, FRPP 4.10's, BBK headers, Kicker/Shelby 8" subs, Cadence amps, Optima red top, full body kit, STB, JLT oil separators ps/ds, Cross drilled/slotted rotors, aluminum DS, Eibach struts,shocks, FRPP springs, Eibach sway bar kit, BMR panhard bar/brace, BMR LCA's, SS brake/clutch lines, GlowShift gauges, Shelby RSB/trans cooler, JLT brake cooling kit, Exedy stage 1 clutch/Flywheel
lawrencecar1 is offline   Reply With Quote
Old 06-13-2013, 02:35 PM   #11
AMWill
Platinum Sponsor
 
AMWill's Avatar
 
Join Date: Feb 2012
Vehicle: '14 GT
Location: Pennsylvania
Posts: 1,465
americanmusclefb americanmuscle
Default

Quote:
Originally Posted by Slowpoek06GT View Post
Alright alright- before everyone goes up the ladder on my previous post-- allow me to remove my foot from my forum mouth. It would appear I have a TB issue afterall. Now- maybe I can get some guidance with regard to the TB. It's a BBK 62mm that's been on for about 8-10 months.

I come across a gold-ish colored piece of machined metal that appears to match the color of the idle control. This piece is about a half inch long and cylindrical- almost looking like a piston of sorts. It was found sitting nicely on top of my radiator cover. Any thoughts on a fix, cause, etc?
Slowpoek06GT,

Could you take a picture of both the piece you found and the BBK TB? This may help us identify the piece. At the very minimum, I BBK will be able to see what's missing or broken.

Either way, I'm sure we'll be able to get this figured out!

Shane
__________________
Will Levantovsky | AmericanMuscle.com

Toll Free: 866.727.1266 | M-F 9AM-9PM EST | Sat 9AM-5:30PM EST

Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST

WIN a Raxiom Lights and Tech Package from AmericanMuscle.com!


Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 06-13-2013, 03:01 PM   #12
tj@steeda
3rd Gear Member
 
tj@steeda's Avatar
 
Join Date: Jul 2011
Vehicle: 2012 Ford Mustang
Location: Florida
Posts: 565
Default

Quote:
Lots of custom tune issues here lately, or so it seems. Mostly on the 4.6's. Seems like no one is exempt. Bama, Brenspeed, Steeda.
Not many issues here ... sometimes we just need to do a revision or two to get it spot on.

Best Regards,

TJ
tj@steeda is offline   Reply With Quote
Old 06-13-2013, 10:15 PM   #13
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

This is a pic (rotated) of the right top corner of the TB and idle control (gold). You can see the idle control is hollow in this pic..
Click the image to open in full size.
After I re-inserted the found piece, it looked normal-- in this pic..
Click the image to open in full size.
On the left of the below pic is the piece I found on my radiator cover. After I re-inserted it into the idle control and then removed it, it pulled out (with it) the silver piece on the right. Maybe this is the issue????
Click the image to open in full size.
Those two pieces fit together as such..
Click the image to open in full size.

at this point, both small parts are out of the car.. I disconnected the CAI and found the TB (with engine off) spring loaded closed, which I expected. When I pushed it open, it returned to closed. I checked all electrical connections and everything looks good.. Is this the point at which I dis-assemble the (right) side of the TB and find out what the hell is up with these two random idle control pieces?? Anybody seen this?
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-14-2013, 09:29 AM   #14
lawrencecar1
2nd Gear Member
 
lawrencecar1's Avatar
 
Join Date: Sep 2011
Vehicle: 07, Ford GT
Location: Northern Virginia
Posts: 369
Default

i believe that is the plunger to adjust the tps voltage, probably could take the motor side off and re-insert. adjust to stock voltage..

check out below video..

http://www.bbkperformance.com/produc...ttle-body.html
__________________
07 Mustang GT 5 Spd
Roush M90 SC w/2.49 pulley, KB BAP, Roush CB, Hurst ss, FRPP cams, FRPP 62mm TB, Helo 20" wheels, FRPP 4.10's, BBK headers, Kicker/Shelby 8" subs, Cadence amps, Optima red top, full body kit, STB, JLT oil separators ps/ds, Cross drilled/slotted rotors, aluminum DS, Eibach struts,shocks, FRPP springs, Eibach sway bar kit, BMR panhard bar/brace, BMR LCA's, SS brake/clutch lines, GlowShift gauges, Shelby RSB/trans cooler, JLT brake cooling kit, Exedy stage 1 clutch/Flywheel
lawrencecar1 is offline   Reply With Quote
Old 06-14-2013, 11:31 AM   #15
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

So here are the three parts all out of the TB.. allen bolt to allow the idle control (gold) to be backed out.
Click the image to open in full size.
I talked to BBK and they said the three parts are pressure mounted together upon construction of the TB itself. I'm hoping they'll let me just send these three back instead of having to uninstall the entire TB. We'll see... MTF
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-14-2013, 05:02 PM   #16
AMWill
Platinum Sponsor
 
AMWill's Avatar
 
Join Date: Feb 2012
Vehicle: '14 GT
Location: Pennsylvania
Posts: 1,465
americanmusclefb americanmuscle
Default

Let me know if BBK is able to send you new components and get this straightened out. If you have any troubles, shoot me a PM!

Shane
__________________
Will Levantovsky | AmericanMuscle.com

Toll Free: 866.727.1266 | M-F 9AM-9PM EST | Sat 9AM-5:30PM EST

Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST

WIN a Raxiom Lights and Tech Package from AmericanMuscle.com!


Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 06-14-2013, 05:14 PM   #17
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Vehicle: 2007 GT
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,109
Send a message via AIM to Nuke Send a message via Yahoo to Nuke Send a message via Skype™ to Nuke
Default

Quote:
Originally Posted by lawrencecar1 View Post
the permanent fix to put the stock tb back on..
^This, as is stated over and over in this forum. With all the info about the BS people put up with using aftermarket TB's, I have no idea why people insist on installing them without the mods that make it worthwhile.
__________________
Rick
07 GT Prem: Alloy, MT, 3.55's, Steeda CAI w/Brenspeed tunes, FRPP Stingers, 275/40/18 Goodyear Eagle F1 A/S on SVT Cobras (OE GT500's), 14" shorty, Wheelskin side scoops & qtr window louvers, A-H rear window louvers, SHR honeycomb blackout panel, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
06 V6: Legend Lime, Pony Package, 14" shorty, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
Nuke is offline   Reply With Quote
Old 06-14-2013, 09:55 PM   #18
mapitts
3rd Gear Member
 
Join Date: Nov 2009
Vehicle: 2012 GT, MT82, 3.73's. Borla S Type , Steeda tuned
Location: Decatur AL
Posts: 785
Default

Quote:
Originally Posted by tj@steeda View Post
Not many issues here ... sometimes we just need to do a revision or two to get it spot on.

Best Regards,

TJ
Luckily mine is still running strong. Steeda still has my vote. Was not trying to flame any of the tuners. Without ya'll, life would suck. May be that we are just seeing the influx of more and more people running tunes. Looks like this thread was totally not tune related. Also plus 1 on what Nuke said. An aftermarket TB N/A is just asking for a problem IMHO.
mapitts is offline   Reply With Quote
Old 06-17-2013, 09:48 AM   #19
kevinmalec
5th Gear Member
 
kevinmalec's Avatar
 
Join Date: Apr 2008
Vehicle: 2005 Ford Mustang
Location: Acworth, GA
Posts: 3,633
Wink

Quote:
Originally Posted by Nuke View Post
^This, as is stated over and over in this forum. With all the info about the BS people put up with using aftermarket TB's, I have no idea why people insist on installing them without the mods that make it worthwhile.
I agree with Rick. I've read many negative posts in regards to the BBK TB and other after market TB's.
Get your money back and put it towards another mod.
__________________


- 2005, 4.0 - Missing 2 cylinders :-/
- SCT Xcal3 w/ Brenspeed Custom Tunes
- Airaid CAI
- Pypes Streetpro Exhaust
- AM Front Chin Spoiler
- AM Quarter window louvers
- SHR honeycomb decklid panel
- Cobra R wheels
- Eibach Pro-Kit lowering springs
- Billet Honeycomb Chrome Front Grille Overlay
- Smoked tail lights & turn signals, Mustang 3rd brake light decal
- Raxiom sequential tail light kit
kevinmalec is offline   Reply With Quote
Old 06-19-2013, 10:37 AM   #20
Slowpoek06GT
1st Gear Member
 
Slowpoek06GT's Avatar
 
Join Date: Jun 2012
Vehicle: 2006, ford, mustang
Location: California
Posts: 53
Default

Alright- so I emailed BBK. The response I got from them is that the TB is very sensitive to voltage changes and the new tune likely changed something. Either way, the result was that I blew the idle control open at some point. I have subsequently re-installed the OE TB and retuned.

Coincidentally, while removing the BBK TB, I look down and see the spring for the idle control sitting atop the pan below the radiator-- so it came apart while under power and I eventually found all the parts-- what are the chances!?

As much as I hear about aftermarket TBs causing problems, do they not provide ANY performance gain?
__________________
FTMO

<<MGW>|<Steeda/BAMA>|<Koni/Eibach>|<Flowmaster/CB>|< Foose/Nitto>|<Ford Racing>>

~~~~Don't let the Bastards get you down~~~~
Slowpoek06GT is offline   Reply With Quote
Old 06-19-2013, 10:37 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:10 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup