Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs > GT S197 General Discussion
Sign in using an external account
Register Forgot Password?
Search


GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Rear Window blowing fuse

Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-17-2015, 07:36 AM   #1
zeroscum
 
Join Date: Apr 2015
Vehicle: 2007 Mustang GT Convertibile
Location: Michigan
Posts: 4
Default Rear Window blowing fuse

Hi everyone, have a problem on my 07 GT Convertible I'd like to run by you.

As soon as I press the rear window button a 5 amp fuse blows in the interior fuse box.

The front windows work no problem, but the second I press that rear switch the fuse pops.

I guess the first thing I was going to check was to disconnect the rear window motors and try the switch again to see if the fuse blows. If it doesn't than I know it's not the switch and its one of the motors, right? Than just through process of elimination I can plug the motors back in one at a time to figure out which is bad.

Does that sound like a good way to proceed?

And if so, can anyone tell me the best way to get to the rear window motors to disconnect them?

Thanks much!

Justin
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
zeroscum is offline   Reply With Quote
Old 04-17-2015, 09:21 AM   #2
zeroscum
 
Join Date: Apr 2015
Vehicle: 2007 Mustang GT Convertibile
Location: Michigan
Posts: 4
Default

I have been searching through the forums like mad, still searching....
zeroscum is offline   Reply With Quote
Old 04-19-2015, 12:30 AM   #3
cruisin5268d
4th Gear Member
 
cruisin5268d's Avatar
 
Join Date: Mar 2014
Vehicle: 2013 GT/CS Convertible & 2010 GT Premium
Location: Austin, Texas
Posts: 1,024
Default

I think you got some good info on your other thread.

Keep at it - somewhere something is happening to cause this issue. By process of elimination you'll find it eventually. Maybe it's a simple short in an easily accessible place.
cruisin5268d is offline   Reply With Quote
Old 04-19-2015, 12:30 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 03:04 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup