Mach 1 wont Idle - MustangForums.com


Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang > Mach 1 Section
Search


Mach 1 Section This section is for discussions relating to the reincarnation of the Mach 1 trimline.

Mach 1 wont Idle

Reply
 
 
 
Thread Tools Search this Thread
Old 09-22-2010, 12:07 AM   #1
LowLyfe
 
Join Date: Sep 2010
Posts: 2
Default Mach 1 wont Idle

Ok I have a stock 2003 Mach 1 that just cracked 100k miles. I went to get in the car today for work and it would crank but not idle. If I give it gas it will stay running with no problem untill I let off the gas and it just dies out. I put the OBD II on it it is throwing zero codes. I checked for vaccum leaks, found none at all. I changed the TPS sensor no change at all in the idle or lack of idle. I even pulled the PCV valve and MAF off cleaned them and reinstalled, again no change. I almost have my mind made up that either the sensor is bad in the PCV valve or the Idle Air sensor is bad. I have never seen a PCV valve with a sensor so I'm not sure what the symptoms would be when they go out. If anyone could be of assistance I would greatly appreciate it.
LowLyfe is offline   Reply With Quote
Old 09-22-2010, 03:25 PM   #2
smitty2919
5th Gear Member
 
Join Date: Sep 2009
Vehicle: stang go bye bye
Location: KY, was MA
Posts: 2,797
Default

My first guess would be IAC valve. Don't clean it...replace it and report back.
__________________
-Always thinking how to be different in a world of
commonality.
-Driver mod=best investment

smitty2919 is offline   Reply With Quote
Old 09-23-2010, 03:43 PM   #3
darkmach1
4th Gear Member
 
darkmach1's Avatar
 
Join Date: Feb 2008
Location:
Posts: 1,466
Default

^^I'll try this first.
__________________
2015 A6 Mustang GT..........Current
2007 Trailblazer SS................Current
1985 Mustang GT.................. Nov 2012 ROTM SOLD
2004 Eaton swapped Mach1....Sold
darkmach1 is offline   Reply With Quote
Old 09-25-2010, 08:56 PM   #4
LowLyfe
 
Join Date: Sep 2010
Posts: 2
Default

Ok I did a full tune up and replaced the IAC and it idles fine now thanks for the help.
LowLyfe is offline   Reply With Quote

 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
TNT, New PB TCStangerv6 Street/Strip 12 10-11-2015 05:57 PM
Starting Issue svfetter 5.0L (1979-1995) Mustang 9 10-05-2015 11:39 AM
Rear Package Shelf jrrhd73must Classic Mustang General Discussion 2 10-02-2015 09:17 PM
04 Mach 460 system, Installed Aftermarket HU, No Highs/Tweeters breaking Audio/Visual Electronics 5 10-02-2015 01:27 PM
Rough idle and vibrating 4cylinderplus2 V6 (1994-2004) Mustangs 9 09-30-2015 05:26 PM


Tags
2003, 2004, 46, idle, idling, location, mach, mustang, pcv, problems, running, sensor, stay, valve, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 

All times are GMT -5. The time now is 06:02 AM.



This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company