Search



Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang > Mach 1 Section
Sign in using an external account
Register Forgot Password?
Search

Mach 1 Section This section is for discussions relating to the reincarnation of the Mach 1 trimline.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-22-2010, 12:07 AM   #1
LowLyfe
 
Join Date: Sep 2010
Posts: 2
Default Mach 1 wont Idle

Ok I have a stock 2003 Mach 1 that just cracked 100k miles. I went to get in the car today for work and it would crank but not idle. If I give it gas it will stay running with no problem untill I let off the gas and it just dies out. I put the OBD II on it it is throwing zero codes. I checked for vaccum leaks, found none at all. I changed the TPS sensor no change at all in the idle or lack of idle. I even pulled the PCV valve and MAF off cleaned them and reinstalled, again no change. I almost have my mind made up that either the sensor is bad in the PCV valve or the Idle Air sensor is bad. I have never seen a PCV valve with a sensor so I'm not sure what the symptoms would be when they go out. If anyone could be of assistance I would greatly appreciate it.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
LowLyfe is offline   Reply With Quote
Old 09-22-2010, 03:25 PM   #2
smitty2919
5th Gear Member
 
Join Date: Sep 2009
Vehicle: stang go bye bye
Location: Walton,KY was MA
Posts: 2,767
Default

My first guess would be IAC valve. Don't clean it...replace it and report back.
__________________
-Always thinking how to be different in a world of
commonality.
-Driver mod=best investment

smitty2919 is offline   Reply With Quote
Old 09-23-2010, 03:43 PM   #3
darkmach1
4th Gear Member
 
darkmach1's Avatar
 
Join Date: Feb 2008
Location:
Posts: 1,400
Default

^^I'll try this first.
__________________
2004 Eaton swapped Mach1....Sold
2007 Trailblazer SS................Current
1985 Mustang GT..................Current Nov 2012 ROTM
darkmach1 is offline   Reply With Quote
Old 09-25-2010, 08:56 PM   #4
LowLyfe
 
Join Date: Sep 2010
Posts: 2
Default

Ok I did a full tune up and replaced the IAC and it idles fine now thanks for the help.
LowLyfe is offline   Reply With Quote
Old 09-25-2010, 08:56 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
2003, 2004, 46, idle, idling, location, mach, mustang, pcv, problems, running, sensor, stay, valve, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:31 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup