Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang > Mach 1 Section
Sign in using an external account
Register Forgot Password?
Search


Mach 1 Section This section is for discussions relating to the reincarnation of the Mach 1 trimline.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-15-2013, 12:18 AM   #1
tnfidelity
 
Join Date: Oct 2013
Vehicle: 2003 FORD MUSTANG MACH 1
Location: Tennessee
Posts: 1
Default headlights will not stay on.

I OWN A 2003 MACH 1 MUSTANG. RECENTLY THE HEADLIGHTS WILL COME ON AFTER 2 OR 3 MINUTES WHEN STARTING THE AUTOMOBILE. IT WILL ALSO NOT FUNCTIONING WHILE DRIVING ON THE HIGHWAY AND COME BACK ON AGAIN AFTER 2 TO 5 MINUTES. I THOUGHT IT WAS THE HEADLIGHT SWITCH AND IT WAS REPLACED TODAY WITH A NEW HEADLIGHT SWITCH. THE HEADLIGHTS STILL HAVE THE SAME PROBLEMS AFTER INSTALLING A NEW SWITCH. PLEASE ADVISE WHAT SHOULD BE THE NEXT STEP. PLEASE ADVISE AND COMMENT ANYONE.

EMAIL: tnfidelity@aol.com
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
tnfidelity is offline   Reply With Quote
Old 10-21-2013, 08:12 AM   #2
AzPete
4th Gear Member
 
AzPete's Avatar
 
Join Date: Aug 2008
Vehicle: 08 GT Vert, 02 GT Vert
Location: Panama City, FL
Posts: 1,214
Default

Replace any fuses and/or relays for the lights in either fuse box. Something may be getting hot and causing an open condition.
__________________
AzPete
Retired USAF
Panama City, Fl.
I wake up in the morning with nothing to do and by supper time, I have half of it done.

2008 GT Vert, stock
2000 Lightning, s/c, tuned, Basanni, built tranny
Previous Mustangs:4 - '66 Coupes(silver/blue/grey/red) '87 GT HO, '00/'02/'07 GT Vert(red)(grey)(black), '68 Coupe, '11 GT/CS
AzPete is offline   Reply With Quote
Old 12-03-2013, 02:16 PM   #3
aframe
2nd Gear Member
 
Join Date: Nov 2008
Vehicle: 2003 GT VERT
Location: illinois
Posts: 172
Default

Did you ever get the problem fixed i have the same car with the same problem
aframe is offline   Reply With Quote
Old 12-03-2013, 02:16 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:27 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup