Mach 1 Ticking Noise At Idle - MustangForums.com



Mach 1 Section This section is for discussions relating to the reincarnation of the Mach 1 trimline.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-17-2017, 04:57 AM   #1
JROCars
Thread Starter
 
Join Date: Dec 2016
Location: Illinois
Posts: 7
Default Mach 1 Ticking Noise At Idle

So my 2003 Mach 1 has a ticking noise when idling. Some people after listening to it thought it was an engine knock, but the reason I don't believe its a knock is because once I start pushing in the clutch, even if its not fully depressed, the ticking goes away completely. Someone also said it could be an exhaust leak, but the fact that the ticking goes away when I push in the clutch leads me to believe that its something in the drivetrain. We recently got a new clutch in the car, and ive been told that the throwout bearings that come with aftermarket clutches can go bad pretty fast? I don't know a ton about this stuff, just enough to get by. So if anyone has any input let me know!

Also side note: the ticking used to be a sort of squeaking noise, so we took it to the shop and they lubed up the throwout bearing and the noise went away. Now its back, in the same pattern, but a ticking rather than a squeaking. Any and all input is appreciated! Thank you
JROCars is offline   Reply With Quote
Old 01-17-2017, 12:34 PM   #2
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,317
Default

Sounds like something in throw out bearing. If it's recently been replaced I would give them a shout out to whoever installed it.
movielover40 is offline   Reply With Quote
Old 01-19-2017, 03:48 PM   #3
C1Forged
Sponsor
 
Join Date: Jun 2016
Location: California
Posts: 107
Default

If its a tick similar to rod knock, it could be your transmission. Had a similar noise in a WRX, drained the transmission fluid and found a chipped tooth from what ended up being 2nd gear.
C1Forged is offline   Reply With Quote
Old 01-20-2017, 06:31 PM   #4
Camster
2nd Gear Member
 
Join Date: Apr 2014
Location: NY
Posts: 458
Default

Quote:
Originally Posted by movielover40 View Post
Sounds like something in throw out bearing. If it's recently been replaced I would give them a shout out to whoever installed it.
Agreed.
Camster is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:56 PM.