Go Back   MustangForums.com > Members
Sign in using an external account
Register Forgot Password?
Search


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


RyanPR RyanPR is offline

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Hoose84
    05-26-2011 10:50 PM
    Hoose84
    Hey, was looking over old posts and was curious what ever happened with your transmission problem. I'm up to 102k miles and the problem is the same, never gets worse or better other than better in winter worse in summer. I have the T50D too.

About Me

  • Personal Information
    State
    OH
  • Vehicle Information
    Year, Make, Model
    05
    Forced Induction Setup
    Nitrous Oxide

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 02-12-2014 05:51 PM
  • Join Date: 10-16-2008
  • Referrals: 0
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 06:47 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup