Search

Go Back   MustangForums.com > Members
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


stangelmer stangelmer is offline

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. stangelmer
    08-24-2011 08:55 PM
    stangelmer
    I had it apart today when I was replacing the thermostat and I looked down in the radiator and it has absolutely no build up at all from what I can see, and I have done 2 flushes on the system and both times they were clean, no corrosion at all. I am really starting to think it is something electrical. Because I put a new water pump in it 2 weeks ago when it started leaking from the weep hole, new thermostat and the radiator is clean and all the hoses are new. It only seems to run hot when I turn on the ac and am driving, I can let it idle in the parking lot for an hour with the ac on and it doesn't get hot(did that this mourning after replacing the thermostat)
  2. GIXER7502006
    08-24-2011 01:22 PM
    GIXER7502006
    Ive ran into that problem b 4 with cars over heating with the a/c on and it is useally the first sign that yur radiator is plugging up, didnt know if u fixed the problem or not yet
    good luck

About Me

  • Personal Information
    State
    Florida
  • Vehicle Information
    Year, Make, Model
    1994, Ford Mustang GT

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 09-06-2011 11:03 PM
  • Join Date: 08-26-2010
  • Referrals: 0

Garage

stangelmer has no vehicles in the garage
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 10:41 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup