- View Profile: Robb03

Go Back > Members

Robb03 Robb03 is offline

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. TRMach1
    07-03-2014 10:25 PM
    Lol its been a year later and I never heard anything from them, now I have 22k miles on the car. I noticed that it only happens after an oil change but after 200-300 miles of driving it goes away so I just left it, I just did an oil change last week and once again it was back. I drove a couple of hundred miles and once again it's gone. Mine isn't too loud, I mean you can hear it but you have to pay attention to it otherwise you won't notice it. At drive trus you can hear it but like I said once I drive it for a while with the new oil in it the ticking goes away. I don't worry about it anymore, my car doesn't have any problems and it has actually ran pretty strong compared to other 5.0s and like I said now I know that once I change the oil the ticking will go away after driving for a bit.

    Sorry I never check the messages on here.
  2. TRMach1
    07-03-2014 10:25 PM
    I took it in to the dealer and they acknowledge that there was a ticking but supposedly ford told them to put it back together and that I could drive it while they investigated the situation.

About Me

  • About Robb03
  • Personal Information
  • Vehicle Information
    Year, Make, Model
    2013 Mustang GT


Total Posts
Visitor Messages
General Information
  • Last Activity: 06-13-2014 12:39 PM
  • Join Date: 02-13-2014
  • Referrals: 0

All times are GMT -5. The time now is 06:44 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company