84 (or 85) Mustang GT 302 HO - MustangForums.com


Go Back   MustangForums.com > General Mustang Forums > New Member Area
Sign in using an external account
Register Forgot Password?
Search


New Member Area Are you new to Mustang Forums? WELCOME! Check in, tell us about yourself and your ride.
Sponsored by American Muscle


84 (or 85) Mustang GT 302 HO

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-09-2014, 08:36 AM   #1
Kingsley69
 
Kingsley69's Avatar
 
Join Date: Jul 2014
Vehicle: 1984 Ford Mustang GT
Location: Michigan
Posts: 3
Default 84 (or 85) Mustang GT 302 HO

Just bought this car a couple weeks ago. Title says it's an 84. Someone told me the VIN has an E, so it's an 85. Any thoughts? I want to add some juice. Bought a Flamethrower coil, Dist cap & rotor. Cap fits, rotor doesn't. I figured I should increase plug gap due to hotter coil, so I gapped them at .054. Literally just guessed at that. Should I bite the bullet & get a performance full distributor? Maybe an ignition module? Holly 4 has the choke zip tied and taped. Not sure what that's all about. Plug wires are pretty good performance, plugs are basic. Anyone have any advice?
Kingsley69 is offline   Reply With Quote
Old 07-09-2014, 03:23 PM   #2
05 Mustang
6th Gear Member
 
Join Date: Sep 2006
Vehicle: 2012 BOSS 302
Location: Canton, Georgia
Posts: 10,990
2012_CO_BOSS_302
Default

welcome
__________________

2012 BOSS 302
Competiton Orange/Black

1 of 67 (Car Cover, Floor Mats, No Recaros)
#0614 of 3250 (Overall)

Procharger Stage II (Powdercoated Black) l 20x9 & 20x11 Gloss Black Forgrstar F14's l 255/35/20 & 305/30/20 Pirelli P-Zero Tires l Eibach Sportlines l BMR Adjustable Panhard Bar l MMD Hood Struts l Shorty Antenna (AntennaX.com)
05 Mustang is offline   Reply With Quote
Old 07-10-2014, 06:23 AM   #3
88 orangepeel notch
5th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Vehicle: 1988 notchback
Location: Wisconsin
Posts: 3,052
Default

Welcome, congrats on the fox purchase. Gears for the rearend would be my first mod after you get her running good. Biggest bang for the buck.
__________________
306 with all bolt ons, letter cam, ported E7's, T5 swap, full exhaust, 3:55's, 2" drop, and the worst paint you'll ever see or feel.
Dyno'd 300/316, 2745lbs-track scale
Best ET………12.4@108, 1.66 60ft on 8" ET Drags.

88 orangepeel notch is online now   Reply With Quote
Old 07-11-2014, 12:32 PM   #4
96t-bird
4th Gear Member
 
96t-bird's Avatar
 
Join Date: Jan 2011
Vehicle: 01,Mustang,GT
Location: NC
Posts: 1,915
Default

Welcome. Post your questions in tech section. You will get more members to respond.
__________________
01 GT, True Blue,auto,CAI,CDC shaker,70MM TB,PP upper intake,PP Typhoon lower intake,21 lb injectors,Blue Hi-temp hoses,Steeda coil springs,Koni struts,stock sub-frame connectors,Flowmaster catback,Mach 1 delete grill Member #120
96t-bird is offline   Reply With Quote
Old 07-12-2014, 01:24 AM   #5
jimkaray
4th Gear Member
 
jimkaray's Avatar
 
Join Date: Aug 2007
Vehicle: 2005 Ford Mustang Coupe
Location: Stroudsburg, PA
Posts: 1,102
Default

Quote:
Originally Posted by Kingsley69 View Post
Just bought this car a couple weeks ago. Title says it's an 84. Someone told me the VIN has an E, so it's an 85. Any thoughts? I want to add some juice. Bought a Flamethrower coil, Dist cap & rotor. Cap fits, rotor doesn't. I figured I should increase plug gap due to hotter coil, so I gapped them at .054. Literally just guessed at that. Should I bite the bullet & get a performance full distributor? Maybe an ignition module? Holly 4 has the choke zip tied and taped. Not sure what that's all about. Plug wires are pretty good performance, plugs are basic. Anyone have any advice?
Welcome! E is for 84 it seems...vin decoder
__________________
'05 4.0: G-Force T-5, MGW Shifter; VMP MAF/ CAI/93oct N2O Tun; CHE K-Brace & Torque Limiters, Rr Ctrl Arm; Shorty Headers; Centerforce Pressure Plate, McLeod DF clutch, Adj Slave Cyl; 8.8" 4:10's w/ T-Lok; Coast Alum D/S; FRPP Dual Ex; 18" Bullitts; CF Hood; Rr Louvers; SS Gen 1 Frt Cover. ZEX N2O - 100 shot bests: 1/4mi ET 13.495/MPH 103.95 (*only mods were VMP N2O tune & CAI; shorties w/ duals; t-lok).

Last edited by jimkaray; 07-12-2014 at 01:28 AM. Reason: correcting post
jimkaray is offline   Reply With Quote
Old 07-12-2014, 08:17 PM   #6
Soldier GT
6th Gear Member
 
Soldier GT's Avatar
 
Join Date: Aug 2007
Vehicle: 2003 Ford Mustang GT
Location: MO/ Born and raised in Louisiana
Posts: 10,392
Default

Welcome!
__________________



Vortech V-1 T Trim SC (intercooled), MMR 900 Short Block, CMS Stage 1 blower cams, MHS Stage 1 heads, eddy Vic jr intake, 6061 plenum, FRPP 410's, Flowtech LT's, MGW STS, Nitto NT555 DR's (305/35-18)

524 RWHP/465 RWTQ. Tuned by Bob Monks, STL Mustangs
Soldier GT is online now   Reply With Quote
Old 07-13-2014, 07:54 PM   #7
2005Redfire6
6th Gear Member
 
Join Date: Jul 2008
Vehicle: 2005 Mustang
Location: Acworth, GA
Posts: 12,257
Default

Welcome
__________________
Eddie
Livernois 298 stroker
2005Redfire6 is offline   Reply With Quote
Old 07-16-2014, 07:34 PM   #8
Stang BB
2nd Gear Member
 
Stang BB's Avatar
 
Join Date: Apr 2014
Vehicle: 05, Ford. Mustang
Location: Washington
Posts: 275
Default

Welcome.
__________________


BBK Titanium CAI, Magnaflow exhaust, Hurst short shifter
Stang BB is offline   Reply With Quote
Old 07-17-2014, 07:00 AM   #9
Kingsley69
 
Kingsley69's Avatar
 
Join Date: Jul 2014
Vehicle: 1984 Ford Mustang GT
Location: Michigan
Posts: 3
Default

Thanks for the decoder. Very handy!
Kingsley69 is offline   Reply With Quote
Old 08-01-2014, 09:18 AM   #10
Kingsley69
 
Kingsley69's Avatar
 
Join Date: Jul 2014
Vehicle: 1984 Ford Mustang GT
Location: Michigan
Posts: 3
Default Update - electrical stuggles

So far I have added battery, coil, dist, ignition mod, Edelbrock 650, alternator, brakes, shocks/struts, tires. I am not getting as much of a boost as I thought I would get. Now, I am having trouble with the battery not charging. Apparently, this is not uncommon as I have seen several entries on blogs with the same basic scenarios. One guy went through tons of time & expense & it ended up being a fuse. I checked all mine last night and they're all fine. Any thoughts??
Kingsley69 is offline   Reply With Quote

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 
Advertising
Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:54 AM.>

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup