What oil do you use? - Page 2 - MustangForums.com


Off Topic A place for you car junkies to boldly post off topic.
Sponsored by American Muscle


Reply
 
 
 
Thread Tools Search this Thread
Old 08-20-2014, 11:11 PM   #11
rmodel65
Yukon Cornelius
 
rmodel65's Avatar
 
Join Date: Oct 2005
Location: deep in the heart of dixie GEORGIA
Posts: 11,721
Default

could definitely be the fuel pump. or maybe just the drain back valve failing. try turning the key on and off a few times and see if it starts quicker. if you do replace the pump only buy an OEM motorcraft or a Walbro. if you buy any cheap pumps it will last about a month or maybe 3 if youre lucky
rmodel65 is offline   Reply With Quote
Old 08-21-2014, 07:22 AM   #12
fastbackford351
Foghorn Leghorn
 
fastbackford351's Avatar
 
Join Date: Dec 2006
Location: I reside in a near constant state of amazment.
Posts: 2,583
Default

Motorcraft synthetic blend.


For lawnmowers and small engines 30W non detergent.
fastbackford351 is offline   Reply With Quote
Old 08-21-2014, 07:46 AM   #13
audioAl
4th Gear Member
 
audioAl's Avatar
 
Join Date: Mar 2012
Location: Texas
Posts: 1,001
Default

I use 5 qt of Castrol Edge & 1 qt of Lucas oil synthetic stabilizer. I need to change mine in the 2014 as I just turned 5,000 miles.
audioAl is offline   Reply With Quote
Old 08-21-2014, 10:49 AM   #14
Mishri
Mish-ogynist
 
Mishri's Avatar
 
Join Date: Nov 2007
Location: Great Falls, MT
Posts: 3,754
Default

I use mobil 1. Motorcraft is supposed to be good too.

I use 5w-20. Why? because the difference between 5w-20 and 5w-30 is like 8 degrees. unless you have a precise thermometer you wont know which works best, but they both work well in the 190-210 temp range. So it doesn't really matter anyway.

I should use something like 10w or 15w being so cold here, but I only change my oil once per year in the spring, I don't drive it much. (Drive the truck more in the winter).
Mishri is offline   Reply With Quote
Old 08-21-2014, 12:21 PM   #15
akiba17
Not 100% a dick
 
akiba17's Avatar
 
Join Date: Jun 2009
Location: Texas
Posts: 878
Default

You should still change it bi yearly Mish.
akiba17 is offline   Reply With Quote
Old 08-21-2014, 12:38 PM   #16
Tubra
2nd Gear Member
 
Tubra's Avatar
 
Join Date: Sep 2006
Location: .
Posts: 282
Default

Used to use mobil 1, when I got my '12 GT I decided to try Royal Purple and noticed an improved overall smoothness and bump in power. I wanted to go for amsoil, but it was difficult to find.
Tubra is offline   Reply With Quote
Old 08-21-2014, 01:15 PM   #17
Mishri
Mish-ogynist
 
Mishri's Avatar
 
Join Date: Nov 2007
Location: Great Falls, MT
Posts: 3,754
Default

Quote:
Originally Posted by akiba17 View Post
You should still change it bi yearly Mish.
http://www.fordservicecontent.com/Fo.../11musog1e.pdf

1 year or 10,000 miles is the recommended oil change interval noob. I only have like 11,000 miles and owned it for 3 years. No way would I change oil after 1,500 miles.. tis silly.
Mishri is offline   Reply With Quote
Old 08-21-2014, 02:55 PM   #18
Derf00
6th Gear Member
 
Join Date: Feb 2005
Location: AZ
Posts: 10,469
Default

Quote:
Originally Posted by Mishri View Post
I use mobil 1. Motorcraft is supposed to be good too.

I use 5w-20. Why? because the difference between 5w-20 and 5w-30 is like 8 degrees. unless you have a precise thermometer you wont know which works best, but they both work well in the 190-210 temp range. So it doesn't really matter anyway.

I should use something like 10w or 15w being so cold here, but I only change my oil once per year in the spring, I don't drive it much. (Drive the truck more in the winter).
You got it backwards Mishri. The colder the temp, the lower the first number should be.
Derf00 is offline   Reply With Quote
Old 08-21-2014, 02:59 PM   #19
HRnB
Administrator
 
HRnB's Avatar
 
Join Date: Dec 2003
Location: Southern California
Posts: 25,078
Default

That's because Mishri is an idiot savant.
HRnB is offline   Reply With Quote
Old 08-21-2014, 03:00 PM   #20
Derf00
6th Gear Member
 
Join Date: Feb 2005
Location: AZ
Posts: 10,469
Default

Touche.
Derf00 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need to rebuild the automatic transmission 1996 GT wraith777 General Tech 1 09-28-2015 11:49 AM
Ticking coming from 4.6L. What could it be? Shadow7874 2005-2014 Mustangs 4 09-24-2015 10:06 PM
Oil change belam Oil and Oil Related Topics 4 09-24-2015 12:29 AM
Need Help ??? Demodulates General Tech 2 09-18-2015 12:14 PM
JLT III CAI cleaning, do I re-oil? kevsgt GT S197 General Discussion 1 09-09-2015 07:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:42 AM.