Search

Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 5 of 5
Search took 0.02 seconds.
Search: Posts Made By: TripleG
Forum: 5.0L (1979-1995) Mustang 05-04-2013, 08:16 PM
Replies: 11
Views: 703
Posted By TripleG
Well, the noise is gone for now. I opened up the...

Well, the noise is gone for now. I opened up the valve cover, everything appeared to be in good condition. Taking the lifter direction, I found a video with a similar sound and lifters in the...
Forum: 5.0L (1979-1995) Mustang 05-04-2013, 05:41 PM
Replies: 11
Views: 703
Posted By TripleG
found a great video on the youtube about lifter...

found a great video on the youtube about lifter noise. Going to try the engine flush technique and see if that alleviates the problem. Thanks for the direction.
Forum: 5.0L (1979-1995) Mustang 05-04-2013, 04:59 PM
Replies: 11
Views: 703
Posted By TripleG
Got the valve cover off and the rocker arms and...

Got the valve cover off and the rocker arms and push rods look ok. Any specific way to inspect these besides visual and checking the security of the components?
Forum: 5.0L (1979-1995) Mustang 05-03-2013, 05:38 PM
Replies: 11
Views: 703
Posted By TripleG
In video 1, when the car gets close to dying,...

In video 1, when the car gets close to dying, that was me pushing on the throttle housing in the opposite direction...
Forum: 5.0L (1979-1995) Mustang 05-03-2013, 05:35 PM
Replies: 11
Views: 703
Posted By TripleG
Something is definitely Wrong... '91 GT

I have a 91 GT that recently developed this loud annoying sound on startup. I have searched the net and some people have mentioned a Camshaft Position Sensor...but none specifically for a foxbody...
Showing results 1 to 5 of 5

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 06:28 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup