Search

Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 2 of 2
Search took 0.01 seconds.
Search: Posts Made By: dz01
Forum: 5.0L (1979-1995) Mustang 04-23-2014, 04:51 PM
Replies: 3
Views: 438
Posted By dz01
I'm not sure why. Maybe RMPs were up high enough...

I'm not sure why. Maybe RMPs were up high enough that it went in pretty easily.

Yeah it sucked, and was loud!
Forum: 5.0L (1979-1995) Mustang 04-23-2014, 12:26 PM
Replies: 3
Views: 438
Posted By dz01
1993 5.0 Mis Shifted- 1st Instead Of 3rd!

No idea how I did this, but I tach'ed out first and second and instead of grabbing third, I put it back in 1st! Rear wheels hopped and I'm sure I sent the tach into orbit. I'm pissed I did this and...
Showing results 1 to 2 of 2

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 01:27 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup