Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 25 of 120
Search took 0.32 seconds.
Search: Posts Made By: 7 UP Mustang
Forum: GT S197 General Discussion 05-09-2014, 09:06 AM
Replies: 11
Views: 1,021
Posted By 7 UP Mustang
Steve did you check the cabin filter?

Steve did you check the cabin filter?
Forum: 4.6L V8 Technical Discussions 03-28-2014, 10:20 AM
Replies: 24
Views: 1,801
Posted By 7 UP Mustang
Sounds like a lifter problem, but it might be an...

Sounds like a lifter problem, but it might be an exhaust leak around the front part of the car. Also 5W-20 sounds like it might be too thin. What does the manual recommend for the oil. Good luck!
Forum: 4.6L V8 Technical Discussions 03-21-2014, 09:47 AM
Replies: 5
Views: 479
Posted By 7 UP Mustang
Sounds like you might need a front end alignment...

Sounds like you might need a front end alignment and balance job. In the mean time check for bent rims up front. Jack up the front end and spin the wheels to see if there is any deviation from true....
Forum: 5.0L (1979-1995) Mustang 06-12-2013, 04:29 PM
Replies: 17
Views: 1,095
Posted By 7 UP Mustang
I used a oil can that has the built in pump, and...

I used a oil can that has the built in pump, and just squeezed in about two pumps in each plug hole. Sounds like you lost the sealing effect of the rings due to getting too hot, and burning the oil...
Forum: 5.0L (1979-1995) Mustang 06-12-2013, 10:53 AM
Replies: 17
Views: 1,095
Posted By 7 UP Mustang
You might try this old trick! Take the plugs back...

You might try this old trick! Take the plugs back out, and squirt some motor oil into each plug hole. Crank it over about twice to spread the oil around, and redo your compression check!

Good...
Forum: 2005 - 2014 Mustangs 06-02-2013, 10:05 AM
Replies: 2
Views: 388
Posted By 7 UP Mustang
I am assuming the top is in good condition, and...

I am assuming the top is in good condition, and the rear window is still properly sealed. Check the drain tubes for the top. You have one on each side under the rear area near the tires. If you park...
Forum: 4.6L (1996-2004 Modular) Mustang 05-29-2013, 07:39 PM
Replies: 12
Views: 580
Posted By 7 UP Mustang
Yes pull the driver's side door panel, and check...

Yes pull the driver's side door panel, and check the master up and down switch. Make sure you are getting power to the switch and then that it is going out of the switch. . Very unlikely both motors...
Forum: V6 S197 General Discussion 05-23-2013, 02:02 PM
Replies: 11
Views: 704
Posted By 7 UP Mustang
Did you replace the radiator pressure cap? You...

Did you replace the radiator pressure cap? You said you replaced the reservoir cap, I guess you mean the over flow reservoir cap. Could be a bad pressure cap or the radiator is restricted due to...
Forum: 5.0L (1979-1995) Mustang 05-15-2013, 05:16 PM
Replies: 2
Views: 429
Posted By 7 UP Mustang
Check the wiper switch and or wiring up to the...

Check the wiper switch and or wiring up to the wiper relay. Sounds like the relay is being energized all the time. If so the new relay will do the same thing.

Good Luck!
Larry
Forum: 5.0L (1979-1995) Mustang 05-13-2013, 04:03 PM
Replies: 6
Views: 526
Posted By 7 UP Mustang
MY old 7 UP Convertible had a broken rear window...

MY old 7 UP Convertible had a broken rear window for a couple of years before I replace the complete top and window. The only time we drove it was during nice weather with the top down. While it was...
Forum: 5.0L (1979-1995) Mustang 05-10-2013, 04:27 PM
Replies: 15
Views: 571
Posted By 7 UP Mustang
MY top motor was completely dead with the bad...

MY top motor was completely dead with the bad brushes. They had worm down so far that they did not make the connection to the commutator pat of the armature. Motor still works to this day!

Good...
Forum: V6 (1994-2004) Mustangs 05-10-2013, 10:21 AM
Replies: 4
Views: 828
Posted By 7 UP Mustang
Did you do a good visual inspection to make sure...

Did you do a good visual inspection to make sure there is no corrosion on the sockets? Maybe remove all the bulbs for the brake lights as it could be a bad socket. Definitely drawing too much current...
Forum: 5.0L (1979-1995) Mustang 05-09-2013, 03:23 PM
Replies: 15
Views: 571
Posted By 7 UP Mustang
The UP and DOWN relays are back in the top...

The UP and DOWN relays are back in the top compartment. You can get to them by going into the trunk, and removing that cover that protects the top motor parts. If I recall the spare tire cover and...
Forum: 5.0L (1979-1995) Mustang 05-08-2013, 09:12 PM
Replies: 15
Views: 571
Posted By 7 UP Mustang
On my 7 UP Mustang I had a bad relay one time,...

On my 7 UP Mustang I had a bad relay one time, and the brushes were worn out another time. I swapped the relays around to verify that one was bad. You might try that since the relays just plug in and...
Forum: 4.6L (1996-2004 Modular) Mustang 05-04-2013, 09:40 AM
Replies: 14
Views: 986
Posted By 7 UP Mustang
You do not have to remove the drain pan. There is...

You do not have to remove the drain pan. There is an over sized thread cutting bolt you can screw back into the oil pan. There is a link below that explains it in detail. Good luck!

Fixing A...
Forum: Classic Mustangs (Tech) 05-02-2013, 09:35 AM
Replies: 7
Views: 576
Posted By 7 UP Mustang
IT has been a long time since I replaced points,...

IT has been a long time since I replaced points, but sounds like they were not set properly.
Forum: 5.0L (1979-1995) Mustang 04-30-2013, 05:03 PM
Replies: 4
Views: 328
Posted By 7 UP Mustang
I had some bad brushes inside my motor. They had...

I had some bad brushes inside my motor. They had worn down so bad that the power was not getting to the armature. Ford does not sell new brushes but I did make a set that I had to custom fit, and...
Forum: 5.0L (1979-1995) Mustang 04-29-2013, 11:23 AM
Replies: 16
Views: 3,424
Posted By 7 UP Mustang
MY 1990 LX has two relays, and one went out. The...

MY 1990 LX has two relays, and one went out. The easy thing to do is to swap the relays around since they are plug in types. One is used for UP and one is used for DOWN. In my case a new relay fixed...
Forum: V6 S197 General Discussion 03-24-2013, 04:40 PM
Replies: 261
Views: 16,532
Posted By 7 UP Mustang
I just might be the oldest ONE here! So much fun...

I just might be the oldest ONE here! So much fun not owning a Grandpa car. We have had 3 Mustang Convertibles and we love our new, 2013, FGB Premium V6. It has all the goodies I wanted to put on the...
Forum: 4.6L General Discussion 07-07-2012, 11:17 AM
Replies: 9
Views: 796
Posted By 7 UP Mustang
This is not an easy problem, but you have to...

This is not an easy problem, but you have to start some place troubleshooting. When it is running "hot" is the fan still running or perhaps it is cutting off too soon. Another thing to check is the...
Forum: 2005 - 2014 Mustangs 06-29-2012, 10:31 AM
Replies: 66
Views: 2,930
Posted By 7 UP Mustang
Heck no you are never too OLD! It is all a state...

Heck no you are never too OLD! It is all a state of mind, and I take a lot of pride in NOT driving a Grandpa car! I love the sound of the Flo Masters on my 1990 LX 5.0. By the way I am 73!! LOL!
Forum: 5.0L (1979-1995) Mustang 05-05-2012, 11:13 AM
Replies: 52
Views: 6,782
Posted By 7 UP Mustang
Unfortunately I gave my Chilton Manual to my...

Unfortunately I gave my Chilton Manual to my daughter who now owns our old 7 UP Mustang. I wanted to keep it in the family! Google and you will find all kinds of info on the TPS.

This was one...
Forum: 5.0L (1979-1995) Mustang 05-05-2012, 10:41 AM
Replies: 52
Views: 6,782
Posted By 7 UP Mustang
I had the same problem with my 1990 5.0. Try the...

I had the same problem with my 1990 5.0. Try the throttle position sensor that tells the computer where the throttle is setting at. If it is defective car will not start. Good luck!
Forum: Convertible Tech 01-11-2012, 11:02 AM
Replies: 8
Views: 1,538
Posted By 7 UP Mustang
I had the same problem on the passenger side up...

I had the same problem on the passenger side up around the latch area on my 09 Convertible. Drove me up the wall as I cannot stand that sort of noise. Mine turned out to be the sun visor. I added a...
Forum: 4.6L (1996-2004 Modular) Mustang 08-01-2010, 09:53 AM
Replies: 9
Views: 1,430
Posted By 7 UP Mustang
Do you have the radio or stereo turned on? Make...

Do you have the radio or stereo turned on? Make sure it is not alternator whine coming thru the radio system.
Showing results 1 to 25 of 120

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 12:33 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup